Welcome to discussions

Quick Suggestions

  • AIG1860
    1 posts

    1.04,still have the same problem.after finding the paint the quest does not switch over to turning paint in.Luki said nothing and the mission cant go ahead.
    Its really a terrible bug , after half month working still no solution.why???

  • jee54
    1 posts

    This is just ridiculous. There are so many major bugs in this game, were a lot of players cant progress in multiple storylines. Ubisoft toon there sweet time for the newest patchwork and in fixed next to NOTHING! for me its just the big finish that is bugged right now, but i came across more. Luckily i manual save frequentie nog. But Ubisoft if this is your idea of how to give a good customer service, then you have no idea what you are doing over there. I hope this gets fixed VERY soon.....

  • Lilesjeffrey99
    1 posts

    i Don’t know if the quest was supposed to be fixed in the new patch, but it still won’t let me progress any farther. I have tried everything possible to try and fix, but nothing works.

  • F7RON
    2 posts

    @prudcop But listen to yourself, you got 150 hours of fun and enjoyment, a wonderful story, loads of cool stuff to see, and now there is one broken quest because you did things in a way the developers didn't expect. They have said they are working on it, and all you need to do is wait a bit. Your response to all of that is to say you have "the right to be upset" and you say we deserve "a complete unbroken game" but all you are missing is around 30 minutes of gameplay. The fact that you could play 150 hours means that the game is pretty complete and not all that broken.

    Development is hard man, you could do a thing 1000 times in testing and just not think of doing it the way a user does, and when they do do the thing that triggers a bug it seems so obvious you look like an idioot for missing it.

  • Alpha-Woodzs
    11 posts

    Have you even looked at the patch one mission its a massive amount of issues. What about players that have only have 30 hours in what if I play further have more issues how many hours do I have to play before I can complain?

  • Shovez2009
    2 posts

    Hi the glitch for "the big finish" in asgard is still present, you cannot progress with picking up the paint after entering through the door and killing the enemies, you are able to pickup the crates of paint but thats as far as it gets.
    I must add this is on the PS5

  • APPLE5333
    28 posts

    So they fixed a bunch of stuff with 1.04 but not the bugs that actually prevent people from Finishing the dam game??? X_X Still stuck at the paint also the side quest in Lunden where you have to move the shelves is still bugged where the shelves become unmovable.

  • Wallop5600
    1 posts

    I beat the builder and nothing happened. I was able to leave asgard, but when I returned hoping it would continue the quest it told me to beath the builder again but he was gone I was locked out of the arena and I couldn't travel back to the real world. Had to reload an old save to not lose hours of progress.

  • TigerKnight1
    3 posts

    Even after the update packs 104 still can't finish the big quest still won't progress after pick up paint would like to be to restart the whole mission but doesn't allow please fix like you said would have fixed in patch It is not fixed please make sure you restart the quest

  • Jamesrd98
    1 posts

    Latest update from Ubisoft was 3 days ago saying a fix was been worked on for this. It would be good if we could be informed with progress on the fix or an estimated timescale for implementation.

    I am beginning to lose patience with this game (on PS4) far too many glitches and graphic errors that have stopped me enjoying AC Valhalla.

    Numerous times Evior has become 'trapped' in bushes/ trees/ crevices in rocks etc even getting trapped in rooms where he refuses to 'slide' out though the low narrow openings which is how he entered the rooms.

    All these errors have meant I have had to end the current sessions and start again and with the extremely long load times on this game I am getting sick of it.

    Now I am unable to finish the final quest in Asgard. I cant believe the game has been released in this state. Obviously not tested properly!!

  • Pippo77316
    2 posts

    It's incredible. I have tried everything. I also managed to get Freya killed, as you can see from the screen. But Loky stands on a round terrace and looks up at the sky. I collect the pigment and bring it to the builder but nothing happens. When will you fix this bugs? I don't have time to cancel the whole game up to now. The platform where I play is XBoxSX.


    https://ibb.co/3zTTPJB

  • babbsty2012
    1 posts

    Unable to finish "The Big Finish" quest in Asgard. Trying to find the blue paint which i know where it is..but there is no loki..take the paint to the tower and nothing..wont let me continue the quest..any suggestions?

  • ParadigmFusion
    5 posts

    I am also stuck on "Find the builders paint" playing on PC, Loki is stuck as Freya, I can pick up the paint crate, but the quest doesnt progress passed it.. PLEASE FIX THIS UBI!!! I can not complete the game until its fixed...

  • The_Deceived36
    1 posts

    I've got the same problem. Quest won't continue once I try to deliver the paint.

  • SIc1295
    1 posts

    La missione traccia “cerca il pigmento per il costruttore” trovo la grotta sia apre, combatto i mostri e basta si impalla lì... loki non mi segue e anche se porto la cassetta col pigmento al costruttore non succede niente...
    70 euro di gioco pieno di bug (non è il primo che mi succede) e di errori di sistema (per due volte schermata blu e mi ha chiuso l’applicazione)
    e mai possibile ?

  • bobert338
    4 posts

    Same issue. Went to the cave without loki because the gold icon appeared for ymirs tear, then went to do the cutscene and when we got back to the cave, it glitched and can't progress.

  • k2kmax2
    1 posts

    I'm having a problem where I have defeated the builder and then got stuck inside the shield so I fast traveled out and now I can't get back inside the shield and the quest won't move on and I when I reload and im still stuck in the same predicament

  • bobert338
    4 posts

    Can you guys please patch this? Like seriously? There's hundreds of us on dozens of feeds that can't progress the game. I can't believe I spent $300 on the collectors edition for THIS.

  • meijinsnow
    1 posts

    help my game wont continue the quest after i have found the builders paint it continues to think it hasnt been found

  • lee6653
    1 posts

    Hey all,

    It's now been 2 weeks since the last post and I still cannot complete this missions do we know when they will fix it so we can continue with game?

Suggested Topics