Welcome to discussions

Quick Suggestions

  • worthyy
    9 posts

    For me Loki is standing disguised as Freya at the tower after him opening the door and doing his voicelines. Afterwords he just stands at the door - quest does not trigger then if you teleport away he will vanish, enemies respawn and thats it. I also went in to the cave before starting the quest and could press use on the door so I did that before I got the quest - That might be the possible reason why the quest is bugged.

  • Ubi-Borealis
    Ubisoft Support Staff 3571 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy several fixes for "The Big Finish" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET. The list of fixes includes the following issues:

    • "Defeat the Builder" objective does not complete
    •  Unable to complete "Search for the Builder's paints"


    If you are still encountering issues with "The Big Finish" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue that you are still experiencing in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • TGL-Tanto
    2 posts

    @worthyy i did press the interacts around the door

  • worthyy
    9 posts

    Yeah same here - I think the issue is that since it that trigger is activated it has no failsafe so now it wont trigger again. But we wont know until more people get to this point that uses forum so we can get more people to recognize the bug so ubisoft can fix it. It sucks but all we can do is just leave Asgard until they fix it.

  • worthyy
    9 posts

    Just need to keep this up there - Same issue for me - As I did the same thing as you @Sp4rky201014 - Went underground first to go for the chest as I just thought it was a normal cave - pressed interact with the door nothing happend went to go do the quest - Loki spawned at the door when I went opened the door - killed the dudes, picked up the paint and then nothing.

  • Akorna
    14 posts

    I finished the fight against the "boss" won't spoil... he's dead on the ground, but his lifebar is still there and I'm still locked in his arena, can't fast travel or anything so guess I'll stay here for ever now?

  • Z24
    1 posts

    I am at the step to "Search for the Builder's paint" however, Loki is still disguised as Frayja and not moving from the tower. I worked my way into the cave and "Forced Door" which made the dialogue between Loki and Eivor start. After the door was forced I killed the Jotuns and found the paint. The step did not progress and Loki just stood at the door. I moved the 3 paint crates out and placed them down, no change.

    I then decided to retrace my steps so I ran towards the tower. Along the way, just outside the cave where the trail goes up some stair-looking rocks there is a rogue "Interact" option that appears to be floating with no one near it. Nothing happened when I tried that.

    I decided to reload my auto save which, turns out, the game auto saved at the Loki interaction 6 times so I didn't have one for before the cave. I tried closing out the game and restarting it. To no avail. I tried restarting the Xbox from a hard shutdown, same results. I decided that I would create a second manual save and just reload my manual save from an hour before. I saved my game as a new save then went to load the previous manual save only to find that the new save was now duplicated over both the saves that I had.

    So now I'm stuck with this quest and no way to progress it. Please help.

  • Alteran6
    5 posts

    @ubi-spud
    same problem here.
    Nothing happen after you pick the paint. Quest will not progress before/after you pick the paint.

  • Dycoth
    4 posts

    @tgl-tanto I have the exact same bug, I guess we'll have to wait for a hotfix

  • Dycoth
    4 posts

    @z24 I have the same bug, Loki is just staying near the door and nothing is happening

  • Dycoth
    4 posts

    @rhys_sace Same bug here... Quite annoying, impossible to progress

  • worthyy
    9 posts

    @rhys_sace same bug here

  • JablesRocks
    3 posts

    I too have this bug. If the Asgard questline is story critical this is game breaking.

  • Delboyspencer
    2 posts

    Have you guys taken the paint back to the tower where the builder is?

  • Legion_Hunter
    1 posts

    I've forced opened the door and I'm looking at the paint but it still is saying to search for the paint, Loki is still stuck as freya at the tower and now I can't progress.

  • Subatory
    1 posts

    Hey there, I just finished, the Builder Boss Fight in Asgard.
    Sadly the cutscene isnt loading and Im stuck in the tower and I cant finish this quest even with fast travelling elsewhere.
    It Would be nice if theres a way to fix it or anything, its kinda rough after 20H of playing.

  • THOR099
    2 posts

    The quest “The Big Finish” has bugged out and I cant complete it. Please add a reset quest option and or fix the problem for me. I don’t want to restart the game. I already logged 20hrs into it.

  • ElessarTargarye
    1 posts

    Hello Ubisoft, i have a big problem with paints...... in mission big finish. When i crushed the door with Loki, he helped me in battle, and freeze. No matter, how many times i reload, games or load old saves. He still freezes. This glitch ban me from complete asgard side quests. I moved paints to the tower, but mission is still dead. So i am stuck after 27 h hours played.

    I played on ps4. Version 1.02

  • gtfomyplanet
    1 posts

    Hi, same bug exists on XB, pls patch. I've moved the paint in so many ways already...

  • x_DR_3MO_x
    2 posts

    @thor099 Same, the game doesn't register that I've located the paint and won't trigger the fight even when I bring the paint to the tower. Effectively locking me out of the quest

  • THOR099
    2 posts

    @x_dr_3mo_x

    spend all this money on a game and it’s broken. Disappointed in Ubisoft, I was really hopeful for the game too. Hopefully they will fix it quick and we can enjoy it once more

Suggested Topics

Community Details

40
Online
191.7k
Users
32.2k
Topics
161.4k
Posts