Welcome to discussions

Quick Suggestions

  • fsocietylp
    2 posts

    @thriftyshane I'm having the same issue. I've tried everything from waking from the vision and going back to the quest to restarting the game. Loki has also disappeared from the doorway for me as well. Desperate from a fix for this that doesn't result in having to start the game again!

  • Thriftyshane
    2 posts

    I'm having those exact same things as well. I'm glad I'm not the only one.

  • rhys_sace
    3 posts

    For the step where you need to get the Builders paint, i have located the room, cleared the enemies and found the paint crates, but it will not register that I have found the paint and let me proceed. I have tried re-loading the save, closing the game entirely and leaving to different locations but when I return same thing happens -XSX versiob

  • APPLE5333
    28 posts

    Got to the bit where you need to fetch the Builders paint. When you pick up the paint it is SUPPOSED to trigger Loki to say his voice line then you continue with the paint to the tower. Instead I pick up the paint, Loki just stands still doing nothing and I can't progress. I've tried:

    1. Restarting the game
    2. Reloading an earlier save
    3. Updating my drivers (Something somebody said worked for them when encountering another incompletable quest issue
    4. Bringing all three boxes of paint back to the tower

    NOTHING WORKS. I'm not going to just uninstall the game because Ubisoft can't make a game that's actually completable. Visual bugs, I can understand. The occasional getting stuck on a rock in a falling animation, Sure, I just fast travel out of that anyway so it's fine. But the F Game should be F completable Right??

    ALSO while I'm here, breaking breakable walls under water is stupid. It takes forever for the character to finally hit the wall because ubisoft didn't care enough to fix up the targeting system while underwater. Just make bows usable underwater or something for a quick fix IDK but do SOMETHING.

  • TGL-Tanto
    2 posts

    After fighting the giants under the builder's tower Loki stays outside the door and will not come inside the room.

    The objective "Find the builder's paint" does not go away, even if all three crates are dropped in the middle of the circle.

    Even leaving Asgard and returning does not reset the quest.

  • worthyy
    9 posts

    For me Loki is standing disguised as Freya at the tower after him opening the door and doing his voicelines. Afterwords he just stands at the door - quest does not trigger then if you teleport away he will vanish, enemies respawn and thats it. I also went in to the cave before starting the quest and could press use on the door so I did that before I got the quest - That might be the possible reason why the quest is bugged.

  • TGL-Tanto
    2 posts

    @worthyy i did press the interacts around the door

  • worthyy
    9 posts

    Yeah same here - I think the issue is that since it that trigger is activated it has no failsafe so now it wont trigger again. But we wont know until more people get to this point that uses forum so we can get more people to recognize the bug so ubisoft can fix it. It sucks but all we can do is just leave Asgard until they fix it.

  • worthyy
    9 posts

    Just need to keep this up there - Same issue for me - As I did the same thing as you @Sp4rky201014 - Went underground first to go for the chest as I just thought it was a normal cave - pressed interact with the door nothing happend went to go do the quest - Loki spawned at the door when I went opened the door - killed the dudes, picked up the paint and then nothing.

  • Akorna
    14 posts

    I finished the fight against the "boss" won't spoil... he's dead on the ground, but his lifebar is still there and I'm still locked in his arena, can't fast travel or anything so guess I'll stay here for ever now?

  • Z24
    1 posts

    I am at the step to "Search for the Builder's paint" however, Loki is still disguised as Frayja and not moving from the tower. I worked my way into the cave and "Forced Door" which made the dialogue between Loki and Eivor start. After the door was forced I killed the Jotuns and found the paint. The step did not progress and Loki just stood at the door. I moved the 3 paint crates out and placed them down, no change.

    I then decided to retrace my steps so I ran towards the tower. Along the way, just outside the cave where the trail goes up some stair-looking rocks there is a rogue "Interact" option that appears to be floating with no one near it. Nothing happened when I tried that.

    I decided to reload my auto save which, turns out, the game auto saved at the Loki interaction 6 times so I didn't have one for before the cave. I tried closing out the game and restarting it. To no avail. I tried restarting the Xbox from a hard shutdown, same results. I decided that I would create a second manual save and just reload my manual save from an hour before. I saved my game as a new save then went to load the previous manual save only to find that the new save was now duplicated over both the saves that I had.

    So now I'm stuck with this quest and no way to progress it. Please help.

  • Alteran6
    5 posts

    same problem here.
    Nothing happen after you pick the paint. Quest will not progress before/after you pick the paint.

  • Dycoth
    4 posts

    @tgl-tanto I have the exact same bug, I guess we'll have to wait for a hotfix

  • Dycoth
    4 posts

    @z24 I have the same bug, Loki is just staying near the door and nothing is happening

  • Dycoth
    4 posts

    @rhys_sace Same bug here... Quite annoying, impossible to progress

  • worthyy
    9 posts

    @rhys_sace same bug here

  • JablesRocks
    3 posts

    I too have this bug. If the Asgard questline is story critical this is game breaking.

  • Delboyspencer
    2 posts

    Have you guys taken the paint back to the tower where the builder is?

  • Legion_Hunter
    1 posts

    I've forced opened the door and I'm looking at the paint but it still is saying to search for the paint, Loki is still stuck as freya at the tower and now I can't progress.

  • Subatory
    1 posts

    Hey there, I just finished, the Builder Boss Fight in Asgard.
    Sadly the cutscene isnt loading and Im stuck in the tower and I cant finish this quest even with fast travelling elsewhere.
    It Would be nice if theres a way to fix it or anything, its kinda rough after 20H of playing.

Suggested Topics

Community Details