Welcome to discussions

Quick Suggestions

  • guest-wG590nuH
    1 posts

    @artimas1995 okay go to last save before you killed guards in room. Go to room. Don’t kill guards!!! Sneak in like a tweaker sliding past the cops...get your paint...sneak out. Boom!!

  • GoDodgersGo
    3 posts

    I'm at the point now where I have everything else complete but what's blocked by this bug.
    I think this will be the last ubisoft game I ever buy... the experience and customer support has been so poor....

    I've also lost weapons due to the weapon swap glitch and ubisoft hasn't fixed...
    even people who BOUGHT AND PAID EXTRA for new weapons lost them and no word from ubisoft beyond load a previous save

    At least I know now ---- never to support this developer in the future!

  • rodra06
    1 posts

    Same issue on the PS4. Really hope this gets resolved!

  • guest-lk2cUf2G
    1 posts

    I play on the ps4 platform and after the update patch still having same problem. Has anyone figured out away around this bug?

  • APPLE5333
    28 posts

    Will Ubisoft ever fix the Big Finish bug? and the bugs with side quest in Lunden ( the move the shelves and blue bottles quest )

    Seriously how long do I have to wait to actually finish asgard.

  • guest-jI0uOwqR
    1 posts

    I found what worked for me load the game after the cut scene stare at Loki (freya) there he will change into loki and walk over to the cave kill both deer (enemy) first the walk to the door. LMK if it worked for you.

  • MANAZ_AU
    1 posts

    The door for indre holm (Ymir’s tear) remains locked, ‘the big finish’ quest is finished however doesn’t appear in completed quests. Please help!!

  • Balla_Jazzuz
    100 posts

    @manaz_au You had to open that door through the main quest, because this wealth was only obtainable during/after the Asgard arc. Are you saying this door isn't possible to enter again?
    Or is it the wealth with an underwater entrance north of the island?

  • Jack_Joseph06
    1 posts

    @ubi-spud this was posted on the 13th November. It’s now the 1st December and I’m having the same issue.. what’s going on?

  • clerocktheend
    2 posts

    @guest-ji0uowqr
    way past the cutscene save now.
    can't reproduce the cutscene.
    loki didn't change back.
    i managed to make imposter freya(loki) to the paint location
    it did fight but dead within few strikes by the jotnar

  • Pippo77316
    2 posts

    Why is Ubisoft no longer responding to customers who have encountered this problem? It does not seem to me a behavior in keeping with the software house it represents. At least one: "You guys, sorry but we are working to fix the problem!".
    Come on Ubisoft, make yourself heard!

  • ParadigmFusion
    5 posts

    Im still stuck here too, Ive brought the paint to the tower, Ive brought all 3 crates to the tower, Ive relogged, Ive reinstalled, and Im sure as hell am NOT going to start a new game hoping that it doesnt glitch out again...Ive even loaded saves just before that paticular step and still bugs out, it is the only quest chain I have left to do, and I cant not complete the game until its fixed... cmon Ubi....

  • Alpha-Woodzs
    11 posts

    There is only one fix for the loki issue that I could find is load the save file for asgard before you go into the cave with the issue. As I was looting gold before the mission as most people do I was able to get in that room before the mission and no chest was there and this seems to have caused the issue. It worked but lost massive amounts of time and any one who played on till the end can't see this being any help. I would say that's why there not saying anything as there not going to tell you well in order to get the fix start again some people clocking 160 hours.Its sad this isn't coming from ubisoft Hope it helps some one peace out

  • SpionSlakNL
    3 posts

    @meijinsnow got the same bug even after the patch...

  • SpionSlakNL
    3 posts

    Dear Ubi,

    the game hase so much broken/bugged quest in the overworld & asgard.
    please see to this and fix it. i know you can do better for a 100+ euro game.....

    this goes fot the big finish quest in search of the builders paint. been there since day 1 i mean come on.....

  • Wosek2
    1 posts

    Im also having the same issue, loki just dissapeared 10 seconds after killing the "guards" inside the cave. Cant continue the quest sadly

  • knifefanatic
    1 posts

    How is this bug still an issue, the game has been out for almost a month now and I can't complete this quest, ps4 version

  • fidolfiogato
    4 posts

    @friedriklucas I have the same problem. I got out of Asgard however, when I come back I still have to defeat the builder and the barrier is still up. Can't do anything about it but restart the game and I don't want to; I don't want to lose my progress.

  • fidolfiogato
    4 posts

    @fidolfiogato Please help ubisoft. I am currently playing on the Xbox Series S and very much enjoying the game. This is bad for me... a completionist.

  • linerhead
    3 posts

    Hi guys. Some good news: The Big Finish quest will be fixed in next patch 1.05. This info was posted on several gaming websites today and they suggest that patch will also coming today 02.12.2020. But i haven't found the confirmation about todays release of the patch on any official sources.

    Can someone i mean moderators from Ubi confirm this?

Suggested Topics