ubisoft discussions

Quick Suggestions

  • Natael2
    4 posts

    Same issue here on PS4 with paint bucket. Loki is still disguised as Freya in the centre of the tower and nothing will trigger with the paint crates.

    **Would be nice to know if this is getting a fix soon, since it is affecting A LOT of people in multiple platforms**

  • dahdondon
    1 posts

    I've gotten all the way to the big finish where you look for his paint located the south tower but as I open the door kill the enemies and find the paint it still tells me to find the paint I take up to the tower and it just teleports back please help me ubisoft

  • harryrobo92
    1 posts

    @natael2 Apparently the patch notes for 1.05 say it will be fixed along with other bugs, hopefully its true, had to stop playing because of all the bugs

  • enzo48010
    6 posts

    Hi @tailwind08 ,
    I had the same problem, cant progress after killing the builder, what I did, is re-load where I need to get the paints with loki, I waited for loki to come with me back to the tower, It took some time for him to follow me, but I made sure to have loki with me back to the tower, after defeating the giant builder again, the game progresses after that. The bug must have started back with loki, not changing back, and or at the cave.

  • johnm1875
    1 posts

    Actually embarrassing this bug has been reported almost a month ago and there still isn't a fix. Surely Ubisoft should have accounted for people trying to collect all the wealth and mysteries before completing the story arc! It's quite a common play style. Absolute joke it's caused a game breaking bug.

    It's not as if these games are cheap! People often only buy a new game every couple of months. And this is what they get for buying AC Valhalla. Disappointed.

  • RononDex88
    1 posts

    Still can't get past this mission!!!!

    I'm too far in the game to simply restart it all and Loki has just disappeared.

    Are Ubisoft evening seeing these threads?

  • GONEphishin87
    1 posts

    When is the patch happening or where can you see details of the patch? I have been carrying around a crate of paint for hours! I brought it to heimdall's tower.

  • Nihilathak
    1 posts

    I stucked at the same point. With two lokis and so. I reloaded a savegame with a point befor the quest started and i not discovered the builders hideout. Then i played normal but i didnt run straight to the last yimr tear. After the first cutscene i didnt run straight forward to the hideout, i stopped at loki, a short dialog triggerd, he changed his form and from this point the quest runs without a problem for me. I played on xbox one.

  • Deadgirllwalkin
    2 posts

    Search paint bug, is there any fix to it yet or am i the only one who cant get by it? Ive spent alot of time trying to get it to work and idk.. would love to play out the rest of the game.

  • CGSB2
    2 posts

    Same issue....I bring the paint into the area and it doesn't continue....great!

  • FastSmitty
    28 posts

    Similar issue except it let me fight the builder... then once i beat him i was stuck inside the area......... the patch did not fix this [censored]!

  • FastSmitty
    28 posts

    like the title says. i beat the builder and i am now stuck in the arena.... there was no cut scene afterwards! help!

  • Rarebear69
    1 posts

    having this same issue w the paint boxes. This game is so unforgivably buggy, I feel like I’m playing Unity all over again. There’s literally a new game crashing bug almost every time I play lol

  • FastSmitty
    28 posts

    Different issue for me............. After I beat the Builder it will not allow me to leave the arena. I ended up fast traveling out of the arena but it did not finish the quest chain..... I tried waking up and going back into Asgard and now i cannot fast travel in asgard at all and the quest is not complete.... it tells me to go beat the builder when i go back to beat the builder again the Shield that was holding me in the arena is still there.... there is no builder and the gods are standing outside the arena....... if i could video it i would but i do not know how.... but Ubisoft if you could fix this that would be great... makes me not want to play the game... i bought the expensive version of the game and I have also spent money on some of the packages.,..... if this cannot be fixed i would like a refund.

  • guest-lpM0SjGI
    1 posts

    Im having the same issue 😭

  • FastSmitty
    28 posts

    If i uninstall the game do i lose all my save data? im just thinking if i reinstall it may fix?

  • tommetj
    4 posts

    if players want to go back to the main story, open up the map, and towards the top left there will be a small icon in the shape of an eyeHover over it, and it should say "wake up"Once pressed, players will awake from their dream back in the settlement and faraway from Asgard.

  • liamo_ac
    5 posts

    So as reported by others the big finish Quest is completely broken. Im at the paint but it still says to search for it so it never prompts me to bring it back to the tower. It's been over half a month since first reported.

    Is it going to be fixed anything soon? Or will it be fixed at all? Might be time to refund this game. Way too broken.

    Wasted so much time getting to this point and the thing doesn't even work. So frustrating.

  • bobo2000
    1 posts

    SOLUTION HERE.
    After cut scene where Builder is tricked with fake Freya, fake Freya (loki) will stand by doorway. Stand next to him right after cut scene and until dialogue gets him to change back into loki, then he should follow you towards the cave.
    Quest should continue normally.
    If you run by yourself to the cave, it has already bugged.


  • Gr8ful_Deed
    21 posts

    My game has soft blocked on "The Big Finish" quest. After defeating the builder, no cut scene was triggered, so I was just stuck in the cage. I was able to fast travel to another Asgard location, but that appeared to do more harm than good as now all of my quick saves start at the fast travel location. The option to wake-up is greyed out because the game still thinks I am in the fight. My next earliest hard save was 10 hours previous. I have tried dying and walking back to the tower, but nothing seems to trigger the cutscene or end the quest. Is there any way to abort or restart quests without having a quick save?

Suggested Topics