Welcome to discussions

Quick Suggestions

  • liamo_ac
    5 posts

    I have the builders paint but it won't prompt me to bring it to the tower.

    Any fix? Or is my game just screwed?

  • Gabec1007
    1 posts

    After beating the boss nothing happens, I was stuck inside the barrier, no cut scene or anything, so I fast traveled out of the tower and still nothing. I went back to the tower and the barrier is still up and I can’t get inside of it. Also Thor, Loki and the other characters are stuck in front of the tower clapping, it doesn’t let me interact with them. I was able to wake up out of Asgard but now when i travel back to Asgard, I can’t fast travel nor wake up and the barrier is still up at the tower. I have to reload a saved point to get back to the main game.

  • phiantastisch
    1 posts

    Stuck at "Defeat the builder". Killed him, but the quest didn't register that I finished. Couldn't get out of the "protective" circle he put around me, and my crew outside (Thor, Freya, etc.) just watch and act as though the fight is still going on. Was able to fast-travel out of the circle and now everything is broken: Can't fast-travel within Asgard anymore and I am stuck in the end of the quest. Please fix!!!

  • Trikeree99
    2 posts

    @sp4rky201014 Having the same problems.

    As I read that others tried. I traveled back to the starting map and back to England, then back into Asghar. Did not work.

    I also installed a different language pack and still no changes.

    Also attempted to sneak past the sleeping guards to move the paints back to the tower. I was able to get 2 of the three there. Every time I got the third crate of paint to the tower all three crates respawned back in the cave.

    I also deleted the game and reinstalled. no worky worky...

    I also reloaded older saves and this also didn't work.

    The game is broken and pointless to continue for me.

    I'm going back to my replay on New+ very hard mode of Ghost of Tsushima

  • Gr8ful_Deed
    21 posts

    Adding to the list of complaints. My game has soft blocked on "The Big Finish" quest. After defeating the builder, no cut scene was triggered, so I was just stuck in the cage. I was able to fast travel to another Asgard location, but that appeared to do more harm than good as now all of my quick saves start at the fast travel location. The option to wake-up is greyed out because the game still thinks I am in the fight. My next earliest hard save was 10 hours previous. I have tried dying, going on a murder spree to de-sync, and walking back to the tower, but nothing seems to trigger the cutscene or end the quest, all the while Loki, Thor, and the rest just stand there and clap. Is there any way to abort or restart quests without having a quick save? The irony of being soft blocked on a mission called the big finish is not lost on me.

  • FastSmitty
    28 posts

    @tommetj negative none of the fast travel/ wake up functions work any longer.

  • guest-DP7xsSmS
    1 posts

    same issue here

  • foldenz
    1 posts

    THE BIG FINISH

    I understand that the developers are trying their best, so the big issue must be with the Ubisoft Leadership; under-funding everything, and undermining what creativity and capability that lies in each and every employe, just to gain money for their shareholders.
    Customer support - you need to communicate this to your leaders, and make sure they communicate this further up the chain. Because all of the forums, reddit, discords etc. are FED UP WITH UBISOFT. This is my last purchase from ubi. No more chances, guess Valhalla was the big finish for me.

  • Asthenoth
    1 posts

    Same problem here on PC. Locked at "Locate the paint" objective. Can't finish Asgard. Honestly this should be a number one priority to fix, can't understand this was not patched in the last update.

  • Trikeree99
    2 posts

    @tommetj Fast travel works fine here. However, the story will not progress in either realm.

  • Hyde314
    1 posts

    I went after the Tear before the quest. Couldn't get in so continued on to the quest. I have a Loki who is Freya standing at the bridge. And I have a Loki that showed up in the cave to help me fight. Both Lokis exist. No progression update about finding the paint. Still says something about activity to the south. Gone back and forth, loaded and reloaded, fast traveled and ran all over. Nothing worked.

    This bug has been reported for almost a month and Ubisoft still hasn't fixed this? This is a "game breaking" bug. My last [censored] autosave was hours of progress before. Dumb. I'm not going back and chasing down all of the tears again and other quests. Why has this not been addressed. No need to wait to kick out a bunch of bug fixes. Fix the damn quest, and kick it out so the people stuck like myself can continue on.

  • Dthumpr
    2 posts

    The story will not progress, Stuck on finding paint.

  • Dthumpr
    2 posts

    Still stuck on finding paint.

  • bill245
    2 posts

    I'm Korean. So I don't know the english name of the NPC, but 'she' looks Asian, wife of 'friend of Eivor'(don't know either name of husband).

    Every time I progress the quest, she always died almost end of quest

    Here's youtube link, check the time from 7:45

  • bill245
    2 posts



    Sorry for just link youtube. I don't know the name of NPC, so I link the youtube (time from 7:45)

    I can't progress anymore

  • bobert338
    4 posts

    Are you guys going to fix this yet?

  • Natael2
    4 posts

    @fastsmitty tried it 2 times, did not work.

  • XXBloodBath13XX
    1 posts

    I am also having this issue, is there any possibility of adding a restart quest option like there was in the previous versions of Assassins Creed. I've been stuck on this mission since launch week and it is currently the only quest line that I still need to complete until I've finished all the missions and collected all the collectables.

  • blackfire565
    2 posts

    Just got to this point and same issue, after killing the Jotuns Loki just hangs out by the door and nothing happens when I pick up the paint.
    Just another issue to add to the list with this game.

  • Stratorino
    1 posts

    Dude Ive been trying submiting a ticket about this glitch for weeks, hoping to learn if theyre gonna fix it anytime soon cuz my subsciption about to run out, but everytime I tap on submit my case it keeps showing me this error message.

    undefined

Suggested Topics