Welcome to discussions

Quick Suggestions

  • AierzVDirl
    4 posts

    After killing enemies inside of the cave, mission won't continue.
    Tried few things:
    I go back to England and come back, not fixed.
    Restart the game, not fixed.
    Reload the save point, not fixed.
    Reload the save point before the mission start, not fixed.

    Please fix this, thank you.

  • Ubi-Borealis
    Ubisoft Support Staff 3623 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy several fixes for "The Big Finish" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET. The list of fixes includes the following issues:

    • "Defeat the Builder" objective does not complete
    •  Unable to complete "Search for the Builder's paints"


    If you are still encountering issues with "The Big Finish" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue that you are still experiencing in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • Animeaniac
    1 posts

    @aierzvdirl I'm having the same problem as OP. Upon reload also Loki returns to being Frejya under the tower so he's nowhere near the objective.

  • worthyy
    9 posts

    @delboyspencer Yup brought all three - didnt do anything as Loki is just chilling as freya.

  • worthyy
    9 posts

    @fjallmar You are most likely correct - And im actually shocked that their Q and A didnt find this. Should be an easy spot - Same bug here.

  • worthyy
    9 posts

    @aierzvdirl Same problem here

  • worthyy
    9 posts

    @alteran6 Same issue here - I went in to the cave before I went to do the quest - I managed to trigger some voicelines and also could actuate the door and did so which ofc did nothing - Then went to do the quest - first Loki didnt join me to the cave - then suddenly he was in the cave and helped me open the door - after killing all the enemies inside and taking the paint back nothing happend and it just says "locate the paint" in the quest and Loki went back to the tower and just stands there in his freya illution.

  • fsocietylp
    2 posts

    @ubi-spud same thing happened to me. I'm playing on ps4 and at first when I entered the room and started killing the enemies loki joined in but the quest objective didn't change from Find the paints. Now loki is back at the tower but the door is still open. If I carry the paints to the tower nobody reacts. I can't interact with anybody but the room remains open however the quest objective won't change from Find the paints. All my past saves resulted in the same outcome. I'm currently over 30 hours in so would love a fix that doesn't involve restarting the game. I've tried changing gender, restarting the game and ps4, going back to England and returning and nothing fixes this.

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hi folks! We have reported this issue up to the developers already. Rest assured, it is being looked into. If we need any further information or have information to share, we will let you guys know.

    Official Response
  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey there, thanks for getting in touch! We are aware of this issue and are currently looking in to it. I have also seen similar reports of the progression not working correctly if you interacted with the door in this area before getting to this point.

    No updates as of yet, but rest assured it is a priority!

    Official Response
  • x_DR_3MO_x
    2 posts

    @thor099
    I managed to fix it by reverting to a previous save before the quest started, but I has lost nearly 2 hours of progress. It's still a massive annoyance that they need to fix especiall for the price we paid for it.

  • worthyy
    9 posts

    @ubi-spud Thanks, can I suggest that it gets a sticky note just like the other quest as it seems like it is a pretty common thing.

  • Ownage_gv
    1 posts

    I'm in the same position tried everything

  • D3M0N07
    1 posts

    Anyone facing any problem in The big finish mission ?? soo many bug/glitch, i am facing in this mission. . .

  • ThiccMoses
    1 posts

    lets just hope they fix this issue unlike in odyssey, with its game breaking glitches

  • Rampagesmithy
    1 posts

    I managed to reload from my previous save file and it worked thankfully.

  • Vesgo_Torto
    1 posts

    I got the same exact problem. Loki is still cross dressing as Freyia and the quest doesn't progress even after killing the shape shifting enemies

  • KarmaDash
    7 posts

    While doing this section I've gotten locked out of progression. I found the area easily and went to pick up the paints to bring back but it won't trigger a new cut scene or further tasks. I thought it may have been due to Loki standing at the door and not moving, but after I reloaded the save to this quest, it keep happening except now Loki isn't spawning at all.

    I don't want to 'wake up' just encase this issue will be stuck preventing me from coming back later. Does anybody have a recommendation on what to try or has this happened to you? Ive even fast travelled away to come back, and unchecked/reselected the quest from my list.'

    I've completed all the mysteries and collected all the 'wealth' from this area so this quest line is all I have left to do.

  • games4good
    3 posts

    @karmadash
    You can leave and comeback . I have the same bug

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @games4good Hey folks! Would either of you be able to attach a video of this issue occurring with the quest not triggering the cut scene?

    Official Response
  • Alakfron
    2 posts

    Same problem here. Went to the cave before going to the tower and triggered some voice lines. After the cutscene in the tower the quest has locked up for some reason. Objective is stuck at "Search for the builders paint". Going into the cave, killing the enemies and bringing the paint to the tower does nothing. I've tried restarting the game and leaving asgard then returning. Oddly enough when I return to asgard loki does not come to the cave at all. A fix would be appreciated as I have played for 30+ hours now.

Suggested Topics

Community Details

116
Online
192.0k
Users
32.3k
Topics
161.8k
Posts