Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • bronx516
    11 posts

    so my question for @ubisoft is this new 1.1.1 update will it let us exit asgard if we stuck in this stupid mission? so we can reattempt it upon leaving or even get out of [censored] gard and forget it exists? or will we continue to still be bugged and i sent my save data to you guys and haven't heard nothing yet on it..

    Edit: Players will now be able to use "Wake up" at any time while in Asgard. Previously you had to complete the first quest.

    THIS DOES NOT WORK FOR OUR ISSUE @Ubi-Woofer so now what another month before we don't get a patch for this? this is getting out of hand now..and we get nothing for the wait? im paying 15 a month for your ubisoft connect and i cant even play the game...

  • bronx516
    11 posts
    This post is deleted!
  • wowo213
    7 posts

    For information, the new patch 1.1.1 does not fix the bug we are writing about here

  • bronx516
    11 posts

    @wowo213 yea i just canceled my subscription for ubisoft connect until this get resolved why should i be paying 15 a month and cant play one of your games when it wasn't fully tested.. until they patch this and its officially resolved im not giving them a dime. if this was the only game i was interested in i would ask for a refund but since i did play watch dogs legion i technically used their service so🤷 but for those of us who been waiting for a patch should get some kind of incentive for the trouble.

  • FastSmitty
    18 posts

    @mtsmn send your save files to ubisoft

  • strayzombie
    1 posts

    I just encountered this problem and I think i know why it glitches.

    When you leave with Loki to look for the paint I think you are supposed to "track" him and interact with some footprints along the way.

    I didn't I just went straight for the cave and got glitches.

    I hope this helps the developers fix this glitch.

  • Twolizard
    2 posts

    I am stuck on The big finish as well as everyone else posting here. I beat the builder, but was stuck in the forcefeild. I teleported out and ended up waking up at some point so I could finish the game. When I go back I am unable to teleport as well and am still stuck at this point.

    I also have a bug after I do the quest forge and the flame, where I am unable to fast travel like in asguard. Im not sure if they are related, but I thought I would throw it out there.

    I am unable to send the save files, I wish we could send our ubisoft cloud saves to themselves. I have tried on the ps4 and the ps5 with no luck. Has anyone tried a reinstall of the game? I may try in a couple days if no one has tried that. It should not make a difference, but I'm just waiting on fixes now.

  • Gr8ful_Deed
    10 posts

    @twolizard

    yeah, same here. It was reported to Ubisoft in early December, but they are just reviewing the issue now. It will be a while...

  • Twolizard
    2 posts

    FYI Uninstalling does not help. Too bad we could not just restart the quests.

  • Ubi-Borealis
    Ubisoft Support Staff 144 posts

    Hello all!

    I apologise for the delayed update. Thank you for continuing to update this thread with your experiences with the issues within "The Big Finish."

    As Ubi-Woofer mentioned earlier in this post, the issue regarding bringing the paints to The Builder was marked as resolved in TU 1.1.0. This investigation has now been reopened by the development team for further investigation, as well as the issue regarding the "Defeat The Builder" objective not completing. The development team would like to collect the save files of affected players as part of the investigation. If you play the game on PC/PS4, please can you open a support ticket and submit your save files for investigation. If you have any videos, please feel free to share these as well (please feel free to share videos within the thread if you don't play on PC/PS4).

    Once you have opened up a support ticket, please share your ticket number within this thread so we can ensure all the data is forwarded to the development team. Thank you! 😊

    @wowo213 - Thanks for explaining further for us, and for submitting your save file for further investigation. This, as well as your video, has now been passed on to the development team for further investigation.

    @FastSmitty - Thanks for sharing your ticket number here. I can see that your save file has also been submitted to the development team for further investigation 🙂

    @Twolizard - Have you been able to try the steps on the FAQ linked above to submit your save files? I've found it works best if you transfer your save across to a USB stick, as you can easily make this into a .zip file on your PC.

    Official Response

Community details

64
Online
102.7k
Users
17.1k
Topics
81.0k
Posts