Welcome to discussions

Quick Suggestions

  • GuitarRock59
    1 posts

    @baelzar super helpful and worked, thank you!

  • yoyohoss
    1 posts

    @baelzar its asking me for an activation code, which I don't have even tho i bought the game on epic

  • CimmarianG
    1 posts

    Mine is doing the same. I bought through Epic, I do not have an activation key for Ubisoft connect. Any solutions?

  • chrono2979
    1 posts

    Thanks! Your solution worked for me as well. But something I don't understand is that the Ubisoft Connect client is now downloading another 50GB of data for the game. But the Epic Store already did that. I don't understand...

  • kiltedjock1
    1 posts

    at that point when it asks you for an activation code...close it and relaunch from epic again....worked for me

  • Talthorn
    1 posts

    @baelzar This worked for me. Thank you!

    Also noticed people mentioned they need activation keys even though they bought through epic. I had to log into ubisoft through my epic account to activate. I did this during the download.

  • NickVVB66
    1 posts

    it said it couldn't find de program file.

  • WildHunt
    72 posts

    @chrono2979 That could be related to another issue with the Epic Game Launcher which I recently sent as a support ticket: when you verify files on Epic you may go back a version (I think it sends you back to the launch version). So if you find your game is missing content (missing armor, Yule event ends prematurely) after you have verified your files on Epic, just verify them using Ubisoft Connect and it should bring you back to the current version but this would mean a massive download, it won't just replace a few files.

  • emintd21
    1 posts

    above solution helped me thanks, for activation key you need to download "google authenticator" this program will give you a code. i downloaded it to my smartphone.

  • acidxburn125
    1 posts

    You don't need to redownload the full 50 GB. once the Ubisoft launcher opens on the left side there is locate game files point it at c/program files/epic games/ac Valhalla. and then the update is only about 4GB. hope this helps

Suggested Topics

Community Details