Welcome to discussions

Quick Suggestions

  • hisbeastlyness
    3 posts

    @Ubi-Woofer Do you have any updates from the dev team on what the status of the bug fix is? Many of us are really disheartened due to the amount of time that has passed since this was first reported since there has yet to be any indication other than "we know" that there is a fix in the works for this immersion-breaking bug. Thanks

  • Imcrea
    3 posts

    @Ubi-Woofer ?
    Can we have at least a message like « hi there no new update for the moment i will comment later etc.. » it will be nice this bug is still here since the beginning. Come On

  • Espilce101
    1 posts

    During the Taken for Granted quest (at the part where Randvi wants you to drink with her) i decided to fast travel to another location to finish a story quest and now Randvi just stands by the entrance to the longhouse and I can't interact with her and there is no teal mark for her on the world map. Also, I cannot upgrade my settlement past 80% of level 5. I've done all raids and completed all available alliances before starting the Taken for Granted quest. Has anyone else had this same issue?

  • Font81
    19 posts

    Same issue.

    on PS4

    After completing East Anglia and achieve 3rd alliance I went to Longhouse and spoke to Randvi. The icon for the quest was there in gold.

    Before I started the mission however i spoke to Tove first and completed the carrying the torch quest. Went back to Randvi and start the Taken for Granted and completed it by choosing "Now it´s not the time". All went well, I returned to the longhouse, the option let´s talk about us was available, so i chose to pledge to Oxenefordscire and I just went there to the first viewpoint , a tower on some ruins and collected small chests there, I sync and then saved and left the game to see if it would bug. Loaded the manual saved game and the quest Taken for granted and also the carrying the torch disappeared from completed quests, and Randvi had no option to talk about us, just view the alliance map.

  • SpiffierColt918
    2 posts

    Why is the staff not doing anything about this? I haven't touched this game since 2 months ago from the moment I encountered this bug. I refuse to let this bug dictate how I play.

  • Font81
    19 posts
    This post is deleted!
  • Font81
    19 posts

    I was expecting news from ubisoft support on this matter and stopped playing for a week due to this bug but since day 1 they are still investigating... so I did Taken from Granted again and this time I chose to romance Randvi since we can have 2 strikes and still get the good ending,Same result, the 2 quests (carrying the torch and taken from granted) disappear from completed quests after the loading of the manual save. Tove on both choices (now it´s not the time and romance) is in the tattoo shop. guess no problem with this-But Randvi still has the romance dialogue options...

    As i did a save during the taken for granted quest (before drinking contest) i loaded it and carrying the torch was already gone from completed quests.

  • R4MPZY
    13 posts

    @font81 Yeah.... I had this issue back in mid-November, have dropped the game and been waiting on a fix ever since, i dont think Ubisoft wants me to play the game anymore.

  • KingRogers23
    4 posts

    So disappointed this hasn’t been fixed yet, haven’t touch the game since the 17th of November. I’ve done a good job dodging spoilers up to this point but I know this has an impact on the ending and the story along the way. I don’t want to change the options I want to pick because of a bug. I’m also disgusted support stopped reaching back out to give us updates. Fix your game. I’ve played and beaten every AC game, this series has been a staple for me since I’ve been young, and I’ve always played these games making the decisions I’ve wanted to make. One quest bug may seem trivial to developers but its not to some of the people who love your games.

  • niosanz
    1 posts

    I got this game for Christmas and have encountered the same problem as all of you mention in this thread. In "Taken for Granted" I chose "Now is not the time" because, poor Sigurd; I was willing to wait until the end of the game. But I changed my opinion a few hours of play later, and no autosafe was available, and I discovered this bug too late. I stopped playing too, waiting. And waiting. I thought this would've been solved by now, almost two months since the game was released. I guess we shall wait even more.

  • trickitrules
    11 posts

    Does anyone know whether the Title Update 1.1.1 will fix this issue?

  • Font81
    19 posts


    Guess not.
    I chose to go on with the game, with the "now is not the right time" option. The 2 quests disappear no matter the choice. If you didn´t plan on romancing Randvi spoiler, no difference until that poit, and apparently there´s no problem with Tove interactions. Some players say we can start a romance dialogue at the Forge and the Flame quest spoiler Hope that until i reach that quest they patch this issue...

    Pledged to Oxeneforscire next and completed everything but 1 wealth so far without major problems.... only a minor issue with chipping away quest, that even after completion Strong Soldiers and supply carts still have quest icons troughout the region.

  • R4MPZY
    13 posts

    @font81 I cant even do the quest anymore, the quest simply vanished from my game before i even picked it up. I saved right before Randvi and she had the quest marker. I went to work, came back and the quest marker was gone. So i dont even know if i can still romance Randvi even if i continue the game.

    Thanks Ubisoft for fixing this issue that has been here since mid-November, guess i'll just move on to other games and this will be my last AC game.

  • Zer0524
    10 posts

    so i did this quest yesterday and i have the same problem after reloading my latest checkpoint when i wanted to continue playing today...taken for granted isn't showed in my log of completed quests and i don't have the dialogue option for randvi to romance her..i see this game breaking bug has been a problem for over 2 months and it's not yet fixed...what the hell ubisoft, move!!

    @font81 i did the carrying the torch quest and tove is in the tattoo shop, however i have no option to talk to her..after the latest update lot of players can't talk to her to customize their evior..this is so frustrating, can they hurry up and fix all these issues, i really want to play this game but not like this

  • Zer0524
    10 posts
    This post is deleted!
  • WrightWayUp
    18 posts

    On PS5 v1.1.1 and this is still an ongoing bug/issue. Quest is completed but does not show up in Completed Quests and dialogue options disappear from Randvi on a reload, fast travel etc.

  • Ubi-Woofer
    Ubisoft Support Staff 1061 posts

    Hello everyone,

    I just wanted to check in and reassure you all that this issue remains under investigation, and is not one that we have forgotten about. I sincerely apologise that we were unable to resolve this in the latest patch, as I know the romance options are a significant aspect of the game for many of you, and I will continue to provide you with the latest updates with regard to the investigation as soon as they become available to me.

    Having now finished Valhalla myself, I can confirm that at a later time, romance options with Randvi reopen if having selected "now is not the time" earlier in the story. However, the interactions offered are limited to spoiler and are not on the same scale as those offered by the relationship with Petra for instance (where you can spoiler). If that is not an issue for you, you can progress through the story with the assurance that this option will become available in the end - but if it is, rest assured that for those of you wanting to pursue a romantic relationship in the interim between telling Randvi "now is not the time" and the endgame, the investigation continues into why "Taken for Granted" disappears from the quest log along with the romance dialogue options. 🙂 I would however exercise caution with regard to your decision to romance Randvi - when you choose to do so, together with some other key decisions throughout the story, influences how the endgame goes for you. 👀

    As above, I'll keep you all updated with the investigation, and will share updates from the developers as and when they become available. They are still requesting that videos of the issue, as well as save files from affected players on PC and PS4, are provided for investigation. These can be submitted here in the thread and via a support case respectively. If having issues with opening a case, let me know so that I can assist you directly.

    @KingRogers23 We have not stopped delivering updates - there just has been no update from the developers regarding this issue at present. 😞 We'll keep you all updated with what we know.

    Thank you all again for your continued patience and understanding, and I hope to share some positive news soon! 🙂

    Official Response
  • Hessa882017
    2 posts

    Re: [Randvi romance bug](/topic/83922/randvi-romance-bug)

    I can not romance randvi or petra as female evior
    why/ i even replay the game again but the same problem
    even randvi`s kiss is removed (when she confessed top the tower)

    I really want romance her as the female lead not the male

  • Zer0524
    10 posts

    @ubi-woofer yes i would like to pursue the "now is not the time" option without being limited by the bug so i hope this can be fixed as soon as possible, i see it's an on-going issue for already two months, that's so long:-/ the newest patch made even "carrying the torch" quest disappear from my log of completed quests so i cannot customize evior now. hot fix for these two issues would be nice.

  • hayd014
    2 posts

    My last comment on here was on the 17th November and I have checked to see if the game-breaking bug has been resolved in every update that has been released. Unfortuantly this still seems to be the case. The romantic chat options were not even a possibility for me as the quest had bugged itself during the drinking challenge against randvi. From this I was unable to continue the quest which further dowm the line caused me to be unable to finish the story as after I finished claiming grantbridgeshire I was unable to interact with Randvi at the war table and this is still the case.

    Extremely dissapointed that a game breaking bug like this still hasnt been resolved. Really do regret purchasing this ultimate edition for this game where I was expecting to play the 2 expansions for the game. But since i cant continue in the game where I am i wont be playing the DLC when they ever come out ethier.

Suggested Topics

Community Details