Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • radarred8
    1 posts

    I play on Xbox and killed the right legendary animal to get the skratii face tattoo but instead it gave me petras bow is this a bug or is this a feature, like a rare drop? Also same issue with the legendary trophies except the elk and the wolf.

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts
    Best Answer

    Hello everyone,

    I'm very happy to say that the patch notes for title update 1.1.0 - releasing tomorrow - have now been published, and this issue with the missing legendary animal trophies in the longhouse is an issue fixed in this update! Here's the information provided in the patch notes for your reference:

    Legendary animal trophies will now correctly appear in the Longhouse.

    Thank you all for your continued patience regarding this issue, and for your understanding. I'd also like to once again thank everyone who provided images, videos and accounts of the issue for us to send to the developers; these were instrumental in the investigation and meant that we could get this fix prepared. Should anyone have any questions, further issues or concerns, don't hesitate to get in touch.

    Official Response
  • Dahmzor
    18 posts

    I have killed all of them. Every last one. Worst one to fight was the Pair of Lynx, they are annoying as hell to fight, something I really wanted to see mounted. However even after collecting them all and mounting them, I still only have three of them up.

    But it's not the only thing in game bugged; The hunter collection items are an incompletable set of submissions because of the Black Bear Skin; where are black bears? America.... Vinland. I found three which I fast travelled to respawn, I killed those three, twelve times. I got no bear skins, none, nada, nothing. But even if I did it wouldn't matter, because nothing from Vinland goes back with you.

    I also cannot complete Dobby's alter as no more fabric drops after I upgraded my quiver and ration pouch. Need 5 for the alter that I cannot get. To be clear, I'm at 94% completion and have looted every chest from Norway and England (and Vinland, not that it matters).

    Oh and as a final thought, I really cannot be bothered fishing another 89 times, button bashing every fish to do the fisherman collections. Seriously, every other fisherman gets a rod, and/or a trawler net. We don't even get a spear and a good place to stand, so button bashing with a rope. I thought the "tips" said it was relaxing. And you can jump in and use that crappy axe on your lower back, which seems to stun you after every swing, but that's slower than the rope, for the fish I have handed in, I spent my time herding the fish to the shallows then killing them with a great sword or spear when I could be bothered swapping it in.

  • VanRaposU
    14 posts

    [Update] Yesterday I reloaded the save file I had right before giving the pelts to the tanner and tried again. It worked! Turns out the head is displayed in a wall, close to Eivor's room.
    So, as a hotfix for now I would recommend always saving before giving the pelts, then looking for the trophy in the longhouse. If it's not there, it's possible that reloading the save and trying again do the trick.

  • Abeonis
    55 posts

    A late reply, but I am also having this issue. None of the trophy heads are appearing in the longhouse. Playing on XSX.

  • Lianzareth
    2 posts

    Same here on PC

  • Robster_500
    7 posts

    Good news guys! there will be an update Later this week!!! 🤘

  • RlFFRaff
    3 posts

    I’m having the same problem. Killed the elk and black shuck but no trophies are displayed at the longhouse even though Hunter’s Hut says that they are displayed. Must be a glitch of some sort. Hopefully Ubisoft picks up on it and fixes it. I’m playing with an Xbox one@jcutts23

  • Krilanor
    2 posts

    I have killed 5 or 6. I have only the Bear in my longhouse.

  • NeOVoltron
    95 posts

    I have this bug as well. I have turned in the Elk from Norway but it's not mounted in the longhouse.

  • NeOVoltron
    95 posts

    @robster_500 OMG REALLY?! I hope it will fix this and many other issues.

  • PeacekeeperSun
    27 posts

    So I have finished all legendary and have yet to see any on the walls.
    Side note we shouldn't need to try and find a work around. I didn't pay $120 so I can find work arounds so I can play.
    I'm so sick of forking over $$ to get broken stuff. I'm tired of waiting 1,2 even 3 years for [censored] to finaly be working.

  • MarkTony919
    1 posts

    I’ve killed all of the legendary animals. None of the trophies appeared at my longhouse...please help.

  • Robster_500
    7 posts

    @neovoltron yeah, the twitter page of assassins creed mentioned it. Normally it would be the end of november but they said it will be by the end of this week. Now i don’t know which problems they will solved with this patch, but hey. At least they bring out an update

  • Ibanez921
    19 posts

    @chaosandcoffee

    Looks like I got some bad info on the interwebs then! Sorry for the confusion

  • Ibanez921
    19 posts

    @robster_500

    Very exciting news, but I'm concerned by the fact that Ubisoft hasn't officially acknowledged this trophy bug in any way yet. I've been checking up on their list of confirmed bugs that they have identified and this has been missing from the list for weeks 😞

    I submitted a pretty detailed video of the problem, as I had a recent autosave that I was able to use to recreate and document the bug, but no official response to my ticket after I posted it.

    I think a lot of stuff is definitely going to get fixed in the patch, all the major game breaking quest bugs I think are gonna be their top priority for understandable reasons. Let's just all keep our fingers crossed that they've been working on a fix for the longhouse trophy bug in silence @_@

  • chaosandcoffee
    94 posts

    @ibanez921
    No worries, also they have acknowledged it in a couple other threads about this, actually. No idea if this will be fixed in the upcoming patch but they do know about it, at least

    https://discussions.ubisoft.com/topic/81165/bug-legendary-animals-not-showing-in-longhouse/3 (one of the threads)

  • CaduTorquato_
    3 posts

    It's happening to me too, I play on the pc and I'm already playing the game and the head of the 3 wolves and the boar I killed appears.

  • Khaghan01
    1 posts

    I've completed the hunts for the Elk of the Bloody Peaks and Black Shuck and delivered them to the taxidermist, but the trophies don't show up in the longhouse. I've checked around online, and I can't find anybody who has been able to locate the trophies and there are a number of posts on Reddit and various other boards reporting the same issue.

  • Ckpepper02
    2 posts

    @ubi-ginge Sweet! Is there a photo you can share with the location of where the trophies should be showing up inside the longhouse?

  • PeSo.EsT
    3 posts

    In "Assassin's Creed: Valhalla", I hunted all the legendary creatures. The loot that was supposed to be displayed at my house did not show up, and it was still empty.I think the visual achievement is an important demonstration of the player's game history.
    And you can also look at the upper left corner of my screenshot. Because I don't want to hear Reda telling stories, I can't talk to Reda, nor can I complete the task.undefinedundefinedundefinedundefinedundefinedundefinedundefined

Suggested Topics

Community Details

28
Online
128.9k
Users
22.2k
Topics
115.0k
Posts