Welcome to discussions

Quick Suggestions

  • KostiCz33
    2 posts

    I have killed 7 and none is shown..im on ps4

  • Ubi-Woofer
    Ubisoft Support Staff 1009 posts
    Best Answer

    Hello everyone,

    I'm very happy to say that the patch notes for title update 1.1.0 - releasing tomorrow - have now been published, and this issue with the missing legendary animal trophies in the longhouse is an issue fixed in this update! Here's the information provided in the patch notes for your reference:

    Legendary animal trophies will now correctly appear in the Longhouse.

    Thank you all for your continued patience regarding this issue, and for your understanding. I'd also like to once again thank everyone who provided images, videos and accounts of the issue for us to send to the developers; these were instrumental in the investigation and meant that we could get this fix prepared. Should anyone have any questions, further issues or concerns, don't hesitate to get in touch.

    Official Response
  • Robster_500
    7 posts

    @speedynl21 thanks. To bad tho, i only need one more animal and i killed them all. But i don’t have a single thropy to show for 🤦♂😐

  • Robster_500
    7 posts

    @ryugo7 not really no! I just read the patch notes.. i mean, they fixed stuff that didn’t even bother me. Like, not using the arrows if you’re using your bow on the boat. I mean. I’m like 110 hours into this game.. i saw so many bugs that were far more [censored] then any fixing stuff like those arrows not being used 🤦♂

  • PeacekeeperSun
    27 posts

    Will this get fixed?
    I have all Legendary Animal and still have yet to see a Trophy on any wall.

  • Bob__Gnarly
    49 posts

    @peacekeepersun
    Probably obvious, but have you checked inside the longhouse?

    I've only killed 2 legendary animals (elk & shulk) and they're both mounted in the longhouse in my settlement.

  • MarcusAquinas
    5 posts

    Same here (sort of). I've killed five of them and turned them all in at the Hunter's hut. I've got one (the Polar Bear) mounted on the wall in the Longhouse and the rest are somewhere out there in the aether.

  • dlmthree
    77 posts

    Still not fixed. I have never seen my trophies in the longhouse.

    Also the fox (Dandelion) that you can get for your settlement disappeared a long time, I have only seen it once when I came back from Oxenefordscire and it has been gone since then.

  • Swenda
    3 posts

    Hello

    I just finished my 3rd fight with them and wanted to look at them in my long house only to find out that they dont spawn there or any where.
    Is it a glitch or bug, and what can i do to get them to spawn

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Greetings Swenda! Our teams have located the cause of this error with some of the legendary animal heads not being displayed at the longhouse, and are hoping to implement a fix in a future patch. Please continue checking the game's official website and Twitter page for details on future updates.

    Official Response
  • TheHound71
    6 posts

    So far through reloading and trying again over and over I've had mixed results. The elk took a while, black shuck took forever to show up, the bear showed up first time, the corpse eaters took a long time, and the other wolf took exactly 4 attempts (idk why I remember that). Now I'm attempting to mount the bull and it is just plain not working. I've tried 20+ with missions active, no mission active, day, night, raining, clear, before upgrading shops, after upgrading shops. Nothing. And this is after 1.0.4, which saw a bunch of new bugs introduced (most flagrant being enemies spawning directly behind you and enemies just standing passively until they are hit), I'm concerned that this bug got worse as well.

    Has anyone had success mounting a legendary animal post 1.0.4?

  • Mossburg21
    1 posts

    I am experiencing the same issue. I have killed five of the animals and only have the polar bear and the wolf at the moment. I have already finished the game and leveled settlement to 6 and that did not correct the issue. I am even into the mastery points and still nothing. I would like to see what the rest of them look like.

  • MojoCreed
    20 posts

    I can't see the legendary animal trophies anywhere, unless they're well hidden somewhere? I think this is a bug for me on pc.

  • lorddarthmaul76
    3 posts
    This post is deleted!
  • Gamesbroke2020
    14 posts
    This post is deleted!
  • stallattack
    34 posts

    @swisschaox I killed all legendary animals... nothing is displayed before and after the patch. not even a single one is displayed (PC). I even hunted the Vinland moose and Steinnbjorn something too ... still nothing..

  • Dahmzor
    18 posts

    @gamesbroke2020 190 hours of gameplay for me, a lot of other games for the same price have far less content, story and gameplay time. Yes there are bugs, sometimes they are un-avoidable because they work in the development office but not on all platforms, which is hard to test due to the amount of different rigs people own.

    And yes I have seen Ubisoft acknowledge threads about the bugs and apologise and say they are looking into fixing them.

    Give them a chance.

  • Gamesbroke2020
    14 posts

    @dahmzor nah they put out a broken game. I'd rather spend 30 hours in a well built game then 300 in a mediocre one. besides having a different rig shouldn't matter I'm playing on a ps4 pro. I will give them the story though. That is literally the only reason I'm still trying to play the game. and another thin how can it work on the development office but not for all platforms? It's kinda their job to make it work for all platforms they release the game for. If they were just going to make it work for PC then dont release it on console. But no then they wouldn't get that sweet sweet console money.

  • Gamesbroke2020
    14 posts
    This post is deleted!
  • Gamesbroke2020
    14 posts
    This post is deleted!
  • Ubi-Woofer
    Ubisoft Support Staff 1009 posts

    Hello everyone,

    Please accept my apologies for the delay in our update on this topic! I've now created this "megathread" for this issue with the legendary animal trophies not appearing on the longhouse wall as they should, and have added it to our reported issue megathreads list. I've merged a large quantity of threads already into this one, and will be continuing to merge any more that crop up, so apologies in advance if any conversations become disjointed. Please try to keep all relevant discussion in this thread from here on in. 🙂

    I am pleased to say that following investigation, the developers were able to reproduce this issue and a fix is planned for a future update. I do not have any additional information about this update at present (including when it will be implemented) so I can only ask for your patience until this information becomes available for me to share.

    Thank you all for your understanding, and I hope to be back soon with an update! 😄

    Official Response

Suggested Topics

Community Details

128
Online
191.3k
Users
32.0k
Topics
161.1k
Posts