ubisoft discussions


  • locked topic_solved [RESOLVED] Legendary Animal trophies do not appear on the longhouse wall after submitting them to Wallace | POST HERE

    39 likes/263 replies/24524 views
    ubisoft:x-posts, 3

    @partobazyar same issue here as well

  • Ibanez921
    ubisoft:x-posts, 20

    I'm running into this same problem. I've killed the Black Shuck and the Elk of Bloody Peaks. After talking to Wallace for the first time, it takes the trophies from my inventory but they never show up in the longhouse.

    Additionally, it seems that the axe that you get from killing the Black Shuck has disappeared from my inventory?? I saw someone posting in this thread about how sometimes taking out a torch while you are dual wielding will delete your offhand weapon, so I'm wondering if that happened to me?

    It's pretty frustrating to have an item deleted out of your inventory, especially a unique drop from a boss fight. =/

  • Ibanez921
    ubisoft:x-posts, 20

    Having the same issue. Additionally, the axe that is supposed to drop from the Black Shuck either never dropped for me, or got deleted from my inventory somehow.

    I was reading online that you were supposed to be rewarded with an axe called "Vordr's Bite" upon killing the Black Shuck, but I have no such item. Even went back and tried to loot the corpse which has persisted in game (20 hours later) and nothing.

    One thing I've noticed that may or may not help any devs reading this thread, is that when I talk to Wallace for the first time, he automatically takes everything out of my inventory and goes into the "Legendary Animals" screen by default before I ever actually selected this in his dialogue menu. Not sure if that's intended, but it seems to have something to do with talking to him for the first time while you already have animal trophies in your inventory perhaps? It makes me wonder if I would have this same problem if I hadn't killed any legendary animals prior to talking with him for the first time.

  • ABSpetznaz
    ubisoft:x-posts, 1

    Same frustrating problem. Killed the Elk in Norway, then the wolf pack and the Black Shuck. None of them appear in my longhouse and I didnt get the axe from the black shuck as well. Hope it will be fixed and soon

  • Osethme
    ubisoft:x-posts, 1

    Ditto here - I only have the elk completed, but it does not show up in my longhouse after turning it in. I didn't know about the reload trick or I would have tried that.

  • PsycBear
    ubisoft:x-posts, 5

    @commanderx-456 yeah it is super annoying, so far in game I've managed to kill 5 of these legendary beast yet only the trophie for the corpe feeders seems to show up, what's the point of these hunts if the only "reward" won't show.

  • Dahmzor
    ubisoft:x-posts, 18

    I have trophy's 4 left to get, handed the rest in to the taxidermist, only 3 are displaying; The Elk, The Corpse feeder, and Beast of the hills. Black Shuck and Aelfred's Battle-sow don't appear in my longhouse.

  • Ibanez921
    ubisoft:x-posts, 20


    I've tried reloading countless times, even loading into different autosaves at various stages before talking to Wallace for the first time. None of these reloads have fixed the problem with the trophies not displaying.

    Here's some details about how this all went down for me. I killed the Black Shuck and the Bloody Elk PRIOR to unlocking the tanner in Ravensthorpe, so those two trophies were in my inventory already before I talked to Wallace for the first time. Before ever talking to Wallace for the first time, I did the quest with Petra where you have to kill that pack of wolves in order to save that dude's 2 sheep. I'm wondering if A) having the trophies prior to unlocking the tannery is causing the problem or B) Having done the quest prior to talking to Wallace is causing the problem.

    One thing I've noticed is that when I talked to Wallace for the first time after reloading into the autosave where I still had both trophies in my inventory, his dialogue skips straight to the "wow these are great!" thing, as though I had selected to turn them in. It bypasses his dialogue options COMPLETELY and takes me straight to the legendary animals menu, rather than having me select from the 4 options that you see every other time

    So rather than being able to choose from:

    1) Legendary Animals
    2) Hunter Requests
    3) What do you do here?
    4) Leave

    It takes me straight to the legendary animals menu. Not sure if this is a part of the puzzle, or if I'm just scribbling conspiracy theories on the walls at this point...

  • Ibanez921
    ubisoft:x-posts, 20

    @swisschaox I'm also wondering if you could explain this a little more. When you say you did some other quests, do you mean you just did other side quests, or main story quests and then went back and talked to Wallace? Or did you kill more animals and then talk to Wallace?

  • yhibiki
    ubisoft:x-posts, 6

    Yep, same issue here. 😞 I've never seen any of the trophies. I wish I had known about saving/reloading before handing my kills in... I also killed the elk in Norway before I ever reached England, so idk if that affects the quest in any way.

  • chaosandcoffee
    ubisoft:x-posts, 94

    i also have no heads in my longhouse, i've killed the elk, dog, three wolves, drunk bear and polar bear. nothing shows up

  • cmburkit
    ubisoft:x-posts, 4

    I’ve killed them all and nothing.... also, it doesn’t even show the legendary moose from Vinland on his legendary list

  • Shimizu69
    ubisoft:x-posts, 1

    Same on PC it seems that this is not a Console or PC exclusive bug but a general bug. I have turned in 4 trophies and have Zero displayed in my Longhouse. I can't redo the quest as there isn't a safe game that i can go back to. I hope that Ubisoft will see this and just update the game based on the number that has already been turned in for the reward. It does mark them off on my kill list and shows them with a Big X so I would think this would be an easy patch to do and resolve based on there is already a formula/code in place it just isn't working right now.


  • Cid22_
    ubisoft:x-posts, 2

    Same Issue here. PC

  • Cid22_
    ubisoft:x-posts, 2

    Same For me - PC

  • RedSectorA
    ubisoft:x-posts, 1

    Did not get Petra's Arc from Aelfred’s Battle-Sow and no trophies in the longhouse. PC version.

  • ValtyrNine
    ubisoft:x-posts, 88

    According to the legendary animal menu, it specifically says "Hunt down legendary animals and deliver their pelts to receive a reward and a hunting trophy in the longhouse".

    There are no "hunting trophies" in the longhouse that I can find. I searched high and low through the entire thing. I have killed almost all of the legendary animals, so unless it means that you have to kill ALL of them to get anything for it then this dialogue needs to removed or changed.

    Has anyone noticed anything actually being added after killing a legendary animal?

  • BadDagron
    ubisoft:x-posts, 2

    @partobazyar Ya I have the same problem. No trophies showing for any of my legendary kills.

  • prophetykone
    ubisoft:x-posts, 2

    Same issue here, no trophies in the longhouse at all. I've killed three, and playing on xbox.

    Ubisoft, can you acknowledge the issue at least?

  • Ubi-Baron
    Ubisoft Support Staff ubisoft:x-posts, 798

    @ValtyrNine Thank you for reporting this issue to us.

    We are aware of this issue occurring, and it has been passed on to the team to be looked into.


Suggested Topics