Welcome to discussions

Quick Suggestions

  • cmburkit
    4 posts

    I’ve killed them all and nothing.... also, it doesn’t even show the legendary moose from Vinland on his legendary list

  • Ubi-Woofer
    Ubisoft Support Staff 799 posts
    Best Answer

    Hello everyone,

    I'm very happy to say that the patch notes for title update 1.1.0 - releasing tomorrow - have now been published, and this issue with the missing legendary animal trophies in the longhouse is an issue fixed in this update! Here's the information provided in the patch notes for your reference:

    Legendary animal trophies will now correctly appear in the Longhouse.

    Thank you all for your continued patience regarding this issue, and for your understanding. I'd also like to once again thank everyone who provided images, videos and accounts of the issue for us to send to the developers; these were instrumental in the investigation and meant that we could get this fix prepared. Should anyone have any questions, further issues or concerns, don't hesitate to get in touch.

    Official Response
  • Shimizu69
    1 posts

    Same on PC it seems that this is not a Console or PC exclusive bug but a general bug. I have turned in 4 trophies and have Zero displayed in my Longhouse. I can't redo the quest as there isn't a safe game that i can go back to. I hope that Ubisoft will see this and just update the game based on the number that has already been turned in for the reward. It does mark them off on my kill list and shows them with a Big X so I would think this would be an easy patch to do and resolve based on there is already a formula/code in place it just isn't working right now.

    Thanks.

  • Cid22_
    2 posts

    Same Issue here. PC

  • Cid22_
    2 posts

    @ibanez921
    Same For me - PC

  • RedSectorA
    1 posts

    Did not get Petra's Arc from Aelfred’s Battle-Sow and no trophies in the longhouse. PC version.

  • ValtyrNine
    87 posts

    According to the legendary animal menu, it specifically says "Hunt down legendary animals and deliver their pelts to receive a reward and a hunting trophy in the longhouse".

    There are no "hunting trophies" in the longhouse that I can find. I searched high and low through the entire thing. I have killed almost all of the legendary animals, so unless it means that you have to kill ALL of them to get anything for it then this dialogue needs to removed or changed.

    Has anyone noticed anything actually being added after killing a legendary animal?

  • BadDagron
    2 posts

    @partobazyar Ya I have the same problem. No trophies showing for any of my legendary kills.

  • prophetykone
    2 posts

    Same issue here, no trophies in the longhouse at all. I've killed three, and playing on xbox.

    Ubisoft, can you acknowledge the issue at least?

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    @ValtyrNine Thank you for reporting this issue to us.

    We are aware of this issue occurring, and it has been passed on to the team to be looked into.

    Official Response
  • Ubi-Spud
    Ubisoft Support Staff 700 posts

    Hi there! We are aware of this issue and have forwarded this report to the developers. We're just waiting for them to investigate further. Thank you for your patience!

    Official Response
  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    Hi all,

    This issue is something we are aware of occurring, and it has been passed on to the team to be looked into.

    Thank you for the report!

    Official Response
  • ValtyrNine
    87 posts

    @ubi-baron Do you know if other more serious issues, like the camera getting stuck when first aiming the bow during combat, are being looked into as well? I've reported tons of bugs with video evidence and it seems many bugs that actually effect gameplay are either being overlooked or buried. I'd rather the game be more playable than having eye candy added to a location I visit for probably less than 1% of the time playing.

  • Ibanez921
    19 posts

    @shimizu69 I'm basically afraid to go any farther in the game at all at this point until they fix this massive list of bugs 😞

  • MMAprop
    1 posts

    I have four of the legendary animals killed and turned in. But they are not showing anywhere in the long house. I had a save from before I turned the first one in and after the reload there was no change.

  • TheHound71
    6 posts

    So I had the same problem mounting my first trophy (elk). Due to previous bugs I've encountered in the game of things not unlocking when they're supposed to (specifically the wolf companion ability not unlocking after completing the required quest) I did not save after giving the tanner the trophy. First giving it to him resulted in no mount. I reloaded and tried again, no luck. I reloaded and fast traveled and tried again, no luck. In my last ditch effort I reloaded and farted around ravensthorpe building houses and changing decorations for a little bit. This time it worked and it was mounted properly! I don't know what I did differently this time, as the building upgrades and decoration changes I did before the successful attempt were the same as the ones I did initially. The only difference is it was raining during the successful attempt.

    Can anyone verify that once a hunting trophy is mounted it stays mounted?

    I would recommend babysitting this game with nearly everything you do and saving often in different slots. Just because the game says something happened doesn't mean it actually did. Turn in legendary animals one-by-one and verify they are mounted before saving and moving onto the next one. They should, eventually, be properly mounted but it will take lots of reloads to do so.

  • Steffchenko
    1 posts

    Same here. Killed 3 or 4, but ony the stag from early Norway is dispalyed. Shame...

  • guest-bOQAz0KF
    1 posts

    I have the very same issue on PS4. I have defeated all but 2 of the Alpha Animals, received rewards from then at the hunting lodge/vendor but none are appearing in my longhouse.

    Also, another comment discussed big fish not appearing when caught in hands which is also something that is happening to me.

  • Ibanez921
    19 posts

    @thehound71 I saw someone mention either in this thread, or another thread talking about this same issue that they don't stay mounted. Someone had an issue where their first couple were mounted properly, and then at a certain point they all disappeared and never reappeared and all the ones they got past that point never appeared either. This part of the settlement seems well and truly bugged.

  • maxrocktansky
    2 posts

    Hello to anyone who have or will read this I have been playing the game for around 60 or so hours now and have encountered some bugs one that is already known and one that might not be but it’s about the legendary animals I have killed all but two of them and they are supposed to be displayed in the long house and I check and only two have been displayed I hope the devs see this and fix it

  • Ubi-Ginge
    Ubisoft Support Staff 135 posts

    Hi all!
    The dev team have been made aware that the trophies of the legendary animals are not on display in the longhouse.
    They're currently looking into this, and when we have more information, it will be shared on the forums 🙂

    Official Response

Suggested Topics

Community Details

102
Online
141.2k
Users
24.9k
Topics
129.3k
Posts