Welcome to discussions

Quick Suggestions

  • Locked SOLVED [RESOLVED] Legendary Animal trophies do not appear on the longhouse wall after submitting them to Wallace | POST HERE

    39 Likes/263 Replies/21750 Views
    speedynl21
    79 posts

    its bugged like most thing, i have 5 none are displayed (pc)

  • VanRaposU
    14 posts

    @speedynl21
    Well, that sucks. Sorry to hear it.
    I will probably refrain from hunting legendary animals until this problem is addressed then.
    And I know the devs are already aware of this issue, but I honestly hope there will be some sort of marker highlighting the trophies or something like that because it is really annoying struggling to find something that should be obvious.

  • CaduTorquato_
    3 posts
    This post is deleted!
  • CaduTorquato_
    3 posts

    @swisschaox It's happening to me too, I play on the pc and I'm already playing the game and the head of the 3 wolves and the boar I killed appears.

  • Robster_500
    7 posts

    Same problem here. Also have 8-9 animals killed and neither of them showed in the longhouse. My village is fully build as well. Nothing changed.
    We are the 23th of november, and still no update on this game. I remember on the previous ones they updated like 2 days after to fix some bugs..
    this is such a good game but man, there are so many bugs in this game it just hurts. i had moments when i was climbing a tower to a synchronising point and my character just stops climbing and i can’t do [censored] about it.. then i have to fast travel to another point and then go back. just one of those bugs i found.

    i hope they at least fix the trophy’s, cause like some of you guys said it’s a crap load of work, it would just be nice to sit in my throne and just stare at them 👀

  • Jcutts23
    2 posts

    Same issue here fix this [censored] ubisoft games been out for weeks and we don’t even have an update on anything yet

  • Jcutts23
    2 posts

    Like the title says, I have killed the White Elk and the Black shuck but I’ve looked around online and seen it’s happening with every legendary animal. You turn the head into the tanner Wallace at Ravensthorpe and it says the trophy is now in the longhouse but they never show up, none of them show up even after reloading and re turning in the head.

  • evilhippo
    79 posts

    @evilhippo Ok, weirdly two of the missing trophies have now appeared (wolf & drunk bear)... I have killed five of the creatures however. 🤔

  • Robster_500
    7 posts

    @evilhippo and where in the longhouse? on the walls? Or cause i have none, so I don’t know where to look 🤣

  • speedynl21
    79 posts

    same thing killed 5 none show in longhouse, bugged like the rest of the game 70% +

  • Verz0
    1 posts

    got all of them, only the bear show up. I'm so frustrated.

  • RoninRedleg71
    2 posts

    On Xbox 1X I have killed 5 of the legendary anaphase animals and turned them in to the tanner. His interface declares that they are displayed in the longhouse, but they are clearly not present.

  • wiktor184
    6 posts

    @valtyrnine I got one trophy. White bear next to door of my room. But I killed all legendary animals...

  • Darigorn1
    1 posts

    Same here,
    Nor did petra's arc drop after killing Aelfred’s Battle-Sow..

    On Xbox one x

  • Hypnotron_
    5 posts

    Same here PC

  • Tha_Real_Dc
    1 posts

    I also am suffering the same as above with longhouse & fish. Xbox one X

  • evilhippo
    79 posts

    @evilhippo Hmm... as 2 of the trophies (of 5) were in the longhouse I was hopeful when I killed the big boar, that would also show up... nope... I have now killed 6 of them and only still only have a wolf head and a bear head. I has a sad 😞

  • heijenni
    1 posts

    Same here, xbox one. Only killed elk so far but cant see head anywhere. 🤷

  • radarred8
    1 posts

    I play on Xbox and killed the right legendary animal to get the skratii face tattoo but instead it gave me petras bow is this a bug or is this a feature, like a rare drop? Also same issue with the legendary trophies except the elk and the wolf.

  • Dahmzor
    18 posts

    I have killed all of them. Every last one. Worst one to fight was the Pair of Lynx, they are annoying as hell to fight, something I really wanted to see mounted. However even after collecting them all and mounting them, I still only have three of them up.

    But it's not the only thing in game bugged; The hunter collection items are an incompletable set of submissions because of the Black Bear Skin; where are black bears? America.... Vinland. I found three which I fast travelled to respawn, I killed those three, twelve times. I got no bear skins, none, nada, nothing. But even if I did it wouldn't matter, because nothing from Vinland goes back with you.

    I also cannot complete Dobby's alter as no more fabric drops after I upgraded my quiver and ration pouch. Need 5 for the alter that I cannot get. To be clear, I'm at 94% completion and have looted every chest from Norway and England (and Vinland, not that it matters).

    Oh and as a final thought, I really cannot be bothered fishing another 89 times, button bashing every fish to do the fisherman collections. Seriously, every other fisherman gets a rod, and/or a trawler net. We don't even get a spear and a good place to stand, so button bashing with a rope. I thought the "tips" said it was relaxing. And you can jump in and use that crappy axe on your lower back, which seems to stun you after every swing, but that's slower than the rope, for the fish I have handed in, I spent my time herding the fish to the shallows then killing them with a great sword or spear when I could be bothered swapping it in.

Suggested Topics

Community Details

94
Online
219.2k
Users
37.0k
Topics
183.6k
Posts