ubisoft discussions

Quick Suggestions

  • Locked Solved [RESOLVED] Legendary Animal trophies do not appear on the longhouse wall after submitting them to Wallace | POST HERE

    39 Likes/263 Replies/24256 Views
    Ubisoft Support Staff 703 posts

    Hi there! We are aware of this issue and have forwarded this report to the developers. We're just waiting for them to investigate further. Thank you for your patience!

    Official Response
  • Ubi-Baron
    Ubisoft Support Staff 796 posts

    Hi all,

    This issue is something we are aware of occurring, and it has been passed on to the team to be looked into.

    Thank you for the report!

    Official Response
  • ValtyrNine
    88 posts

    @ubi-baron Do you know if other more serious issues, like the camera getting stuck when first aiming the bow during combat, are being looked into as well? I've reported tons of bugs with video evidence and it seems many bugs that actually effect gameplay are either being overlooked or buried. I'd rather the game be more playable than having eye candy added to a location I visit for probably less than 1% of the time playing.

  • Ibanez921
    20 posts

    @shimizu69 I'm basically afraid to go any farther in the game at all at this point until they fix this massive list of bugs 😞

  • MMAprop
    1 posts

    I have four of the legendary animals killed and turned in. But they are not showing anywhere in the long house. I had a save from before I turned the first one in and after the reload there was no change.

  • TheHound71
    6 posts

    So I had the same problem mounting my first trophy (elk). Due to previous bugs I've encountered in the game of things not unlocking when they're supposed to (specifically the wolf companion ability not unlocking after completing the required quest) I did not save after giving the tanner the trophy. First giving it to him resulted in no mount. I reloaded and tried again, no luck. I reloaded and fast traveled and tried again, no luck. In my last ditch effort I reloaded and farted around ravensthorpe building houses and changing decorations for a little bit. This time it worked and it was mounted properly! I don't know what I did differently this time, as the building upgrades and decoration changes I did before the successful attempt were the same as the ones I did initially. The only difference is it was raining during the successful attempt.

    Can anyone verify that once a hunting trophy is mounted it stays mounted?

    I would recommend babysitting this game with nearly everything you do and saving often in different slots. Just because the game says something happened doesn't mean it actually did. Turn in legendary animals one-by-one and verify they are mounted before saving and moving onto the next one. They should, eventually, be properly mounted but it will take lots of reloads to do so.

  • Steffchenko
    1 posts

    Same here. Killed 3 or 4, but ony the stag from early Norway is dispalyed. Shame...

  • guest-bOQAz0KF
    1 posts

    I have the very same issue on PS4. I have defeated all but 2 of the Alpha Animals, received rewards from then at the hunting lodge/vendor but none are appearing in my longhouse.

    Also, another comment discussed big fish not appearing when caught in hands which is also something that is happening to me.

  • Ibanez921
    20 posts

    @thehound71 I saw someone mention either in this thread, or another thread talking about this same issue that they don't stay mounted. Someone had an issue where their first couple were mounted properly, and then at a certain point they all disappeared and never reappeared and all the ones they got past that point never appeared either. This part of the settlement seems well and truly bugged.

  • maxrocktansky
    2 posts

    Hello to anyone who have or will read this I have been playing the game for around 60 or so hours now and have encountered some bugs one that is already known and one that might not be but it’s about the legendary animals I have killed all but two of them and they are supposed to be displayed in the long house and I check and only two have been displayed I hope the devs see this and fix it

  • Ubi-Ginge
    257 posts

    Hi all!
    The dev team have been made aware that the trophies of the legendary animals are not on display in the longhouse.
    They're currently looking into this, and when we have more information, it will be shared on the forums 🙂

  • WolfLazerbeast
    7 posts
    This post is deleted!
  • WolfLazerbeast
    7 posts

    @ibanez921 Wait wait wait. On PS4 Pro here. What the hell?! You get an axe from killing Black Shuck?! I didn't get [censored]!! This is an absolute no no Ubisoft. Also killed 3 animals and only the stupid Black Shuck head appears. It's also glitched and mapped horribly on the wall.

    You get an axe from Black Shuck?! What axe?! I got [censored] all from doing that busted [censored] fight... Ubisoft is extremely unacceptable these days.

  • WolfLazerbeast
    7 posts

    Killed 3 legendary animals and only the dumb Black Shuck head mounted and it's mounted super glitchy, ugly and terribly mapped. Also not a single reward from the legendary animal kills. Tried reloading and NOPE, nothing mounts. My god Ubisoft WHAT ARE YOU DOING?!? Fix this now! People paid money for this game, some of us paid quite a bit of money as well! This is absolutely, 100 percent unacceptable with the horrid, horrid bugs and glitches. My faith in this company is in the dumpster.

  • Ibanez921
    20 posts

    @solsacrifice You are supposed to get an axe called "Vordr's Bite"

  • chaosandcoffee
    94 posts

    @ibanez921 wait really? i didn't get any axe from the Shuck fight..

    EDIT: i looked that axe up, and you find it in a chest, not as a reward from a legendary animal. i haven't gone to the chest location to check but i don't see why the information would be wrong

  • evilhippo
    79 posts

    Playing on PC, have killed three of the legendary beasts (hard work!) but they never showed up in the longhouse at all (as of PC version 1.0.2)

  • VanRaposU
    14 posts

    I've just slayed the Black Shulk and brought it to the tanner so I could display it as a trophy in the longhouse.
    But I simply cannot find it? Where was it supposed to be found? Like, near the throne? On one of those shields at the walls? Will I find only its head or the whole beast? Part of the problem is that I don't even know what I'm looking for.
    I saw some people online complaining their trophies never appeared either, but I'm not sure if I'm just not looking at the right place. And I didn't want to risk spoiling myself watching a video or reading an article because they tend to focus on finding the legendary animals when they are alive lol.
    I play on PS4, by the way.

  • speedynl21
    79 posts

    its bugged, i have 5 of them, none are displayed

  • miguelgallart
    1 posts

    @ptechpanther Same here on PS5, already killed the Elk, Black Shuck and Corpse Feeders, but only Elk head is showing. Already have heads to Wallace of course.

Suggested Topics