Welcome to discussions

Quick Suggestions

  • Locked SOLVED [RESOLVED] Legendary Animal trophies do not appear on the longhouse wall after submitting them to Wallace | POST HERE

    39 Likes/263 Replies/21740 Views
    79 posts

    when you walk to your room, you see them left and right, they are in the main hall on both sides

  • Jnastynati512
    2 posts

    None of the legendary animals are showing in long house and my wolf has disappeared from long house more bugs

  • Delphus68
    2 posts

    Same here, got 6 or 7 animals, but only 2 showing up in the first 2 spots in the front of the longhouse lenghtwise 😞

  • drnknnmd
    2 posts

    Same here. I've killed only 2 or 3, but none of them are showing up at all.

  • nuglife22
    26 posts

    I've had all legendary animals killed and turned into Wallace at the Hunter's Hut almost a week now. Each one has a red X over it and at the bottom it says, "Now proudly displayed in the Longhouse." Only the big white elk is on the wall, nothing else. Is it because I slept with Petra and then immediately broke up with her? Did she steal my legendary animal trophies?

  • Private_ubi.
    1 posts

    i haven’t had any trophies Appear in the longhouse so far I’ve done the corpse eaters the elk and the black shulk but I’ve noticed that whenever I turn in the trophies that the tanner says the same sentence repeatedly before he talks about the trophies and crosses them off the list he talks about the quest where you follow the white elk to try and find him when he goes missing I don’t know if this could affect it either but I did that quest before I killed any legendary animals Does anyone else experience this or is it just me

  • DestinHarris
    1 posts

    Series X. All alpha animals killed but no trophies are displaying.

  • Moonlitwings
    6 posts

    I've done the elk, corpse eaters, black shuck and a bear, and I'm not seeing any trophies in the longhouse. Searched online to see if I'm just blind, just to find that it seems I'm dealing with a glitch. Fun. So, half the legendaries killed and not a trophy to show for it, apparently. I'd really appreciate a fix.

  • Fractal009
    63 posts

    I want my trophies !!!!!!!!!!!

    Fix this and give us our trophies @Ubibug

  • KostiCz33
    2 posts

    I have killed 7 and none is shown..im on ps4

  • Robster_500
    7 posts

    @speedynl21 thanks. To bad tho, i only need one more animal and i killed them all. But i don’t have a single thropy to show for 🤦♂😐

  • Robster_500
    7 posts

    @ryugo7 not really no! I just read the patch notes.. i mean, they fixed stuff that didn’t even bother me. Like, not using the arrows if you’re using your bow on the boat. I mean. I’m like 110 hours into this game.. i saw so many bugs that were far more [censored] then any fixing stuff like those arrows not being used 🤦♂

  • PeacekeeperSun
    27 posts

    Will this get fixed?
    I have all Legendary Animal and still have yet to see a Trophy on any wall.

  • Bob__Gnarly
    49 posts

    Probably obvious, but have you checked inside the longhouse?

    I've only killed 2 legendary animals (elk & shulk) and they're both mounted in the longhouse in my settlement.

  • MarcusAquinas
    5 posts

    Same here (sort of). I've killed five of them and turned them all in at the Hunter's hut. I've got one (the Polar Bear) mounted on the wall in the Longhouse and the rest are somewhere out there in the aether.

  • dlmthree
    77 posts

    Still not fixed. I have never seen my trophies in the longhouse.

    Also the fox (Dandelion) that you can get for your settlement disappeared a long time, I have only seen it once when I came back from Oxenefordscire and it has been gone since then.

  • Swenda
    4 posts


    I just finished my 3rd fight with them and wanted to look at them in my long house only to find out that they dont spawn there or any where.
    Is it a glitch or bug, and what can i do to get them to spawn

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Greetings Swenda! Our teams have located the cause of this error with some of the legendary animal heads not being displayed at the longhouse, and are hoping to implement a fix in a future patch. Please continue checking the game's official website and Twitter page for details on future updates.

    Official Response
  • TheHound71
    6 posts

    So far through reloading and trying again over and over I've had mixed results. The elk took a while, black shuck took forever to show up, the bear showed up first time, the corpse eaters took a long time, and the other wolf took exactly 4 attempts (idk why I remember that). Now I'm attempting to mount the bull and it is just plain not working. I've tried 20+ with missions active, no mission active, day, night, raining, clear, before upgrading shops, after upgrading shops. Nothing. And this is after 1.0.4, which saw a bunch of new bugs introduced (most flagrant being enemies spawning directly behind you and enemies just standing passively until they are hit), I'm concerned that this bug got worse as well.

    Has anyone had success mounting a legendary animal post 1.0.4?

  • Mossburg21
    1 posts

    I am experiencing the same issue. I have killed five of the animals and only have the polar bear and the wolf at the moment. I have already finished the game and leveled settlement to 6 and that did not correct the issue. I am even into the mastery points and still nothing. I would like to see what the rest of them look like.

Suggested Topics

Community Details