Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • shadystewar2008
    3 posts

    Loving the game so far but I’ve come across a glitch in the nudist mystery where the box of clothes fell into the water and hasn’t respawned at the camp and isn’t in the water anymore.

    anyone else had this or any idea how to fix it?

  • Ubi-Borealis
    Ubisoft Support Staff 2111 posts
    Best Answer

    Hello there!

    I apologise for the double post. I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein a looping cutscene would occur in "Winchell the Robesfree" is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues with "Winchell the Robesfree" following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • shadystewar2008
    3 posts

    @bradgor1551 I have the same problem too! Hopefully it gets patched up. The completionist inside me wont be too pleased if we can’t get it done!

  • Xaelur
    7 posts
    The box ins't spawning for me.
    I even traveled to Norway and random lookout before returning and still no Box.

    If i try and take off all my clothes at the Camp a weird loop starts where the Camera goes into the air above me and i can hear the woman scream "let the Dane go, someone will see us" something like that before the camera goes back down only to go back up in the air again with the same woman saying the same thing again, looping everything again and again until i leave the area.


    The Box still hasnt respawned after a whole day of questing, which includes:
    A. Going to and 100% completing Asgard.
    B. Doing some Main and World event story quests all over the map.
    C. Hunting and obtaining Excalibur.

  • CretuKsan
    2 posts

    In the "nudist" camp there isn't the clothes crate that I am supposed to steal for Winchell the Robesfree

    (this box )

  • Jayms8462
    1 posts

    Having the same issue. I had the box originally and it would not let me turn it in. So I threw it in frustration into the water. For some reason doing that made it clip through the floor weirdly. And now it is gone all together.

  • CretuKsan
    2 posts

    @jayms8462 At least I know I am not the only one with the same problem

  • Zirkusaffe1
    4 posts

    @bradgor1551 It's funny how I got told by the support this bug wouldn't be reproducible therefore it wouldn't be a bug, yet there are so many people here with the same issue.

  • Starbuckviper
    7 posts

    @ubi-raziel Here's from my perspective - I am playing on PC with controller input > https://www.twitch.tv/videos/801298648 Have been back to there multiple times, I can interact with the nudists at the bottom but there is not chest at all spawning anymore.

  • Neravir
    1 posts

    I'm also having trouble with this quest. At first I had Eivor undressed and there was a cutscene with dancing, then I tried to steal the box, but bothing happened, so I threw out the box.
    Then the quest seems like restarted, the Box respawned, but everytime I tried to steal it I was seeing the same cutscene as if Eivor joined them.
    Then the pack of wolf attacked and the only NPC to interact is dead and the box is nowhere to be seen.

    I tried reloading, traveled to Norway and back again, completed 3 pledge quest and nothing.

  • Kultowy97
    20 posts

    @ohhquinnfx Yesterday I decided to start the story again and the problem disappeared for me too.

  • Ubi-Spud
    Ubisoft Support Staff 675 posts

    Hey folks! We have merged your threads into this megathread. I have sent this issue up to the developers as a bug report. We will update this thread if the team need anything from you guys, such as videos/images/save files. Thank you for your patience in the matter, and feel free to create new threads for any unrelated issues you may be facing that are not covered in our Known Issues sticky.

    Official Response
  • BuffaloTheory
    1 posts

    So I was stuck on this quest too. Stole the crate, took it back to Winchell and nothing would happen. Remembering that other World Events with crates required them to be put on the ground in a particular place, I wandered around Winchell's area until I got the notification on the blanket next to Winchell's tent to place it on the ground. After that the event completed fine!

  • Kavok1
    1 posts

    Same issue as everyone else in this thread. Box is gone, fast travel doesn’t respawn it. This isn’t able to be completed.

  • TheIronChariot
    4 posts

    Same for me... took the box back to him, he wouldn't move to his right spot to complete the task... restarted the game, no box anymore nothing can be completed.

  • GhilliedRush
    4 posts

    I also have this bug and I'm far into the game...

  • falo2k
    21 posts

    Box is gone, have no save game (as I don't expect to keep incremental saves throughout my playthrough) and am far too far to just restart. Now seeing where the crate was meant to go, that's not even mildly clear as the quest giver makes it clear he just wants their clothes stolen. Another untested mission?

  • hadvezer
    1 posts

    Box is gone for me too. A tried many things before that, Bringing back the box to Winchell, throwing the box into water, even killed the woman we could speak to, and when I fast travel back only her body is found and no box. (I progressed to far to go back to older save game)

  • Haellhheim
    1 posts

    I have came across the nudist colony mystery and have no idea how to solve it anymore as I have through the box into the lake next to the mission. The box now doesn’t show up at all for me so I have no idea how to complete it

  • StormRavenant
    1 posts

    So I was doing the Winchell the Robesfree quest and I couldn't remember where to brink the box of clothes so I eventually got fustrated and threw them off the top of the cliff and into the lake, but when I went to find them again, they weren't there. So is there a way to reset a world event


  • TimepointFive
    6 posts

    @ubi-spud I'm glad to have created the thread. Imagine starting the entire game over for one mystery that I'm sure the team will patch up. Thanks!

Suggested Topics

Community Details

45
Online
130.0k
Users
22.5k
Topics
116.7k
Posts