Welcome to discussions

Quick Suggestions

  • TimepointFive
    6 posts

    @sfido Very annoying as it's one of the last things I need to finish the area.

  • Ubi-Borealis
    Ubisoft Support Staff 2207 posts
    Best Answer

    Hello there!

    I apologise for the double post. I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein a looping cutscene would occur in "Winchell the Robesfree" is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues with "Winchell the Robesfree" following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • BillyKidd1981
    3 posts

    World event where the guy wants you to steal all the nudist's clothes, the lady says there is a crate to put my clothes by the tent. There is no crate. I've fast traveled back to home base and went back to this world event and there is still no crate to steal the clothes from. This a glitch?

  • SurexPOSEY
    20 posts

    For me I have the crate but when i take it back to winchell I can't interact with him ...
    These world event are buugged as hell and some really are not explicit about what to do ...

  • J-Dog328
    2 posts

    I've picked up the crate of clothes, ran back to the guy, then he got bugged out so I couldn't speak to him. I put the crate down for a minute to try and fix him, fast traveled away and came back and now the crate has gone... So now I can't finish the mission. Looked everywhere, fast travelled back and to, changed genders, everything. Please help!! Don't wanna have to start everything again to get the completioniat trophy when I've put 30 hours into it already!!

  • andry9611
    20 posts

    @j-dog328 Don't know if this could help you but when i did it my crate fell into water and couldn't reach it anymore, i just run back to the nudists outpost and the crate was back there. Try to reload or fast travel or even change Eivor's gender and see if the crate goes back where it was.

    Edit : btw on which platform are you playing ACV?

  • OhhQuinnFX
    19 posts

    I have the same issue. Made a support ticket. No idea how they will fix this, I'm almost crying man, I was ready to go for completionist, then this [censored] happens...


    If someone knows a fix, please let us know!! ❤

  • that_dude212
    1 posts

    The quest " im not like other nudists" in Grantebridgescire wont let me continue after talking with the guy on the cliff, I go down to steal they're clothes and there is no box for me to steal the 1st time I did the quest I had the box but I fell in the water and I think it glitches bc now the box won't show up anywhere, I even left the area and fast traveled to Norway and came back but still the quest cant be completed ANY HELP PLEASE!?!?!?

  • alwayshuntress
    1 posts

    @surexposey

    I have the same bug. I got the crate, took it back to Winchell and he won't speak to me - even though I still have the crate.

  • VoXngola
    1 posts

    It's bugged for me as well, however in my case the crate isn't even there. It won't spawn.

  • darthbiggious
    4 posts

    pretty sure that mystery/world event is bugged up the wazoo, took the stolen box of clothes back the NPC and still had nothing happen

  • Elmozorz
    2 posts

    Also have the same bug. I have fast travelled, travelled to Norway and back, restarted the game and no luck. Bow will not spawn at all

  • The_Tr3nch
    8 posts

    It was bugged for me as well. How I fixed it was walk away with the crate while watching him in the distance. He despawns but you will still have the crate. Head back over to him and he should respawn and working again. May take a couple of times.

  • GothicEnigma
    29 posts

    @ohhquinnfx

    Box won't appear for me either, and I haven't bugged on the quest yet.. took it, talked to the lady.. no box..

  • recK7
    2 posts

    @creepersown007 My game crashed while I was escaping with the crate. Once I reloaded the game - no crate anymore. Can't progress with the quest as well... 😕

  • FW_LOKUS
    3 posts

    Hi Guys...another bugged Quest.

    I found Wincel, the naked Guy who wants to steal his Cult Members clothes as revenge for expelling him. Went down, grabbed the Box, meanwhile Wincel changed his position on the Rocks, making me unable to talk to him. Tried restarting the game. After loading back in, the wooden Box where the Clothes are supposed to be disappeared completely and is nowhere to be found anymore. So this quest is practically bricked for me.

  • Ubi-Swaggins
    Ubisoft Support Staff 340 posts

    Hey folks,

    I am sorry to hear that you are having problems with this World Event.

    The team has advised that if you encounter an issue with the event and cannot complete it, to fast travel away and return to the event at a later time as it will reset.

    Can anyone provide a video demonstrating the issue with this specific quest so I can forward it for review?

    Official Response
  • FameTree
    6 posts

    The box with the nudist clothes does not spawn.
    Taking off the characters clothes activates an infinite loop of the 'I knew you we're one of us...' cutscene.

  • OhhQuinnFX
    19 posts

    @gothicenigma Seems to be an issue more people have, I hope they make some sort of "reset" world event or for other / side missions aswell, that resets them so we might be able to go for completionist 🙂
    Still have some gameplay left before having everything done tho, still lots of time left so yeah, hope they'll fix it sometime 😄

  • OhhQuinnFX
    19 posts

    @timepointfive Good, well good I hope, news!!

    I checked the known bugs from Ubisoft post, and I quote:

    • World event cannot be completed due to various actions. 
      • Workaround: To reset, fast travel to a different location and return later to restart. 


    Still at work so I can't test it right now, hope this works for y'all. If I remember correctly this did not work for me... Tried it yesterday I think.

  • Velldanas
    16 posts

    @timepointfive Same here! Need a fix asap.

Suggested Topics

Community Details

36
Online
130.9k
Users
22.7k
Topics
117.8k
Posts