Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • KyraJack69
    11 posts

    @timepointfive why do I feel like ubisoft haf no beta testers?

  • Ubi-Borealis
    Ubisoft Support Staff 1381 posts
    Best Answer

    Hello there!

    I apologise for the double post. I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein a looping cutscene would occur in "Winchell the Robesfree" is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues with "Winchell the Robesfree" following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • El_Facko
    4 posts

    @pitusc4 dont jump in the water, jump on the rocks and bring the crate back to nudeguy.

  • Miquel_Rafecas
    1 posts

    Another ones affected

  • CliftonBuckner
    1 posts

    @ubi-swaggins I've traveled to Norway and back 3 times, still no crate. Hope it gets fixed this is my first time getting close to completionist!

  • meitneshi
    1 posts

    same issue for me, the crate will not respawn, I drop it on the ground but not the spot near the tent. The quest does not complete so i fast travel and come back thinking it will solve but instead the crate has disappeared.
    Hope this bug will be patched in one of next patch 😉

    By the way thank you for this game

  • FameTree
    6 posts

    @ubi-spud any update to this issue?

  • Gokislav
    19 posts

    The same issue here - the crate will not respawn. 😕

  • jarednew52
    2 posts

    I tried doing this mystery quest in Grantebridgescire. I went to take the box to the guy, but dropped it in the water. It never respawned. Then the lady got attacked by raiders and died. I’ve tried fast traveling, mediation, loading the previous save. None of these work.

  • jarednew52
    2 posts
    This post is deleted!
  • Ubi-Raziel
    Ubisoft Support Staff 197 posts

    Hello everyone!

    I have merged some of you together in this thread as you describe the same behaviour. What has happened to the box may differ slightly, but the end result (missing box) remains the same.

    Our team managed to reproduce the issue and we are working towards a fix. Please keep an eye on our patch notes for mention of this issue.

    All the best!

    Official Response
  • Dr.Demintor
    1 posts

    I am also having the same problem while playing on the PS4, as a completists this is something that bugs me to no end as I feel I am unable to continue the game until I have finished this mystery.

  • oak3996
    6 posts

    @dr-demintor

    Any eta for next patch ?


    Thanks

  • StevieBee1981
    1 posts
    This post is deleted!
  • SixxCasban
    6 posts

    I'm also having the same issue, stupidly I fell in the river with the box the first time, reloaded my save, tried again and the quest giver wouldn't respond to me when I brought him the box, now iv fast travelled away from it multiple times and come back over the last week and there is no box what so ever... More recent developments I may have killed the woman down there out of frustration! Kills me when I'm going for full completion I hope this can be fixed for me... Probably shouldn't have killed the woman but she was collateral damage, either her or my controller 😂😂

  • Rosco-M-
    1 posts

    Like many on this thread I have attempted to leave the box at Winchells feet and near his tent with no success. Dropped the box into the water too. Now I cannot even interact with Winchell and the box is gone. I've attempted to remove all of Eivors equipment and clothing and the game just loops with a odd camera angle and the same NPC saying "let the Dane go"

  • viaene96
    1 posts

    I have the same problem on PS4.

    I have started the quest and I ran down to the nudist camp took the box, ran out of the camp with the box and dropped it up the mountain near Winchell. When I dropped it I wasn't able to pick it up again and I didn't completed the event. Then I ran back to the camp killed the woman, I hoped that it will reset but the woman is still dead and I can't find the box. Now I'm doubting to continue playing the game because I want to 100% this game. Can Ubisoft fix this issue?

  • Ubi-Raziel
    Ubisoft Support Staff 197 posts

    Hello all!

    I appreciate this is a frustrating issue. Our team are working hard to bring a fix to you all!

    @dr-demintor

    Any eta for next patch ?


    Thanks


    No ETA just yet but we'll let players know the moment we have one! Our next patch should be one that brings a lot of fixes!

    Official Response
  • Deadmennwalking
    21 posts

    Same problem
    Collected box, npc wouldn't talk to me, threw box into water, now unable to complete quest.

  • UnearnedLion678
    5 posts

    @ubi-raziel

    First of all thank you very much for this amazing game.

    I have more than 170 hours of game play and managed to finish the game and unlock all the trophies except "completionist all the way" for Platinum trophy.

    Two events glitched on me : first one which is a known glitch and very likely to get fixed on next update is a shrine in "Eurviscire" which asks you 5 "fabrics" which they dont drop or obtainable from chests or merchants 

    the second one which makes me worry is the one in the nudist island where you have to carry the box up the hill in "Grantebridgescire" ,the box disappeared and doesn't spawn anywhere now 

    I just want to hear from you that this will get fixed on the next patch update please.

    They are other issues with the world events but I have managed to fix them by reloading my saves game,multiple times in some cases.

  • MemeOfCheese
    12 posts

    I HAVE A QUESTION
    WHY ARE THEY NOT NAKED?
    They are all wearing underwear and bras. The hell? Its a nudist camp and I have nudity turned on. Is that a new bug? Can anyone else see them naked? I want to see them naked

Suggested topics

Community details

27
Online
123.9k
Users
21.3k
Topics
109.9k
Posts