Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • TariSzabolcs
    1 posts

    Dear Ubisoft!

    This is the same problem on PC. At the nudist camp, the inability to deliver the crate to the man standing on the rock. The crate simply does not exist. I reloaded the backup, I traveled elsewhere, waited for hours and even then this bug exists. Quite a few people are experiencing this. I hope you fix it. Thanks in advance.

    Anyway, the game is great 😉

  • Ubi-Borealis
    Ubisoft Support Staff 2111 posts
    Best Answer

    Hello there!

    I apologise for the double post. I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein a looping cutscene would occur in "Winchell the Robesfree" is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues with "Winchell the Robesfree" following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • SurexPOSEY
    19 posts

    Well for me the crate doesn't spawn anymore.

  • Josesanz95
    3 posts

    Same issue here, the crate doesnt spawn anymore, so there is no way to complete the quest

  • FW_LOKUS
    3 posts

    Same Problem. At first you can grab the Box and run away with it, but Winchell seems to reposition himself during this procedure and you can´t talk to him anymore because of that. Restarted the game, tried to load a Savegame before i grabbed the Box, and it simple didnt appear anymore.

  • OhhQuinnFX
    19 posts

    @ohhquinnfx Update: I'm restarting my story. Can't be bothered to wait for an ubisoft bug fix, usually they don't even do that. If you're going for completionist just reset your game 😞

  • Kultowy97
    20 posts

    This is the first time I have encountered so many bugs, I have the feeling that the further we move in the plot, the game crashes more and more, if it was one bug in a side mission that's ok, but after 17 hours of play, I came across 5 errors that prevent you from continuing the game and side attractions such as entering the world of Valhalla or getting Thor's armor, do you think restarting the game will help?

  • OhhQuinnFX
    19 posts

    @ohhquinnfx O, MY, DEAR, GOD... DO NOT DO THIS I REPEAT DO NOT DO THIS! I lost all my DLCs!!!!! All my packs from ultimate edition are GONE! HELP!

  • Kultowy97
    20 posts

    @ohhquinnfx after restarting the game ?! are these some jokes? good that I haven't done it yet.

  • OhhQuinnFX
    19 posts

    @kultowy97 My bad, the dlc's only unlock after a mission 😛 Woopsie! I got 'm now. Im rushing the story till I go to England, instantly going to the Winchell quest and updating y'all if I can do it then or not.

  • Kultowy97
    20 posts

    @ohhquinnfx although it's good, I am waiting for information from you whether restarting the game will help

  • Silverex73
    1 posts

    So i was trying to steal the box with clothes of the naked people that danced at the river, the game had a error and shut itself. Now there is no box of clothes anymore. It just dissapeared and i cannot finish the quest. Anyone the same problem or a workaorund? I searched everywhere for the box but its gone haha

  • FatelessLegend
    2 posts

    @silverex73 Yo had the same problem but once the box is gone that’s it man you gotta try and reload to before you started the quest or to a point before you touched the box

  • StewyCheetah118
    1 posts

    Same problem for me. Need a fix asap. Very annoying and poor design. Devs need to get on these small bugs bc they making the game annoying to play. I took the box up the hill and nothing happened so I throw it into the lake and it disappeared. Now this quest is just sitting here and I cannot complete it.

  • OhhQuinnFX
    19 posts

    [NO FIX]

    • Fast travelling away and coming back does NOT reset this world events progress. (- tested by me)
    • Trying to find the crate somewhere close will not work, I've looked over two hours trying to find it, before I reset my game progress. (- tested by me)
    • Trying the kill the NPC will not work. He is some kind of god, he is unkillable. Damage, wolves, arrows, fire, nothing worked 😞 (- tested by me)


    [POSSIBLE FIX]

    • Start a new story.


    This WORKED for me. However you need to decide if it is worth it, losing all your previous gameplay for one world event. If you're going for completionist, I guess it is worth it (if you cba to wait if this will ever get patched, because Ubisoft knowing, ... well, it might never get fixed 😛 ).
    However I lost 16h of gameplay by starting a new story, I'm happy there is still a way I might be able to get completionist at the end 😉

    If you don't think it's worth it to replay the story till now, wait for the first or coming patches from the game in the next days or weeks. Since it's a pritty common bug, I think they will patch it sooner or later.

    I hope I won't encounter more bugs like this in the near future, one setback for 3h of gameplay was already enough from a glitched cinematic, no way I'm resetting a 2nd time for another bug later in the story.

    note: this is not an official ubisoft answer. there is a chanse starting a new game won't fix your issues. i'm not accountable for lost progress if yours still doesn't work after a new story.
    forgive my grammar mistakes, its currently 3am for me and im tired if these stupid bugs 😄

  • GospelOfDustin
    1 posts

    I have the "fix" for this. The quest doesn't explain it well, but you have to place the crate over on the blanket by his tent. If you activate Odin's Eye mode you'll see it glowing. This worked for me, anyway.

  • OhhQuinnFX
    19 posts

    @gospelofdustin Glad you're helping, but most of the people in this thread problem is the crate doesn't spawn 😉

  • Dukat1829
    1 posts

    Good evening everyone,

    I seem to be experiencing a bug in regards to the World Event that relates to Winchell the Robesfree. He tasked me with collecting the clothes from nearby nudists since he was cast out. I picked up the crate after talking to the now lady in charge of the whole group. However, I went the wrong way and the box of clothes were in the water, with no way for me to pick it up. I closed the game and opened it, now the crate was gone. I reloaded an earlier save, the crate did not spawn. I followed the suggestion to leave the World Event and come back later, I did and the crate still did not spawn. I restarted the game and tried it again, did not spawn. I completed other world events far away from there, the crate still did not spawn. What shall I try next or is there a way to reset it some other way?

  • tashonix
    3 posts

    I’m having the same problem, it isn’t back again after quitting the game and restarting either, which I’d hoped would start the mystery over.

  • MartinPopik
    4 posts

    you need to take that chest to quest giver.

  • wVw_Alyssa_wVw
    Original poster 4 posts

    @martinpopik that’s what I tried before throwing it off the cliff, he was motionless inbetween the rock he was standing on and his tent behind the rock, I tried putting it near the tent and talking, near his rock and talking, and right next to where he was stuck and talking, it led me to believe you had to destroy the box

Suggested Topics

Community Details

47
Online
130.0k
Users
22.5k
Topics
116.7k
Posts