Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • DJSKAMDOTNET
    2 posts
    This post is deleted!
  • PRPUNISHER88
    1 posts

    In the nudes group mission in Grantebridgescire
    where I have to carry the crate to the Winchell. I not there for me to carry and I am not able to talk to anyone.

  • Alessiothebest
    1 posts

    Anche io il solito problema la cassa proprio non ce

  • Ayasura
    1 posts

    Same experience on my PS4. I did the same steps as already mentioned. Took the crate, no fighting them, took box to NPC quest giver, didn't see where to put it so I set it by him. No prompt to talk to him now. The others reset below. Left, returned after other missions, reset game. Restarted PS4, no box where it should be. Spoke with NPC woman again as the bubble was there again. Tried to start over, but no box. If I removed clothing the quest became a loop. The woman would praise me for joining them, then state we had to hide. Before I can do anything the screen goes black and repeats the praise for joining them in their behavior and that they need to hide. Only fix was to quickly put clothes on before the loop or to run to the other side of the water to cancel the loop. Box was still nowhere to be found.

  • jjghwull
    2 posts

    Same issue as alot of people. Box in water. No respawn . Girl dead. No respawn or quest markers anywhere.

  • jjghwull
    2 posts

    A patch came out.

    Addressed various issues with quests or world events that prevented players from completing them.

    please can anyone confirm this specific bug has been fixed?

    thanks!

  • NOTr083r73h
    3 posts

    I can confirm that as of Title Update 1.0.4, the quest now works properly. The crate now spawns and can be delivered as intentioned. Completed the quest just now on PS4. Thanks.

  • Gokislav
    21 posts

    After Update 1.0.4, the crate now spawns, but now i have other problem that is very big. I can't save the game automatically or manual, i can't fast travel. The game is unplayable now. I don't want to start the game again and lost whole progress so far. 😞 Someone else to have this problem? 😐

  • Balla_Jazzuz
    100 posts

    @gokislav What platform? I try to decide whether I will download this patch, seems like it creates some new bugs/glitches I don't want at all instead of fixing a lot of things. I'm on PS4 btw

  • Gokislav
    21 posts
    This post is deleted!
  • Gokislav
    21 posts

    @balla_jazzuz PS4 too.

  • Balla_Jazzuz
    100 posts

    @gokislav Thanks mate! I'll probably wait then....hope they fix your game braking issue soon!

  • oldbaldgamer
    3 posts

    Fixed for me after patch (clothes box spawned again)

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone,

    I am pleased to say that this issue with the "Winchell the Robesfree" world event should now be fixed as of today's patch (1.0.4). Please update your game before playing again, and you should find that the crate spawns in and can be handed in for the quest to be completed! It's great to see that a few of you are already confirming this.

    Please let me know if there are any further issues with this world event and I'll reopen the investigation with the devs.

    @Gokislav Could you please open a separate thread for this issue and include a video of your inability to do both? This thread is exclusively for the issue with "Winchell the Robesfree" and I don't want it to be derailed. Thank you 🙂

    Official Response
  • xFizzyx
    2 posts

    After patch I complete this quest! Thanks!!!;)

  • Moonlitwings
    6 posts

    Can confirm, quest is working now with the new patch. Thank you!

  • reddevilrody666
    3 posts

    @pitusc4 Hello! Try to do one other quest before going back to the quest you describe above. That might help.

  • WardenRae
    7 posts

    I'm STILL not able to complete the quest because the guy won't talk to me when I bring him that box. There's no option for conversation. And, yes, I have the latest updates and patches. HELP!

  • Ubi-Borealis
    Ubisoft Support Staff 2131 posts

    @WardenRae - Hello there! I apologise for the delayed response. Are you still unable to interact with Winchell the Robesfree? If so, please can you provide us witha video that demonstrates this in-game? Thanks!

    Official Response
  • HoriZzonZz.UK
    8 posts

    @Ubi-Borealis @Ubi-Alien @Ubi-Baron @ubisoft

    Dear all, this bug is far from fixed.
    Posting on 16th February 2021.
    I have cleared this game, all but for this final mystery, preventing completion of 2 trophies.
    I don't see the point in posting video as requested of others, the problem is exactly as reported by them:

    Start mystery by talking to Winchell
    Move to nudist camp
    Talk to nudist-in-chief
    Remove clothes
    Steal clothes chest
    Return to Winchell, who acts disinterest ed
    Throw box off cliff in frustration and contempt
    Unwittingly ruin mystery completion as box fails to respawn for a further attempt.

    Please can you resolve or remove this mystery?
    I'd dearly love to complete this game and don't fancy a further 150+ hours of game time to do it all again, just for the sake of this glitch?

Suggested Topics

Community Details

25
Online
130.5k
Users
22.6k
Topics
117.2k
Posts