Welcome to discussions

Quick Suggestions

  • OhhQuinnFX
    19 posts

    [NO FIX]

    • Fast travelling away and coming back does NOT reset this world events progress. (- tested by me)
    • Trying to find the crate somewhere close will not work, I've looked over two hours trying to find it, before I reset my game progress. (- tested by me)
    • Trying the kill the NPC will not work. He is some kind of god, he is unkillable. Damage, wolves, arrows, fire, nothing worked 😞 (- tested by me)


    [POSSIBLE FIX]

    • Start a new story.


    This WORKED for me. However you need to decide if it is worth it, losing all your previous gameplay for one world event. If you're going for completionist, I guess it is worth it (if you cba to wait if this will ever get patched, because Ubisoft knowing, ... well, it might never get fixed 😛 ).
    However I lost 16h of gameplay by starting a new story, I'm happy there is still a way I might be able to get completionist at the end 😉

    If you don't think it's worth it to replay the story till now, wait for the first or coming patches from the game in the next days or weeks. Since it's a pritty common bug, I think they will patch it sooner or later.

    I hope I won't encounter more bugs like this in the near future, one setback for 3h of gameplay was already enough from a glitched cinematic, no way I'm resetting a 2nd time for another bug later in the story.

    note: this is not an official ubisoft answer. there is a chanse starting a new game won't fix your issues. i'm not accountable for lost progress if yours still doesn't work after a new story.
    forgive my grammar mistakes, its currently 3am for me and im tired if these stupid bugs 😄

  • GospelOfDustin
    1 posts

    I have the "fix" for this. The quest doesn't explain it well, but you have to place the crate over on the blanket by his tent. If you activate Odin's Eye mode you'll see it glowing. This worked for me, anyway.

  • OhhQuinnFX
    19 posts

    @gospelofdustin Glad you're helping, but most of the people in this thread problem is the crate doesn't spawn 😉

  • Dukat1829
    1 posts

    Good evening everyone,

    I seem to be experiencing a bug in regards to the World Event that relates to Winchell the Robesfree. He tasked me with collecting the clothes from nearby nudists since he was cast out. I picked up the crate after talking to the now lady in charge of the whole group. However, I went the wrong way and the box of clothes were in the water, with no way for me to pick it up. I closed the game and opened it, now the crate was gone. I reloaded an earlier save, the crate did not spawn. I followed the suggestion to leave the World Event and come back later, I did and the crate still did not spawn. I restarted the game and tried it again, did not spawn. I completed other world events far away from there, the crate still did not spawn. What shall I try next or is there a way to reset it some other way?

  • tashonix
    3 posts

    I’m having the same problem, it isn’t back again after quitting the game and restarting either, which I’d hoped would start the mystery over.

  • MartinPopik
    4 posts

    you need to take that chest to quest giver.

  • wVw_Alyssa_wVw
    Original poster 4 posts

    @martinpopik that’s what I tried before throwing it off the cliff, he was motionless inbetween the rock he was standing on and his tent behind the rock, I tried putting it near the tent and talking, near his rock and talking, and right next to where he was stuck and talking, it led me to believe you had to destroy the box

  • MartinPopik
    4 posts

    @wvw_alyssa_wvw i didnt know what to do as well, i was trying to dump it somewhere first... when i was about to give up i kicked those nudists asses and then took the crate on top of that cliff, where the quest giver stood, he started talking when i was getting closer. But it might be bugged for u, i dont know. I have a problem with quest in Lundun, where i have to rescue some guy stuck in a barn. When i got there for the first time the npc wasnt even there so i just messed around moved few thing and when i got back later it like partially reseted. Jars i needed to move reseted but the shelf u can move with didnt, got stucked and you cannot move with it again.

  • MeinChurro
    39 posts

    Just dealt with this. You have to steal the crate and get away with it - TWICE. I mean that literally, grab the crate, run away, get away. Run back to the nudists (who have reset), steal the crate again, NOW you can complete the quest with that second crate.

  • wVw_Alyssa_wVw
    Original poster 4 posts

    @martinpopik I’m hoping they’ll fix these kinds of things, I mean I know the game just came out but Ubisoft is notorious for not fixing bugs, for a lot of their games they just straight up ignore most of the bug reports, but I’m hoping they take the time to do this right because I personally love the game. I mean with the bug I’m caught in, it looks like if you mess up one minor detail you just can’t complete the quest whatsoever. Like, imagine someone accidentally dropped the crate into the water you can swim in, that itself makes the quest uncompleteable right there because the box itself doesn’t respawn, you can’t pick it up in swimming water, and it just gets removed from the game when you fast travel away, and that’s a very easy accident to make, and in cases like mine it was so buggy in the first place that I actually thought I HAD to get rid of the box.

  • styl_fly
    3 posts

    Ps4 player here.. I had the exact same thing happen to me! And I even went through the same thought process of throwing the crate off the cliff! My guy has stepped down onto the lower rock - won't go back to his spawn spot and also has no prompt for me to speak to him. Nothing happened when I brought the crate to him 😞

    Pretty frustrating, hopefully it's fixed soon.

  • pjt1337
    2 posts

    @wvw_alyssa_wvw got the same problem on xbox

  • NafrayuNox
    5 posts

    That would be great but the issue is that the crate isn't there at all. And you want us to steal it twice? Thanks for the suggestion and I'm glad it worked for you but it sadly won't help the rest of us

  • NafrayuNox
    5 posts


    Sorry for double post but can't edit after 300 secondes so I couldn't edit this in my first post.

    I unfortunately will not be playing this game anymore because I don't want tonhave to make a save every time I start something in case it glitches. Ifbthat was the only instance where I need to do it fine, but no. World events, treasures, and artifacts can randomly glitch and not give progress for you region. So you end up having done everything and the region itself isn't at 100%. So you'd have to save at rhe start of a region before doing anything, then save every time tou actually do something and it registers and hope something isn't already glitched along the way. I'm sorry but that ruins any and all pleasure I have in gaming, even for a game that I really like. At this point I'd like an official answer from a community manager reassuring us the devs are on it, some sort of acknowledgement that they heard us would be nice.



  • FameTree
    6 posts

    @starbuckviper i think you are suposed to bring the box to him. if you still can, drop it at his new location.

  • Starbuckviper
    7 posts

    @fametree I did that to start with, put it at his feet but nothing so i thought I had to destroy it, but nothing happened. Its not reset and I can talk to the nudists at the bottom but the box is not there at all. 😕

  • Starbuckviper
    7 posts

    @ubi-swaggins Glad I've been streaming it so went back through the VOD and found my go at it: https://www.twitch.tv/videos/801298648

  • Xaelur
    7 posts

    The box ins't spawning for me.
    I even traveled to Norway and random lookout before returning and still no Box.

    If i try and take off all my clothes at the Camp a weird loop starts where the Camera goes into the air above me and i can hear the woman scream "let the Dane go, someone will see us" something like that before the camera goes back down only to go back up in the air again with the same woman saying the same thing again, looping everything again and again until i leave the area.

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone, thank you for reporting this issue to us. I can appreciate that it must be frustrating, and we'll do what we can to get this investigated and resolved.

    Could anyone advise us of specific reproduction steps (if different to those already provided) and also create a short video clip demonstrating the issue? It would help us massively to understand what the issue looks like in action, and how we might address it. Thank you!

    Official Response
  • oGRANTx
    1 posts

    I had the same problem however I seem to have figured it out! After you steal the box of clothes you have to drop it beside his tent which is just down the hill a small bit from where the quest giver is standing. Once you do this you can then access a dialogue option with him!

Suggested Topics

Community Details

35
Online
131.1k
Users
22.7k
Topics
118.2k
Posts