Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Shayeza
    5 posts

    @alojin yeah same. I’ve got 125hours playtime now and the only thing I can do is to collect fish and animal resources for the village. I guess we have to wait another month if we’re being optimistic...

  • DubDee716
    3 posts

    @ubi-borealis I didn’t pay for this game to have real world tasks to complete. Fix the damn game Ubisoft had its most profitable quarter ever this is utter [censored] this game should have been pulled what garbage. Another update and this bug isn’t even mentioned.

  • DubDee716
    3 posts

    @ubi-woofer I don’t know how to do that and I’ve wasted enough time on this garbage game. If you want to refund my money and pay me to find bugs in your games let me know

  • Ubi-Borealis
    Ubisoft Support Staff 1381 posts

    Hello there!

    Thank you for continuing to share your experiences with "Firing the Arrow," as well as your feedback with the ongoing investigation. The development team is still looking into this quest further, which is why it was not included in TU 1.2.0. We currently have no new updates to share from the investigation. Once we have any new information available, it will be posted within this thread and within the News & Announcements forum.

    The development team are still looking to collect the save files from affected players. If you play on PC/PS4, please would you be able to open a support ticket and submit your saves for investigation.

    @j1mboDE - Thank you for taking the time to record a video for us. I've passed your report along to the development team for a closer look.

    @Shayeza - Thank you for submitting your save files. These have been forwarded to the development team.

    @Alojin - Please be assured that the development team are still looking into the NPC with coins not spawning. Once we have any more information from the investigation to share, they will be posted in the forums. I have also passed on your feedback regarding a quest reset feature.

    Thanks all! 😊

    Official Response
  • Shayeza
    5 posts

    @ubi-borealis hi! I updated my case with this and a picture of my whereabouts:

    Hi! I scoured Lunden a little more with Odins sight, and I found that it still popped up two blue quest-signs at the temple of Mithras even though I’m finished there. It’s the “Liber Antiquae Deorum” paper and another, now unclickable, note at the desk there. (And the key from Octavians quest to the guy who stole his statue still pops up, unclickable if there is any correlation) Hope this helps!

    Do any of you other guys have the same “glitch”? Maybe it’s connected?

  • jeffiroth311
    5 posts

    @alojin Same for me. Such a letdown that this has basically become a Viking hunting and fishing game for me at this point.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @shayeza Thanks! I've added the image to our team's on-going report. 😊

    @jeffiroth311 I'm incredibly sorry that we do not have any further updates we can share on this issue right now, but please rest assured the teams are doing their best to address the various bugs that have been reported to them, including this one. Updates will be shared here as soon as we have any new information.

    Official Response
    1 posts

    In the part of the mission where you have to find a coin for the contest there's nothing, I've watched just about every video on youtube and nothing shows up in my game. Ive restarted the game a dozen times and even left to do other missions and every time i try to redo the misson same thing

  • Ubi-Mark.
    Ubisoft Support Staff 445 posts

    Hello @ODINS_WRATH89,

    Sorry to hear that you are experiencing this issue.

    I merged your thread with this megathread for better visibility 🙂

    I just checked this for you and I can see that this issue has been reported to the development team and it's currently being investigated. Once we have an update, we are going to let everyone know through this thread and the patch notes.

    Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

    Official Response
  • hanax2020
    5 posts

    @ubi-woofer was so fed up that i didn't play for two months...newst patch didn't solve the probkem...tried to copy save games to usb...didn't work with the first device...second...nope. sorry, i tried to help even though it's not my job. even though i got a product which is not what i've paid for...

    but right now, i don't really care summer is comig, the next time i'll play will be october, maybe then there is a patch. if i am REALLY fortunate...

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @hanax2020 Hey there, and apologies for the continued aggravation caused by the error with the NPCs with coins not spawning during this quest. Currently, this issue remains under investigation, but we sincerely appreciate your continued patience and understanding throughout this process.

    Official Response

Suggested topics

Community details