Welcome to discussions

Quick Suggestions

  • xlegionx33
    5 posts

    Still no change here either. Firing the Arrow is in my quest log, but no objective underneath it nor anyone with a coin spawning.

  • kbhughes1999
    1 posts

    Newest update still failed to fix the firing the arrow mission for me, the npc with the coin still refuses to spawn in the market and I've bored myself with side content and can no longer do anymore of the main quest line 🙂

  • Alojin
    Original poster 10 posts

    1.10 still broken. The Patch Notes said something with fixed a issue where the objective would not update but nothing changed. Still waiting for that NPC with the coin to start. How is it possible that after 2 Patches we still cannot continue the main Game. Just put in some reset Mission button or something.

  • hanax2020
    5 posts


    same here. yesterdays patch did...NOTHING...

    PS4 as well

  • Ubi-Woofer
    Ubisoft Support Staff 1061 posts

    Hey everyone,

    Thanks for reporting your issues with obtainng the coin in "Firing the Arrow" to us. I've created this separate megathread to track reports of this specific issue, and ensure that we gather all of the information and files that we need for the developers to look further into this.

    The issue itself has already been raised to them however it is not one that they have been able to reproduce so far. As such, they have requested save files and further videos of the issue from affected players, which they hope will help them to identify the issue and fix it. If those of you playing on PC or PS4 could share your save files with us via a support case or Live Chat, we would greatly appreciate it.

    Thank you all for your time and help in advance! 🙂

    Official Response
  • Gramze8302
    1 posts

    @ubi-woofer my game freeze in the Archer part of The quest, can't do any thing exept enter The menu and use The fishing equipment and the horn.

  • Ubi-Woofer
    Ubisoft Support Staff 1061 posts

    @gramze8302 Hey there, if you're referring to the shooting contest that takes place after you acquire the Arrow's coin, this is not an appropriate issue to address in this thread as this thread is exclusively for the issue with the NPCs in the market not being available to retrieve the coin from. If reloading an older save and progressing to the same point does not allow you to proceed, please open a separate thread for this issue and include a video of it so that we can look further into this. Thanks!

    To anyone affected by the issue the title of the thread concerns, please refer to my above advice and provide me with the requested information for us to look further into this. Thanks! 🙂

    Official Response
  • guest-iO1FZC2T
    1 posts

    Mission objective to collect the coin after talking to Stowe in the western market never appears. They said they fixed this issue in the patch (Dec 17 2020) however it isn't fixed in my game. Ive played 40+ hours after getting to this point so I cannot just go back in save files anymore nor would I want to. This problem has been in the game for 2 months now and not fixed what is the issue Ubisoft!!?? I cannot proceed with any story arcs anymore until I complete this. And paid 80$ for a triple A title game that was hardly finished when released.

  • jeffiroth311
    6 posts

    @ubi-woofer I sent my save files on Dec 15th through a support case and was told it's a known issue and it is being looked into. I still can't progress in the game.
    Case #13596112

  • Alojin
    Original poster 10 posts

    Holy moly even after the 3rd Patch (1.1.1) the npc with the coin does not spawn. Not even a mention in the Patch notes. Cyberpunk workes for me better than this (sorry for my language but after 3 patches i´m [censored]) [censored]. I just want to finish this broken game so i can finally move on and never even touch a ubisoft made game.

  • xxCDOGxx
    6 posts

    Still happening for me on 1.1.1.

  • Brawlz_DE
    2 posts

    firing the arrow quest is still buggy
    the NPC with the coin don't spawn
    XBOX series X

  • Harry_Clfd
    1 posts

    In firing the arrow, no one spawns in for me to get a coin for the arrow contest. I’ve tried reloading older saves but nothing works and I’ve come to a halt on the game and can’t play any more story missions.

  • DubDee716
    4 posts

    Same here still unable to proceed after update 2.1


  • guest-5oKCCl6O
    1 posts
    This post is deleted!
  • jeffiroth311
    6 posts

    @alojin Yeah I'm extremely disappointed with how this has been handled. I won't be buying another Ubisoft game within the first year of release anymore.

  • Rockstar6775559
    1 posts

    I currently stuck on this quest because the NPC will not load with the coin. I can’t continue in with the story until it’s fixed.

  • Feraldusterers
    1 posts

    Just downloaded the newest update and i still (since launch) cant finish the quest. The NPC doesnt appear anyway. Tried to raise a case, but the submit button never becomes selectable. Kinda want to get 100% on all regions. Is this going to be fixed at all?

  • FuntomDoll
    2 posts

    After talking with Stowe, I cannot find the guy I have to get the coin from, and only saw one guard patrolling the market. I've tried everything except for starting a new game as that is out of the question. At least, there is a lot more I can do till this is fixed.

    Xbox One S

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hey everyone!

    I apologise for the delayed update. Thank you for continuing to update this thread. The development team are still investigating this issue further, and they are interested in collecting the save files of affected players. If you play the game on PC/PS4, please can you open a support ticket and attach a copy of your save file for investigation. Once you've done this, please can you post your case number within this thread so we can ensure the save is forwarded to the development team. Thanks! 😊

    jeffiroth311 - Thanks for opening a support ticket and attaching your save file. This has now been passed to the development team.

    Would you be able to open a support ticket and submit your save file for further investigation? Thank you!

    Official Response

Suggested Topics

Community Details