Welcome to discussions

Quick Suggestions

  • j1mboDE
    3 posts

    @jeffiroth311 sad and true

  • DubDee716
    4 posts

    Game ruined for me. Only real solution for me would be a refund. What a waste of time! Never again will I buy from Ubisoft.

  • Ubi-Borealis
    Ubisoft Support Staff 4132 posts

    Hello there @jeffiroth311, @j1mboDE & @DubDee716,

    I'm sorry to hear that you have been affected by this issue, and that you are unable to progress in "Firing the Arrow." Thank you for taking the time to share your experiences and feedback with us here. Currently, we have no new information to share with you all from the ongoing investigation.

    I understand that this may not be the update you were hoping for, and apologise for any disappointment caused. Rest assured that the development team are investigating this issue further, and that the player support team will continue working with you all to try and get this issue resolved. 

    @DubDee716 - If you purchased the game from the Ubisoft Store, you are welcome to open a support ticket to submit a refund request. I would recommend taking a look at the digital and physical refund policies prior to opening a request. If you purchased the game from another retailer, you would need to contact them for further assistance with any refund requests.

    Thank you 🙂

    Official Response
  • willysky44
    2 posts

    I just got the same exact issue and the game unplayable now.
    My only question is, can I get my money back? Or is it raided by UBI viking.
    I bought this THING from EPIC GAMES.

  • willysky44
    2 posts

    I've asked EPIC GAMES's support for refund, but they said I cant get it because I played this thing over 2 hours.
    This is a complete swindle and I'm really disappointed for UBI's lack of skill of fixing bugs.

  • Ubi-Borealis
    Ubisoft Support Staff 4132 posts

    Hello there @willysky44,

    I'm sorry to hear that you've encountered this issue with "Firing the Arrow." Thanks for taking the time to share your report with us.

    The development team have been investigating this issue further, and they intend to deploy a fix in a future update! I'm afraid we don't yet have an ETA for when this update is to be released. Once we have any updates to share, these will be posted within this thread and in the News & Announcements forum.

    I'm sorry to hear that you were unable to request a refund from Epic Games. Please note that we have no control over another retailer's refund policy, and you will need to reach out to them with any concerns or queries.

    Thank you 🙂

    Official Response
  • WolfieWinter7
    2 posts

    I'm stuck at the part where i have to complete The Arrows challenge but when i go and talk to the npc and she says the dialogue nothing happens i tried reloading an older save that didn't work and i tried restarting the game and nothing worked

  • Ubi-Woofer
    Ubisoft Support Staff 1262 posts

    Hello everyone,

    I am pleased to say that TU 1.3.0 introduced fixes for two different issues with the "Firing the Arrow" quest! These were that the NPC with the coin didn't spawn, and that when completing the Arrow's challenge, the targets did not appear. You should no longer encounter either of these issues when completing this quest.

    If you do find that the issue relating to the missing NPC with the coin persists since the latest title update, it would be appreciated if you could provide us with a video demonstrating the following, so that we can forward this to the developers and reopen the investigation into the respective issues:

    • You have the latest title update (1.3.0) installed (you can check the game version from the menu)
    • You are unable to locate the NPC with the coin

    Thank you all for your patience and understanding while these issues were investigated and resolved. I'll mark this thread as resolved now, as the issue it concerns is considered resolved, but we will be happy to reopen the investigation if it should be necessary. Thanks! 🙂

    @wolfdragneel - Welcome to Discussions! I am sorry to hear that you are struggling to complete "Firing the Arrow". It sounds like you may be stuck on a slightly different part of the quest to that which this megathread is for, as you have not mentioned being unable to acquire the coin to take part in the challenge, but rather that after completing the challenge and talking to the NPC, the quest does not progress. If this is correct, could you please open a new thread for the issue you are having and we can investigate further with you there? It would be best to keep this thread specifically for the issue with NPCs not granting the coins to take part in the Arrow's recruitment challenge. Thanks! 🙂

    Official Response

Suggested Topics