ubisoft discussions

Quick Suggestions

  • 7 Likes/295 Replies/31360 Views
    1 posts

    still not fixed with today update on Xbox one . what to do now ?, i'm stop in the prgression of my story .
    any news maybe about why its not fixed . and when it will be .
    it would be nice . i don't want to put the game aside, i'm just alot in it and whant to continue my progression .

  • ChiefTravis
    1 posts

    Just got on to see if I can walk through the smitten but still can’t unfortunately.

    1 posts

    Just tried leaving and doing other stuff and then came back and rehit the trigger points all the way back to the kart again, and now it will allow me to enter the door, but glitches me into the foundation of the mitten.
    I was in the cave once before working on the mission and in trying to reach one of the chests in the back I got stuck in some roots and glitched into one of the kegs and was stuck, so I fast traveled back to the closest synch and that is where my problems began.

  • darchu17
    1 posts

    This issue wasn’t fixed in the last update for anyone wondering. There is an invisible wall not letting you enter Skymir’s Mitten if you entered it previous to the quest. Not knowing it would be a quest breaker, I left Jotunheim and spent 30+ hours of gameplay before trying to go in again so going back to a previous save isn’t an option for me. Any chance you guys are going to fix this soon?

  • We88ie92
    5 posts
    This post is deleted!
  • Raz1977HD
    1 posts

    @darchu17 you have to retrace the steps throught the broken trees and it will let you in.... but once inside still bugged as before.

    this only happens if you been there before cachting loot

    nice job on the update...lvl 200 and cant finish the game.....

  • Anderson11588
    1 posts

    Still won't let me go back in to get the last two blood stones which i need to get for my platinum trophy

  • c23.sniper
    3 posts

    The bug is still there even after the new patch. I'll do other stuff until ubisoft works it out

    94 posts

    Me too, as well as the Sons of Ragnar, this is getting on my nerves now tbh

  • Tex45ACP
    1 posts


    Please fix this quickly. it's not like this was just reported; it should have been a priority for 1.04.

  • cjrotman
    2 posts

    Same glitch. Game breaking. Needs to be fixed ASAP.

  • vSkullyKz
    9 posts

    @souldrinkerlp i finished the entire story in the meantime, you'll love it, sadly all im waiting on is a patch for this and i should have 100% idk yet

  • Assassino89NL
    12 posts


    Thanks for the headups, we will wait for it to be fixed, this should be a #1 priority thing to look for.
    oh btw their is a floating key aswell in Jotumheim for the wealth all the way southest of the map, where you need to shoot the box out of air (Which has the key in it)
    i founded a workaround with the slowmo bow while airborne, but its still a bug and need a fix aswell

    4 posts

    So they didn't update to fix everything else apart from the 1 major glitch can I just do a patch to fix this quest please

  • thebog1984
    4 posts

    @davidanmolly I second that idea, a singular patch just to fix this one issue because it is seriously a pain in the [censored].

  • Evidka
    1 posts

    @ranger_two14 Hi, I have a bug in this mission too but it is The Mead in the Cauldron (in the Feast Hall) - I cannot empty that damn thing, I did all these things they wanted me to do (talking to guests, drinking...) but nothing is happening... No one is interactive anymore...
    Even after the big Update... Does anyone have the same problem?

  • megaweltG
    1 posts

    Earlier-when i first came to the jotunheim- i did go into this cave for ymir's blood stones. Because of the quest i came back and i had this exact bug over here.
    Fix: Just load back to the save data where you didn't go in this cave. Or load back to the point where you didn't even go to the Jotunheim yet. I know it's annoying that you have to go back but this is the only fix that i can find. Cave lets you enter just once guys.
    BTW sorry for my english guys(if there is any mistakes or typos). I am not native in eng. I JUST WANT TO HELP 😞 hope this helps.

    94 posts

    @davidanmolly dude, the Ubba glitch is still happening, it's worse, trust me, I have both that and the Jotunheim bugs.

  • TheGodlyBacon
    10 posts

    I'm unable to enter Skrymir's Mitten for the Lost Cauldron mission because I went in there earlier to collect two of the blood stones. I thought the recent patch would fix this, but nope. Nothing.

    Really frustrating to deal with since people told me how important Jotunheim is, yet I cant friggin' finish and I'm almost completed with the main story (I think).

    Anyone else have this issue?

  • TheGodlyBacon
    10 posts

    @thegodlybacon An update.

    I can now walk through the entrance, but upon entering my character glitches underneath the floor. I've tried about ten times and the same [censored] everytime.

Suggested Topics