Welcome to discussions

Quick Suggestions

  • Torusya
    16 posts

    @ubi-swaggins I am about 3,5 hours in, completed a few side quests before. Something is up with dialog, as he won't even talk as we walk to the dock. Do not think it is platform related as I see people on Xbox, PS4 and Stadia complaining about the same.

  • Steamtrainj29
    4 posts

    Is there any fix yet for Xbox? I also experienced something similar with The Dregnr in the cave and he wouldn’t speak to me.

  • Steamtrainj29
    4 posts

    @sucgshadow exactly and it’s sucks more when you already got 8 hours into the game 😔

  • subhajit_1992
    2 posts

    it just bugged on me ..
    dear ubisoft please fix this ..what kind of a game has a bug in there main missions these days ...
    its a game breaking bug ..playing on ps4..
    so disappointed


  • GingxrReaper
    2 posts

    I started the campaign over and it worked!! a lot of effort but worth a shot for anyone that isn't willing to wait this one out 😑

  • subhajit_1992
    2 posts

    @gingxrreaper

    i spent like 8 hours doing all other stuff ..now this got bugged on me ...no way im starting all over again

  • Bumbumsel
    10 posts

    I fixed it by starting a new game when the download is completed.

  • VikingTusero
    3 posts

    @bakwoodz91 I don't think we are SUPPOSED to stick with the main quest, but the solution to this bug seems to be it, unfortunately...

  • PotholedMovie24
    1 posts

    Im stuck in the prodigal prince. I have tried to restart but its not working

  • skoggi
    8 posts

    Started new game, only did main quests, and able to complete it.
    When it failed before I had "warlock mystery" not completed and bugged (even if I killed hunter)

  • Ubi-Swaggins
    Ubisoft Support Staff 340 posts

    @bumbumsel Thanks for confirming the workaround fixed the issue for you.

    Official Response
  • zulu306
    7 posts

    got that bug also. frustrated

  • DivPrime
    2 posts

    Same issue here. How did this get past QA testing? Cant proceed past "Air Assassination" step in Prodigal Son: Train with the Hidden Blade. Have tried multiple save game reloads from various points.

  • lilsosa21
    2 posts

    I on Xbox One X and I encountered the same issue with my digital copy.

  • Awesome-Name
    2 posts

    I'm also having the same issue.

    I tried replaying the mission multiple times and adjusting the graphics settings. All my drivers are also up to date. I contact support through chat and requested a refund.

  • skoggi
    8 posts

    @ubi-swaggins If you implement the World events/Mysteries in the quest logs, and an option to cancel/quit these might help people to a workaround 👍

  • guest-yvTFVrSF
    13 posts

    @ubi-swaggins Starting the game from the beginning isn’t a ”workaround”! I’ve played for eight hours and I’m not starting over. Get a hotfix out ASAP, this is beyond embarrasing.

  • DivPrime
    2 posts

    Ok so I resolved my issue. Load a save game prior to Sigurd meeting his father and the game transition into the hall. My theory is that once Sigurd, Basim, and Hytham walk to the training area, you can immediately tell if the game breaks. When the scripts run properly, the Basim and Sigurd will move around the training area with instructions. In my broken game, they all just stand by the entrance to the training area. You get a few steps in and then the green quest objective indicator stops showing up. When I loaded a game that was saved inside the hall after the Sigurd + Styrbjorn conversation, if you are in a broken state, you will remain in a broken state. There was no need to update any drivers or change any settings, just needed to find the right save game state. Hope this helps others.

  • T3W2032
    2 posts

    So, I receive the hidden blade, go down to do the training, I assassinate the first dummy, stealth attack the second, then when I go to kill the one on the ledge I assassinate the dummy yet the quest doesn't move forward, I have watched a walk through of this quest and after you are supposed to do the air assassination, I did that even without the arrow above the dummies head and nothing happened, no dialogue or another arrow somewhere else, I am stuck

  • Awesome-Name
    2 posts

    @divprime Thanks but I tried loading game states right as Sigurd got off the boat and that didn't help.

Suggested Topics

Community Details

32
Online
138.8k
Users
24.3k
Topics
125.8k
Posts