Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • BoSxFALLEN
    3 posts

    @zeldafan4life I am having the same issue except on ps4, I get to training area and then NPCs just stand there no dialogue or instructions on what to do.

  • BoSxFALLEN
    3 posts

    I get the hidden blade then follow Sigurd to the training area except once having left the longhouse no dialogue proceeds and once I arrive at training area it says practice with the hidden blade however it will not allow me to move any further on mission

  • SUCGShadow
    2 posts

    @ubi-swaggins I'm on PC

    Have tried to trouble-shoot it for the last couble of hours, and gets stuck the same place each time. Also happening in another quest (cant remember the name of it), [SPOILER] where you have to help a guy choose a crew captain, after fighting the 3 guys nothing happens.

    Seems in both cases that a missing promt is the reason, you can't interact with the npc in both instances.

    Hope it gets fixed very soon. Kind of sad to have bought a game you can't play.

  • ZAKR13L
    Original poster 4 posts

    @sucgshadow Have the same bug with those three as well. Another one I've encountered is with the dude in Hildisvini Crag. After beating him, he falls on the ground with a prompt to speak but then it disappears and he just sits there sniffing dirt. - I'm irritated with all these bugs, its stupid and makes it hard enjoying the game. All the while my girlfriend has been playing along beside me and all she has experienced is a minor audio bug here and there, otherwise her game has been running perfectly and it's making me want to pull my hair out lol.

  • King_Butcher_VI
    3 posts

    @zakr13l yeah thats the first one i bumped into, just left him as i did not know what to do after beating him, also the guy at the edge of a cliff with crates and a horse and carriage, not sure if its a bug but i didnt know how to progress with that one

  • BYRNE-Ix
    4 posts

    @zakr13l I had a bug with the same guy but couldn't speak to him at all to start it, also the world event just south of it where you have to find a comb, couldn't turn the quest in, averaged a quest breaking bug every hour of play so far...

  • Blhess
    3 posts

    I'm having the exact same issue on PS4 Any resolution?

  • fodspeed
    1 posts

    I'm at the mission called prodigal son, and it works fine until the point when hidden blade assassination training. Once the training is over.

    Sigurd says let me on doc and then he don't say anything, I get option to speak but clicking it makes him go to doc but without saying any vocieline. And then just stand at dock and cutscenes never triggers

    It's so annoying.

  • Nonstop2008
    2 posts

    Also bugged in this mission, I can’t even get to the part where Sigrud wants to sprak with me. Playing on Xbox one x.

  • Nonstop2008
    2 posts

    I have loaded the mission from the start, you have te see the king and listen to Sigurd story. After that, I could compleat the mission.

  • daigotsumax
    1 posts

    Manage to unblock it by reloading to before I got the Hidden Blade.

  • tobdad95
    1 posts

    I’m having the same issue, I’ve tried deleting saves and going back over the previous mission to get here but just stuck at the docs with Sigurd, can’t even leave the area or do anything else. Absolutely shocking should have been fixed with the day 1 patch.

  • buzz3508
    1 posts

    I'm also stuck at the docks with Sigurd, no amount of loading different saves, starting the quest over, or even uninstalling and reinstalling the game will get me past this part. Why release the game with the potential for these issues? I gladly would have waited a few more months to get a fully functioning game.

  • Zaphdoe
    1 posts

    Also having this bug on the PC. Absolutely infuriating as I just want to play the game.

  • ben_person
    3 posts

    Hmm. I had an issue with this quest, too. I got about halfway through the training, and then it stopped prompting me for new instructions and wouldn't let the mission continue.

  • mike.dismukes
    1 posts

    Same here running on google stadia 😞

  • ZAKR13L
    Original poster 4 posts

    @zaphdoe I got it to work, sadly, by starting a new save file and skipping all side content and just going through the main story. Got dialogue in other parts of my game in which I didn't have before. Dunno, hopefully it doesn't die again. When the game is working, its a lot of fun. Sadly that isn't happening a lot.

  • gustafsson85
    1 posts

    I have the same problem, and i have quests that I can’t talk to the quest givers. My solution was to continue the main story to end up on the docks and I can’t continue to talk to my brother also.

    xbox series x

  • Devaustus
    5 posts

    Same issue on PC, any fix yet? Can't continue with my game!


  • KevinSly
    2 posts

    Same issue with “Prodigal Prince” and “Rolf the Raider” quests.Playing on the PS4. Disappointing that this game has so many day one bugs.

Suggested topics

Community details

22
Online
125.5k
Users
21.7k
Topics
111.8k
Posts