Welcome to discussions

Quick Suggestions

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    Hi all,

    Thank you for reporting this to us, we're sorry to hear you've been having issues with this Quest.

    @Khyrena Glad to hear that you were able to get around that, if you put the graphics back to where they were will it continue from that point or is it causing more issues?

    @Zinco1993 @CYMM3TRY
    What platform are you guys playing the game on?

    Official Response
  • Dani475c
    3 posts

    Hey. Im sitting on the ship to england for the first time but we are not moving out from the habour. I cant do anything exept move the camera angle around. Ive seen on youtube what there is suposed to happen but that just dosnt happen. Can anyone please help me.

  • HarveyM62
    1 posts

    @dani475c same thing is happening with me

  • Az1ram
    1 posts

    Hey, just resolved it.

    For my problem, which is the cinematic that doesn't launch after you board the sigurd's boat, i went to the dice player near the main house and engage the conversation. I denied the game and when I board the boat, the robleme was resolved.

    Hope it can help some of you

    7 posts

    @ubi-baron hey im on pc using the ubisoft launcher

  • JeanVerton.be
    1 posts

    @az1ram Same here, graphics on low and talked to the gamer

  • malfie2005
    6 posts

    @cymm3try Same here. I get to the middle of the ocean and we just stop, can't move, can't change quests, can't dive out of the boat. They intro credits and exit to animus never happen.
    I'm using PS4

  • malfie2005
    6 posts

    @jeanverton-be How do you change the graphics level? We can't find it on Ps4

  • malfie2005
    6 posts

    @az1ram tried this but still not helping. We're stuck in the middle of the water with only option to return to title screen or option menu.

  • malfie2005
    6 posts

    @ubi-baron I'm on PS4 and having the same issues. The scene that's supposed to be triggered after Sea of Fates to take us to animus just doesn't happen and we're stuck in the middle of the ocean

  • Axeljbbb
    9 posts


    im on PS4 and before starting the mission Seas of fate I try to talk to Sigurd but a message pops up saying that “I can’t continue until the game is fully download”. I had the limited edition PS4 disk.

    can you give me please a solution?

  • Jurassicpatrick
    2 posts

    When the quest Birthrights ends the next quest does not begin. I have verified the game files and reloaded several times, even going back hours. According to guides sigurd should appear in the great hall, he does not. He does however show up at the dock after some time but I am unable to speak to him.

  • Fred_P
    15 posts

    After talking to Sigurd on the docks and getting in his ship the ship just sits there going nowhere.

    One reason this might be is that after the conversation cinematic plays but before getting in the boat, I can see using Raven Vision that two of my allies that I assume should be in the boats get teleported into the ground beneath where I stand after the conversation cinematic, then one of them dies, and the other one stays underground.

  • xX-Olbataaard-X
    13 posts


    When Eivor jump on the Sigurd's boat, we have a little scene of the crew that tails on the sea, leaving their lands and go to England. During this cut-scene, the sailing of the boat just take off, and the boat stop in the middle of the sea... And its impossible to continue the game...

    I've try to take on older save, i've try to restard the game and the Xbox One X, 15 times i've try, the boat stop on the same spot, and i cant do nothing.

    Please, find a solution, i cant continue the journey...

  • xX-Olbataaard-X
    13 posts

    @pikijecar Hi, i have the same bug on Xbox, i've try everything, its doesnt work, the boat stop and we are stuck...

  • xX-Olbataaard-X
    13 posts

    Same problem, stuck in the middle of the lake...

  • Theholyzensage
    2 posts

    ok so im on the Seas Of Fate quest and every time i get on sigurd's longship the game just statically stays in place and doesn't progress the quest basically im stuck in sigurd's boat at the pier and nothing else happens

  • rayuki666
    2 posts

    come on guys fix this! game breaking bug at the moment can't progress no mater what i try. ON PC
    tried lowering graphics didn't help, it sails to the middle of the ocean and they drop the sail and just sit there afk. can only exit and reload.

    i think it has something to do with the blacksmith, he is sitting in the water before we take off and starts swimming after us when we leave! surely this is the issue causing it to bug isn't he supposed to be on a boat??

    im on uplay+ so this is extra frustrating as its time i can't play the game wasting my subscription.

  • Ubi-Spud
    Ubisoft Support Staff 704 posts

    Hey there! Are you stuck at the dock in Norway? If so, could you fast travel elsewhere then travel back? If the issue persists, try loading an earlier save.

    Official Response
  • Axeljbbb
    9 posts

    Hi Ubisoft support:

    It’s a general problem that happens to a lot of users now on PS4. I bought the physical limited edition. The version is the 1.0.2.
    When I try to talk to Sigurd during the chapter 5: “The seas of fate” before taking the ship; a warning message appears saying “You may not continue until the game is fully installed. Please wait for Assassin’s creed Valhalla to finish installing and try again.”

    Its been 24 hs of this problem and it’s not solved. And of course the game is fully installed as I checked it before. Can you please tell me how to proceed? Thank you!

Suggested Topics

Community Details