Welcome to discussions

Quick Suggestions

  • UNSOLVED [PS4] Unable to progress with "The Seas of Fate" as the game is not fully installed | POST HERE

    5 Likes/226 Replies/5857 Views
    sasanoahlukas
    2 posts

    I have buy game over playstation store and i have same problem i have instaled again all game and same problem at same place

  • Ubi-Borealis
    Ubisoft Support Staff 4132 posts

    Hello there @sasanoahlukas!

    I'm sorry to hear that you're encountering an installation error during "The Seas of Fate." Thanks for taking the time to share your report with us.

    If you haven't already, we'd like you to first try some troubleshooting steps. First, please can you fully uninstall Assassin's Creed: Valhalla. This includes any additional DLC or expansions you may have (such as Season Passes).

    Once you have done this, please can you try these basic console troubleshooting steps. In particular, please Restore Licences and Rebuild the database of the console.

    If you're still encountering the error, please can you provide us with the following images:

    • An image of the error message
    • An image of the "Information" panel. You can find this by pressing the "Options" controller button and selecting "Information" when over the Assassin's Creed: Valhalla tile in the system dashboard


    I recommend uploading these images to an online sharing platform, such as Google Drive or One Drive. You can then send us a link to these images, and we can take a closer look.

    Thanks! 😊

    Official Response
  • MrHolotrop
    1 posts

    Can you PLEASE explain to me, how is it possible, that such major bug still persist after 9 months?! I just bought it today for PS5 and after 3 hours I can’t proceed because of this. And because I have a digital copy from PS store I don’t get a refund. Shame, really, really shame.

  • Ubi-Woofer
    Ubisoft Support Staff 1258 posts

    Welcome to Discussions, @mrholotrop, and thank you for sharing your report of this issue with us.

    Can you please try the steps posted previously above by my colleague @Ubi-Borealis, as well as the additional ones in this PS5-specific guide? We'll need to verify that troubleshooting and reinstalling the game does not resolve the issue for you before we can can continue with our investigation. Please provide us with the requested images if the steps should not resolve the issue for you, and we'll then take a closer look. Many thanks! 🙂

    Official Response
  • steelhuevos
    2 posts

    @ubi-woofer I just bought the game a few days ago, and now I find out that there has been this major issue for almost a year and nothing has been done to fix it?
    How is that possible???

    I followed all the steps and still get the error.

    I got the "Cannot read disk" error a bunch of times.

    Should I return the disk? How can you not have a fix 11 months in?

  • steelhuevos
    2 posts

    @steelhuevos I returned the game this afternoon and got a new one. Same error.

    Is Ubisoft really not going to fix this?

Suggested Topics