Welcome to discussions

Quick Suggestions

  • Chockellaa
    6 posts

    @blownsmoke_420 I have already set everything to low but still not working 😕

  • h4ckerv2
    2 posts

    I have a bug, this happens when we go to England and break the chains, we must stop at a pier and kill a few Englishmen, then we go like a cabin and there are 2 people when we talk to them we become allies and they stay there , unable to move or anything, I've tried everything, restarting, verifying game files, changing the gender of the character, etc. URGENT HELP PLEASE IMPRESENTABLE TO PAY 100 DOLLARS FOR THE ULTIMATE EDITION AND CANNOT PLAY FOR A BUG.

  • mickythumb
    2 posts

    @mickythumb just tried the graphics fix an it worked for me

  • h4ckerv2
    2 posts

    I have the same error

  • Kuratoro
    97 posts

    @h4ckerv2 Try the graphics fix like everyone else, should work:

  • Kuratoro
    97 posts

    @h4ckerv2 It is a strange bug indeed but very common now unfortunately. This video explains how to fix it. In short you should change graphic settings:

  • toasteroven47
    11 posts

    I too have experience the gamebreaking "Unwelcome" bug where the cutscene doesn't play and I'm left standing only able to control the camera.

    I have tried the workaround at every graphics level without skipping any dialogue and the issue continues.

    I tried live chat with someone from Unisoft support but they were no help.

    What can I do if the workaround doesn't work? The game is completely unplayable for me in this state.

  • StickerSticker
    1 posts

    @dragonmaster91 it didnt work for me

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    We're sorry to hear that's been occurring.

    If you haven't already, we'd advise making sure you've tried Clearing the Consoles Cache and Rebuilding the Database through the steps in the guide here.

    Official Response
  • may_uri
    1 posts

    @kuratoro Your solution actually really worked. I'm really thankful for your solution but I'm also really mad that that kind of fixing the problem is even necessary. But seriously, thanks a lot kurato! Until the next problem...

  • Ni_rob
    2 posts


    It is strange, but it worked. Thank you!

  • Ubi-Swaggins
    Community Manager 421 posts

    Hey folks,

    I am sorry to hear that you are encountering issues with this quest.

    It has been raised to the team and they are working to resolve it as quick as they can.

    Apologies for any inconvenience

    Official Response
  • Ubi-Swaggins
    Community Manager 421 posts

    @chockellaa Sorry to hear that changing the graphics settings did not work for you.

    Can you confirm if you have attempted to verify the game files as @blownsmoke_420 suggested?

    Official Response
  • Chockellaa
    6 posts

    @ubi-swaggins Yes i did check the game files then turned my graphics down but nothing changed 😕

  • Ubi-Spud
    Ubisoft Support Staff 704 posts

    Hey there, thanks for getting in touch! I am sorry you are having this issue. We are aware of this one and a fix is in the works. In the meantime, try setting your World Details to Ultra, restart, and rerun the quest. If this works for you, you can change the settings back to normal after you get past this issue!

    Official Response
  • Nessis_Hamsta
    3 posts

    same problem... 😞

    3scans of all files yesterday
    -1st scan say: repair and downloaded 329MB
    -2nd scan say: repair and downloaded 680MB
    -3rd scan say: repair and downloaded 1,66GB

    2scans today
    -no problem

    graphic settings: lowest setting from the beginning (incl 30fps)
    setup: FX-8350 throttled to 3.0GHz // RX 570 XT throttled to 1.1GHz

    i can't go lower with the settings...... 😞

  • Nessis_Hamsta
    3 posts

    i turned the settings to "middle" and it works....
    do i turn the settings back to "low" >> stuck

    sry, but i'm confused

  • Chockellaa
    6 posts

    @nessis_hamsta Wow it actually worked, i don't understand why but ok.

  • Small0606
    7 posts

    Hi guys,
    After 3 hours of game I'm arrived to england and after i take ragnarssons camp and utied the hostages I've got a loading screen. After that loading screen the game just freezed. actually im in the game and i can look around but cant move out of the long house. I've tried a lot of things to solve the problem but nothing helped for me. To this point the game runs great..
    Somebody can help me ? Or soon a new patch coming ?

  • Psych0_Trauma
    60 posts

    It didn't start until the most recent patch dropped. I could play the game for hours without issue, but now it will literally just freeze in certain instances. It's not my rig, but it's definitely the latest patch.

Suggested Topics

Community Details