Welcome to discussions

Quick Suggestions

  • M1nDTr1cK2020
    21 posts

    When I talk with the two merchants in the longhouse, after the talk cinematic the game starts to load and when I get back to it, all characters zigurt, ivor and dag are clumpt together and I can't move nor do enything else apart from options menu and quit

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello all!

    The investigation into "Unwelcome" was marked as resolved following TU 1.0.4.

    As there have been no new reports for this issue, I will now be locking this thread. If you're still unable to proceed in "Unwelcome" following the last Title Update, please can you open up a new thread so we can keep this investigation separate.

    Thanks all! 😊

    Official Response
  • ShadowHeaven91
    1 posts

    hello I have a bit of a problem with the character and I don't know what to do on the UNWELCOME mission I have already tried to reload the game but it doesn't help either who knows what to do it thanks

  • joro245
    2 posts


    i had everything at the lowest but i lifted them up and now it works again
    thank you !

  • iToXiiC1
    2 posts

    @kevzyubi @Kuratoro oh ok xD thank you both i will try it later 😄 i hope it works xD

  • Roland6804
    2 posts

    Once started the quest "unwelcome" after landing in England I go to the long house and free the prisoners. After the cutscene I always see the group of 3 people and can not do anything. Moving or any actions are not possible. I just can got to the menu and then reload. Even with previous save before I get the same situation.

  • ImFlugann
    1 posts

    as soon as i go into the longhouse and have the talking scene with the captured people in there i come out of the scene stuck on sigurd in the house and it just says unwelcome and cant move or do anything for that sort can you pls fix this ubisoft ive been wanting to play this game for a min now.

    and dont want to restart my whole game if this is just going to happen again

  • ReapingHangMan
    2 posts

    To everyone that has this bug.. this is the solution........ Cinematic is not triggered after dialogue with Yanli & Rowan 

    • PC Workaround: enter Graphic Options, set “World Detail” to a setting other than “Low” 

  • Roland6804
    2 posts

    Hello, have the same bug. Can only open menu and quit or load save games. Always get to the same situation that game can't be continued.

  • DynamiteCowboy
    1 posts

    Encountered the same bug.

  • Yonsha_89
    6 posts

    @h4ckerv2 Same me too

  • alexsergi
    2 posts

    Como dijo DRATINI. Subir los gráficos (yo lo he subido a ALTO) hacer la cinemática y luego guardar y volver a poner los gráficos como lo tenían. ^^

  • BrAinEater_89
    7 posts

    I enter the island and fought the bandits and then its stops for me...cant even start the mission unwelcome .. pffff

  • Yonsha_89
    6 posts

    @ubi-swaggins I solved it thanks to you friend! Now we have to be patches of ourselves. We got good at Fixing the bugs created by our friend ubisoft. We could all be beta testers.

  • BrAinEater_89
    7 posts

    After i do the mission the swan road and enter the harbor of ragnarkamp and kill the bandits there is nothing left do to ? It doenst even start the mission unwelcome.. HELP

  • Yonsha_89
    6 posts

    @ubi-swaggins optimize the game if possible. there are too many Freezes

  • Xhen1e
    2 posts

    @braineater_89 I have a problem with the mission:"prey in the high halls". Wulfhilda just stops in the temple and doesn't go and won't move. Canno't continue the quest.

  • Babaleas
    1 posts

    the mission is called "unwelcomed" (i think) i go to Ragnarson's settlement i kill all the enemies i go to the 2 prisoners they have, speak to them and as soon as i go to loading screen (suprise it doesnt load) and im back at the Longhouse with Dag and sigurd and i cant move cant fast travel cant open anything at all and i ve been searching for a sollution(i even loaded way back so i can try again and it didnt work) if anyone knows how to make it work im all ears

  • ikaufmann11
    1 posts

    @Ubi-Swaggins I am having the same problem with version 1.0.2 on PS4. I can not advance past the swan road home and the map is not giving me any markers to follow. I have looked for how to verify game files but I can not find anything for the ps4.

  • Small0606
    7 posts

    @babaleas i have the same problem here..

  • kevzyubi
    32 posts

    @babaleas hey buddy i know the fix, change your grahpics and it will work. I changed from Low to Medium and the issue was resolved. We must help eachother when support is not

Suggested Topics

Community Details