Welcome to discussions

Quick Suggestions

  • dantrex
    8 posts

    I am playing on GeForce Now so i cant start the game on administrative mode. Can someone help?

  • johnboy202020
    2 posts

    when i find the two people that where held captive as soon as u land in england my game crashes
    and 3 of them just stand there there is nothing i can do i have reloaded game again and again
    i cannot get passec unwelcome mission on pc

  • Danteassa29
    4 posts

    I have a problem that keeps me from moving forward. In the undesirable neighbor mission after speaking with Yanli, Eivor appears very close to Sigurd and does not allow me to move or open the inventory menu. How can I solve it? I already restarted the game and the mission and I still have the same problem.

  • xXDocPaulXx
    2 posts

    @kuratoro worked like a charm! thank you!

  • Danteassa29
    4 posts

    @johnboy202020
    I have the same problem, I still can't solve it

  • Danteassa29
    4 posts

    @johnboy202020 I was able to solve it, I had to change the graphic configuration in my case I left it on high. You should not skip the dialogue and it will allow you to continue.

  • stricken78
    3 posts

    @small0606 thanks fixed it bit [censored] i had to turn down my gpu (which is overkill for this game) to play it they need in game support or some [censored] tried support no answer couldnt even message them bad start to a game imo

  • Arkweave06
    2 posts

    Yes. This did work. however made the video glitchy, probably my 1050 TI gCard. i changed graphics after it was over though, thank you! 🙂

  • smudge62
    2 posts

    Assasins Creed Valhalla - PC

    My current progress is the Unwelcome mission at the first location in England, Ragnarssons Encampment. Once entering the longhouse, the cut scene in which two prisoners are freed unfolds. I am unable to continue past this scene. There is an excessive loading time for the next scene and when it finally finish loading I am presented with my character, Dag and Siggurd all standing close together in the same building and unable to move. There are limited controls available, which I have highlighted in a screen recording. I am unable to attach the video clip to this form due to size restrictions.

    I have attempted to continue from two previous saves at different locations but both end up in the same dilemma. Occasionally on exiting the game, what sounds like the follow-up scenes audio begins to play, only to be cut short when the game eventually exits. I have also tried without my anti-virus and without internet. Windows and graphics drivers have been updated as well as reducing the graphics to it's lowest possible setting.

    The support form for this is apparently not in use and so I am unable to attach the video, dxdiag and msinfo32

    Please help!

  • RenoxDashin
    23 posts

    @teddie-rex Either do the method listed above, or get to the point where you're sitting where you can't move, and then just let it sit. It'll eventually load. Make a sammich, smoke a bowl, pass some time for 3-6 mins. Both work, this bug is on quite a few missions. Though from what I can tell it's caused from outdated CPU's. I'm running an outdated I5. Out of curiousity, what CPU are you running?

  • Kwalan
    4 posts

    I have tried everything in these suggestions and nothing works for me. PATCH YOUR GAME UBISOFT

  • circuit_zenergy
    2 posts

    69 voice " see nah [censored] look i get ignant when playing under ubisoft stream cause of they return policy and [censored] like that(ending impersonation). I have to now pay good money within those time frames of uncertainty and any future improvements of tooth picking ain't gone fix what can't be invested in the stock. I want my f😁🤣king money back if you can't get this [censored] out my face 📊🎥🔍.

  • circuit_zenergy
    2 posts

    So, if you turn your settings to World Details from low to high/ultra high it should fix it.



    worked for me, found this on the ubi form.

    Thanks Redd it though.

  • kevzyubi
    32 posts

    @crispykibbles changing your graphic settings will solve this.

  • ballofbitter
    2 posts

    I logged in just to post my list of troubleshooting (3.5!! hrs!!!) in the hopes it helps someone else. I tried every configuration of the graphics settings fix I could think of but it just didn't seem to work for me. This all happened after I also got stuck on the boat leaving Norway, super frustrating but after trying all the workarounds I could find this is what I did, and some combination of these (or all) finally fixed it for me:

    1. I have avast, I disabled all the shields.
    2. I play with a steam controller with steam overlay, so I also unplugged the controller and launched with ubi connect, run as admin.
    3. Verified game files
    4. I used graphics settings from a friend who isn't having the same issue, but I'm unsure if the specific settings mattered or if just changing them helped.
    5. Before triggering the cutscene, i broke all of those boxes blocking the door


    I'm unsure what combination of those fixed it for me, but I have most suspicion on the controller being unplugged. I hope this can help someone else!


  • Odin.TAF
    1 posts

    Bonjour à tous,
    Mon problème ce situation sur un temps de charge, debut de l’arc angleterre, apres avoir parlé avec les deux esclaves des camps des ragnarson, au moment ou les autres navires arrivent. Temps de chargement anormalement long, puis aucun controle sur les jeux.

    j’ai fais :
    - vérification des fichiers du jeux
    -lejeux
    - réinstaller Uplay, puis lancer le jeux
    - lancer Uplay, puis réinstaller les jeux et le renance ma partie
    - reprise depuis une auto save
    - créer une nouvelle partie 

    PS: mon pilote graphique est un jour et je n’ai pas rencontré de problème particulier jusquque la sauf les loups qui freez contre le rocher dans la vision dee valka

  • xNeera
    5 posts

    I am at a complete loss. I have tried everything everyone has suggested over a 6 hour time period and I still cannot get it to work for me. I even tried reloading a save from the beginning of leaving Norway, and fighting the bandits again, but that didn't work either. I feel like I have tried everything and it saddens me greatly, I was really enjoying playing this game.

  • xNeera
    5 posts

    @kwalan I'm in the same position as you, I've tried every workaround I have come across, racked my brain for everything I could try and still no success. I guess there's nothing left to do except wait for a patch...

  • kwiky1
    1 posts

    Lors de la mission un accueil déplorable, une fois la discutions avec les deux gars qui sont ligotés, mon personnage ne peux plus bougé mais la caméra n'est pas bloqué. On dirais que la cinématique n'est pas terminé car seul l'action échappe est disponible. 
    J'ai essayé de recommencer les missions mais ce bug ce reproduit à chaque fois (même quand j'ai retenté de prendre une sauvegarde 2h avant).
    Une réparation des fichiers n'a rien fait ainsi que la désinstallation total puis la réinstallation.

  • TORFINR
    370 posts

    @kwiky1 Tu n'es pas le seul avec ce problème. malheureusement. Faudra attendre le patch...

Suggested Topics