Welcome to discussions

Quick Suggestions

  • Nathann.m
    2 posts

    everytime i come to the chapter unwelcome an free the prisoners after the storyscene i get stuck on isgurd an cant move anymore😞

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello all!

    The investigation into "Unwelcome" was marked as resolved following TU 1.0.4.

    As there have been no new reports for this issue, I will now be locking this thread. If you're still unable to proceed in "Unwelcome" following the last Title Update, please can you open up a new thread so we can keep this investigation separate.

    Thanks all! 😊

    Official Response
  • Nathann.m
    2 posts
    This post is deleted!
  • Dave_the_human
    5 posts

    Just want to throw my hat in that I am also having this problem, having the super slow dialogue problems and have had this problem in previous cutscenes too (e.g. Kjotve)

  • KeurKeuRZOO
    1 posts


    Bah je sais pas si t'as réussi a t'en sortir mais du coup j'ai eu le même problème et en me baladant sur les forum (et j'ai vérifié moi même du coup) mais il faut juste mettre les graphisme en moyen et ca lance la cinématique.
    Bonne chance

  • dyxo1
    1 posts
    Hi.
    My game gets completely stuck and doesn't respond to any key. The hero doesn't even move. So far I have not had such a problem....There is prntscr.


    undefined

  • L4RNE
    2 posts

    My problem is that i cant even start the quest. I cant cill the people and there is no one in the long house. plus sigurd is just doing nothing in the river. Please help

  • L4RNE
    2 posts

    @potatodude02 I have the exact same issue. plus i have sigurd just chilling in the river doing nothing. i cant even talk to him

  • Ubi-Woofer
    Ubisoft Support Staff 768 posts

    Hello everyone,

    Thank you for continuing to report your experiences of this issue in "Unwelcome" here in the thread. I am glad to hear that the workaround to adjust graphics settings has worked for many of you, and allowed you to progress. Just to raise visibility on this workaround and another posted:

    Change Graphics quality -> ultra high. Go in Longhouse. Watch the cutscene. Do not Press Any button. Cutscene end. Change Graphics quality your pc specs [Posted by: xzxz5011]


    Update: I changed the framerate setting from unlimited to limiting it to 30 and then it worked. [Posted by: ThreadWitch]


    For those of you who this workaround has not worked for, please rest assured that the developers are continuing to investigate these reports, and are working on a fix at the moment.

    As soon as I have more information to share about this fix, I'll post again in the thread. Thank you for your patience and understanding in the meantime! 🙂

    Official Response
  • WonderWomanHay
    1 posts

    After completing the Hunted quest, it never played the cutscene of the paper actually burning, but it marked the quest as complete and let me continue playing. When I loaded the game today, it put me back at Ravensthorpe and started the quest of Uninvited Guests, but after the cutscene in the longhouse, it glitches back to the cutscene that should have played in Hunted of burning the paper.
    Playing on a PS4 - if that makes any difference. I have tried resetting game, even loading older saved slots hoping to just redo past quests. No matter what I do, the game starts up in the same place, with the same glitches.

  • UbiKoreanBBQ
    Ubisoft Support Staff 217 posts

    Hey there and welcome to the forums, WonderWomanHay! When you were put back in Ravensthorpe to start the "Uninvited Guests" quest, did it still show "Hunted" as being completed? Can you try these steps to start out? Let me know how it goes!

    Official Response
  • DeaDogz
    1 posts

    After the cinematic scene from finding the 2 slaves, Rowan and Yanli in the Longhouse, the game then becomes glitched into a state were all movements do not work.

  • Insidiousb1aze
    1 posts

    So I have played valhallah now for 3-4 hours now. I get to the start of England and i cant get past teh longhouse after freeing the horse tamer and the murchant. all three charecters stand aroujnd not moving and i cant get passed it. I have uninstalled and re installed 3-4 times already, started new games and done evething i can think to fix the issue.

  • PotatoDuDe02
    12 posts

    @l4rne Exactly the same here. I can't do anything other than the side stuff like hunting for treasure, artifacts, and find the eagle towers. I really do not want to start my main campaign over again.

  • tonksy1988
    7 posts

    ive currently just landed in England and saved the prisoners from the brits, after that cut scene all 3 charaters are locked together and i cann't move or anything.

    ive verify the game, no change, loaded a old save before i jumped back into the machine. same thing happens.

    i have recorded some gameplay if that helps?

  • Jetenator
    7 posts

    @tonksy1988 change your graphic settings to something different to what you currently have. Also dont skip any dialogue

  • tonksy1988
    7 posts

    @jetenator just changed to low and watched all the cut scene still the same 😢

  • Jetenator
    7 posts

    @tonksy1988 did you put everything to the absolute bare minimum? i had the same problem and that worked for me

  • tonksy1988
    7 posts

    @jetenator ill double check not sure why that would start making a difference now haha

  • Ubi-Swaggins
    Ubisoft Support Staff 340 posts

    Hey folks,

    Sorry to hear that you are encountering this issue.

    I have passed it onto the team to look into further.

    Apologies for any inconvenience caused.

    Official Response
  • tonksy1988
    7 posts

    @jetenator Sadly still not working, i did just update my gfx drivers maybe setting them to a older driver?

Suggested Topics

Community Details

35
Online
138.7k
Users
24.3k
Topics
125.8k
Posts