Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • ildirda
    1 posts

    same problem. Tried everything mentioned here. Nothing worked. Im stuck.

  • Ubi-Borealis
    Ubisoft Support Staff 2111 posts
    Best Answer

    Hello there!
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for "Unholy Father" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
    If you are still encountering issues with "Unholy Father" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
    Thank you! 😊

    Official Response
  • IronCarb
    3 posts

    This happened to me today. I tried riding away from the town and it didn't change anything, so I rode back to the entrance, dismounted, and went inside. I got detected by guards nearby, started a fight, and while killing a few of them it triggered the next part of the quest to go talk to Lif. So the text updated from "Escape Walden" to "Talk to Lif" and I got past the bug.

  • larrykop1967
    65 posts

    I've just had my 1st crashes in the game, in Walden during the Unholy father quest, 2 in a row, then when i loaded the game up afterwards, i am outside Walden with the quest saying leave Walden and it won't continue or update.

  • larrykop1967
    65 posts

    I've just had 2 crashes doing this after killing the priest, when i loaded the game back up, i'm outside Walden with the quest saying leave Walden and have no idea where to go or who to speak to, i'll try the above post.

  • larrykop1967
    65 posts


    Cannot edit my post, anyway update, i got past the bug in a similar way to Ironcarb's, although i didn't actually go in and fight, just went next to the fence and all of a sudden the quest updated and got past the bug, this might help some players with the same issue.

  • chairpizza
    3 posts

    Same problem as many of the posts. Unable to move past the quest Unholy Father. I went in and cleared out Walden well prior to starting this quest. So I don't know if that was what did it. But I showed up and Lif popped up next to me with "escape Walden" as the quest objective and no matter how many times I go in and clear out Walden and then get out of Walden. It won't move to the next quest objective. This is very frustrating

  • p0nyrider88
    1 posts

    Same problem as all the others.

    Died while clearing Walden the first time I got the quest, now stuck at "escape Walden"

    Cleared it multiple times since, wen't in and out, ran away from the town. The dude just pops up, follows me around, but I'm unable to speak to him.

  • JamesFM676
    1 posts

    I have completed the assassination and the game says to escape Walden. I have left Walden and completed loads of side quests but I cannot progress in the main storyline as this quest will not complete

  • Blessus
    2 posts

    I have same problem I have done everthing and load diffrent saves etc man this suck that game cant go futher 😞 I did everthing what u guys did

  • Infectoid
    1 posts

    I can't progress. Went in, killed the priest, left, did the other two objectives of that quest line out of the three and been trying to get past the Escape Walden objective. Went in multiple times, killed everyone, inclusive to civilian priest, left via right scaffold, left via left zipline out of the church. Ran out of the province. Did a lap clockwise around the entire camp (to confirm above fix for someone else), did more counter clockwise. All while the dude's been following me. Nothing's working. Port out, go back to camp, the dude just randomly appears and tails me aimlessly.

  • MrObnoxiousUK
    1 posts

    Unable to progress in Unholy father as well, snuck in killed priest, get the message leave Walden, leave and no update. Cue entering and exiting dozens of times, killing every guard, fast traveling and restarting the game, nothing works.
    Get this fixed Ubisoft, it effects my progress in the main scenario, so chop chop and get it fixed.

  • Pyro_ubi1010
    1 posts

    Games freezes as soon as I get close to the church. Tried everything to fix it. I can quit the game but if I don’t and I try to wait for it to “unfreeze” it crashes my system. Xbox one x.

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone,

    Thank you for continuing to report your issues with the "Unholy Father" quest. I sincerely apologise that we did not reply here until now, but rest assured that the developers have been investigating this for you! So far, reproduction of the issue has sadly been unsuccessful, so the developers would like to request the following from you all to try and help them with their investigation:

    • Videos of the issue (showing that you have fulfilled the objective but it has not completed - please upload these to YouTube or a similar site, and provide a link!)
    • Your save files (if playing on PC or PS4) via a support case or Live Chat
    • Confirmation of the order in which you completed the following quests: Razing Earnningstone, Unholy Father, and Storming Ravensburg
    • Information about where Lif was located when you killed the priest, and also when escaping - did he follow you / were you together?

    If you could let me know your case reference numbers here in this thread, that would be awesome. Thank you for your help! 🙂

    Official Response
  • SBrovsky
    2 posts

    @ubi-woofer I'm not sure if this will help the Dev team, but I had the same issue completing Unholy Father, tried all ideas in the forum above and nothing worked. I decided to go back to Norway to finish all quests there and then come back to see if this issue would resolve. When I now try and go back to England, I get the "falling through the world" bug - going to the world map while falling doesn't let me Fast Travel to another spot, so I die over and over again. I have tried dozens of save games and Fast traveling from different spots on the Norway map - still the same result. I'm playing on an Xbox One X and I'm 26 hours 23 minutes into the game. I have also shut down and restarted the console multiple times as well.
    I really want to play this game over Thanksgiving Break - help!

  • Blessus
    2 posts

    unholy father quest still bugged. Patch 1.0.4 didnt fix anything to that quest 😞 at lest not for me how its for u other guys have u fix u mission? or? this quest simply bugged

  • nessman21
    1 posts

    Same problem here. Can’t get past ‘Unholy Father’ after it says escape Walden. Now all my current saves cause me to fall through the floor of the map caught in a never ending loop....wtfff

  • SK1CROW69
    4 posts

    Exact same problem. Tried all the possible suggested scenarios posted on this thread and I still can't get past "Escape Waldon". Please get this fix or at least give us a way to restart the mission.

  • sealteamrix
    1 posts

    Tried everything in this forum and nothing worked. Devs pls

  • Sathya2904
    3 posts

    I played this mission yesterday, encountered this problem and googled to find that many of you guys have been having the same problem as me. First to clarify with everyone, what consoles are you guys playing on? I play on XBox One X and see here that many of you have been playing on an XBox as well. I saw many walkthrough videos on youtube where the mission worked fine and notice what they all have in common was that they were played on PS. For some, it seems to work on XBox too, so I am not sure it's a console specific issue (Sorry, just thinking out loud).

    For the devs, maybe some details of how I played the mission might help?

    I started this story arc even before meeting Sigurd in Repton. In the story arc, I picked the Lif mission as the third of the three available raiding/pillaging missions.

    1. I spoke with Lif first to begin mission.
    2. Since I wanted to go stealthy about it, I did not enter Walden directly through the gate, but around the fence and directly through the backside where the church was (or the closest entry point on the fence). Killed the priest and guards, got book of knowledge, exited church.
    3. I then decided to also collect the wealth before leaving Walden, wanted to be stealthy about it but ended up in open combat. I was almost done when I took multiple hits and died.
    4. When the last checkpoint/save reloaded I was outside the fence of Walden with the mission being to escape Walden. Right!
    5. I found a guard tower part of the fence on the side where I could climb up and saw that Lif approached me and joined me from inside, hooded. We ran outside and exited Walden area. But, like many users have mentioned, Lif just followed me around for a distance and then ignored me. Next stages of the mission was not triggered. I even tried going back in, killing the guards looting all the wealth basically completing the area. Result is still the same.

    I am not in the habit of making gameplay videos, so unfortunately I can't provide video evidence. I'm happy to offer any other details that might help. 😞

  • TheBassyTV
    2 posts

    In case it helps, probs won't because I've read so many various things already tried.

    In my case, I was doing everything and was just about to escape, I dunno what happened. I just know I messed up got stuck and just got hammered and arrowed. I ended up dying and it spawned me outside on a deck. I couldn't talk to him, so ran back in, started killing again but the area wasn't highlighted anymore.

    I've explored and ignored the quest for some time, so the quicksave reversal option wasn't for me.

    I ended up going in trying to kill all the soldiers again, that didn't work, so I ran far away until he ignores and then I ran back.

    For whatever reason it took me about 1.5 hours, but I had had enough I started killing a bunch of civilians, got desynced and it respawned back on that deck. I still couldn't talk to him but somehow I ran around in a circle on the deck and ran through him. All of a sudden poof I could talk to him and complete the quest.

    Good luck!

Suggested Topics

Community Details