Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • larrykop1967
    65 posts

    I had this bug with this quest back in November on the 1.02 patch, which just updated out of the blue and i got past it at the time, i've since started a new game using the latest patch and i had no issues this time around, the mission worked as it should, so it has been fixed for me at least, but i did start from scratch,

    No idea why we are all having different types of bugs and issues with the same quest's.

  • d_train_
    1 posts

    I am on patch 1.1.1 and have this issue - can't progress without completing this - come on, this issue has been around for months, why is it hit fixed yet??

  • Ubi-Borealis
    Ubisoft Support Staff 1535 posts

    Hello everyone!

    I apologise for the delayed update. Thank you for continuing to update this threads with your experiences of the issue. I'm sorry to hear that the workaround has not helped all of you to progress further with the quest.

    The development team are still looking into this issue further. As part of the investigation, we'd like to collect some additional information from affected players. Would you be able to let us know the following

    • Which platform do you use (PC/PS/Xbox)?
    • In what order did you complete the 3 missions from Grantebridgescire: Razing Earnningstone - Unholy Father - Storming Ravensburg.
    • Can you remember where was the NPC Lif when you killed the priest?


    Additionally, if you play the game on PC/PS4, we would be interested in collecting your save files for further investigation. If you are encountering this issue on either of those platforms, please can you open a support ticket and submit your save for further investigation. Once you have opened a ticket, please share your ticket number within this thread. That way, we can ensure that all of the data is passed on to the development team. Thank you! 😊

    Official Response
  • StrachanStoats
    4 posts

    Opened a ticket, reported the bug etc.

    Wasn't addressed in the latest 1.1.2 patch, still can't initiate dialogue with Lif. Can't really be bothered starting a new game and jumping through all the [censored] challenges to get back to this point - just wanna hunt down some cult members.

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hey @strachanstoats - I am sorry to hear that this issue with "Unholy Father" persists for you in TU 1.1.2. I can see in your support case 14090620 that you were asked the same questions as my colleague @Ubi-Borealis asked above, but we did not receive a response from you, so your case was closed automatically. Could you please provide us with the requested information, as well as a video of the issue if possible? It would be much appreciated!

    Thanks!

    Official Response
  • philipmolker
    2 posts
    This post is deleted!
  • philipmolker
    2 posts

    i can’t even start the “Unholy Father”… Lif is just sitting in the ground and repairing on his shield every time I get there. Tried to reinstall, go to England and back, get him op putting his little camp on fire and maaaany other things but nothing works so SUPER great game. Any one with the same problemo?

    playing on Ps5

  • Ubi-Mark.
    Ubisoft Support Staff 533 posts

    Hello @philipmolker,

    Sorry to hear that you are unable to start this quest. The development team is currently investigating issues with this quest, and as soon as we have an update on this, we are going to let everyone know through this thread. If you have any additional information that you can provide about your specific issue - such as which quest you completed directly before "Unholy Father", and whether you've tried reloading an older save, that would be much appreciated.

    Thank you for your patience and apologies for any inconvenience caused by this. If you have any additional questions, please let us know.

    Official Response

Suggested topics

Community details

26
Online
125.5k
Users
21.7k
Topics
111.8k
Posts