Welcome to discussions

Quick Suggestions

  • MrWill.R6
    1 posts

    I have this also! This is really bad

  • Ubi-Woofer
    Ubisoft Support Staff 793 posts
    Best Answer

    Hello everyone, sorry to double post, but I come bearing exciting news!

    I’m pleased to say that TU 1.1.1 was announced last night, and will be released today on January 14th! In this patch, we have a fix for the issue in “Settling Down” whereby a blackscreen would prevent progression after constructing Gunnar’s forge / Blacksmith shop.

    After the patch is deployed, please try again to build the forge and you should find that you are now able to proceed into your settlement and get to exploring the rest of Ravensthorpe. If you experience any issues, you should of course feel welcome to communicate those with us here, and we’ll get those looked into as soon as possible!

    Thank you all for your patience regarding this issue, and I hope that today's patch will fix it for all of you and allow you to continue on your journey across England. 🙂

    Official Response
  • happy-101
    1 posts

    I'm also affected, really hope there's a fix

  • A1pha.iwnl
    5 posts

    Also have this issue, just after having the issue with the ''unwelcome quest" this is getting very annoying...

  • styxee
    20 posts

    @a1pha-iwnl oh wow you as well?

    I tried reloading and going back to other saves and Unwelcome will just not progress. It hangs and comes back with the 3 NPC's standing in the abandon hall in a circle and you can only exit the game. The game is literally unplayable for me now i am guessing you as well.

    Ubisoft any ETA on a fix for this game breaking issue?

  • myraddin92
    4 posts

    So I've built the blacksmith and no nothing is happening. The quest isn't progressing at all to the next stage

  • Kuratoro
    97 posts

    @styxee For that unwelcome quest there is this fix:



    I do not know of a fix for the problem in Settling Down quest yet though..

  • Ubi-Swaggins
    Ubisoft Support Staff 346 posts

    Hello everyone, I am sorry to hear that you have all been experiencing issues with the "Settling Down" questline.

    Can you provide a video of what happens when you build the Blacksmith? Any additional information about reproduction steps or troubleshooting you've tried would also be very helpful.

    Official Response
  • Domm1146
    2 posts

    @ubi-swaggins
    I’ve experienced this same bug on PS4, I can’t send a video sorry. When I upgrade the blacksmith during the mission, the screen cuts to black as if it’s about to transition to a cutscene, instead of playing a cutscene, I can move around (can’t see anything, just sound) and I can open the menus. I decided to try and fix this issue by reloading the game but when I reloaded the quest had no objective and the blacksmith is standing outside of his hut (the same position he is in during the cutscene I believe). I can do side content but I have no way to continue the story, the only thing I haven’t tried is deleting my save file.

  • Domm1146
    2 posts

    @domm1146
    I solved the issue by reloading a “exclusive quest” save and playing from there.

  • JohnnyLaw1955
    Original poster 2 posts

    @indianaj0nes I have recently tried uninstalling and then reinstalling and it has worked for me. Although it is a method past this glitch, it still takes time so hopefully it can be patched soon.

  • ckorzenecki
    11 posts

    @ubi-swaggins having this issue too on ps4

  • Chucker2016
    1 posts

    @Ubi-Swaggins
    I have encountered the same bug, and have provided a video of it below


  • jorgen189
    4 posts


    I have finish the raid and came back to the settlement, but when i try to build the forge the cutscene would't show. And the screen goes dark. When i try to relogg the forge is there but i havent complited the mission:(


    Plis fix your game ubisoft.

  • JamesBlonde2410
    1 posts

    The game will not allow me to continue with "settling down", I have built the forge, Gunnar is currently standing outside of it, when I go back to the longhouse to speak with Sigurd , Eivor keeps saying the the forge hasn't been built yet, I have tried restarting the game a few times with no luck on it fixing whatever this is.

  • CountingSpoon
    6 posts

    @ubi-swaggins Same thing happens with my game. Built the forge and it completes the cut scene, but then the mission in the top right hand just says "Settling Down" with nothing to be done. I read a walkthrough and when you go to Sigurd and he asks if the forge is built, my character responds with "not yet." I have gone to an earlier save to redo the mission 3 times and it does the same thing every time. Very very frustrating. Been stuck for hours. 😞

    @domm1146 This didn't work for me on PC.

    @jamesblonde2410 Same! 

  • CountingSpoon
    6 posts
    This post is deleted!
  • CountingSpoon
    6 posts
    This post is deleted!
  • CountingSpoon
    6 posts
    This post is deleted!
  • CountingSpoon
    6 posts

    @barrelplanet413 I have the same issue. Any fix yet? 😞

  • CountingSpoon
    6 posts

    @chucker2016 Exactly what happens to me too. 😞

Suggested Topics

Community Details

189
Online
140.1k
Users
24.7k
Topics
127.8k
Posts