Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • candyflossbaby
    2 posts

    The mission gets so far as to tell me to 'follow njal the bear' but then does not progress to the next stage. The bear is stuck in the field no matter what. I know I am meant to feed him fish from a google search but he never asks for me to do that, instead it remains 'follow the bear' forever.
    I am stuck here now as all of my autosaves are from the same area so even loading an old save does not reboot he mission.
    Restarting the game does nothing either.
    I've already had an hours progress collecting in Asgard lost due to a similar bug so safe to say I feel like I'm literally wasting time on this game so far.

  • candyflossbaby
    2 posts

    The bear won’t even ask for fish, my mission is stuck on ‘follow the bear’ so annoying. I’ve already put a couple of days into this game and now I’m stuck at this point@karineel

  • ReaLadiesMan217
    2 posts

    I went to talk to the berserker and he sent me with his bear to get him food. We went to the lake and nothing. I killed some fish for him but I cant feed him he is just standing in the water attacking the water. Still says I have to fallow him. Is there a way to fix this without restarting because I'm not interested in doing that. I really wanted to do this quest line.

  • nobumeister
    1 posts

    Got a bug for quest ‘The Mysterious Berserker’.
    Follow Ngal the Bear was bugged as I cant seem to bring it to the lake, the bear stuck at the flowers and didnt move. Do help

  • mistermcshark
    1 posts

    This bear won't move or do anything. I am aware that I'm supposed to catch a fish to give to her but the dialogue hasn't come up and she's just standing there. Any way to fix this?

  • kinbumi
    7 posts

    I would advise not completing this quest right now. After I did I lost access to multiple settlement improvements. Can’t use the barracks, Hunter, horse, or ship builder.

  • ReaLadiesMan217
    2 posts

    @mistermcshark Im having the same problem. I dont wanna progress to far in case i have to restart. this really sucks.

  • iTzBoy
    1 posts

    Same here. So annoying.

  • Mondracc
    3 posts

    For me the bear is stuck inside cave ceiling and I cant interact at all after talking to Bjorn.
    https://ibb.co/gF5W5Lt

  • AgitatedNatedog
    2 posts

    On xbox series x this quest is stuck on "follow the bear njal" and we are at the last but all the bear does is attack fish and birds. (I cannot feed it).

  • Tar-Naugrim
    52 posts

    @agitatednatedog Had the same happen to me, I reloaded from an autosave the game made and next time I killed a fish I had an option to talk to Njal and feed it.

  • Guisjaart76
    1 posts

    @svarainiokas I have exactly the same issue here

  • DEDg34r
    2 posts

    @agitatednatedog i am having the same bug, it seems as if something agro'd me in the water and hes constantly at the shore attacking the fish. The only result i get is a ton of dead fish laying in the lake and even if I personally kill them I don't get a response from the bear. My mission continues telling me to follow him. I am fast traveling to Norway and returning to see for a fix because saving and reloading the game hasn't seemed to work.

  • CypegEaT
    1 posts

    @smatter_tipzie I've exactly the same problem. Keep me updated if you get the solution to this please!

  • DEDg34r
    2 posts

    @dedg34r I made a small clip of what the bear is doing for me for any Ubisoft Admins that want to see how it looks. Just a little 2 minute clip.

    https://www.twitch.tv/videos/804110096?t=0h0m3s

  • Siimy1
    2 posts

    @smatter_tipzie Same for me too 😞

  • Mirmidonass
    1 posts

    @svarainiokas outside the bjorn cave on the river bank has a boat. tried to push the bear to land.worked for me!!!!!!

  • swiley99
    1 posts

    Hi, I have a problem with a quest in the Game. I can't progress in the game because off one bug and I can't find and help to skip it. In the quest The Mysterious Berserker, I need to follow the bear and I need to feed him a fish but after im fishing it i can't give it to the bear... I was supposed to press triangle ( PS4) but is nothing... I tried everything restarting the game or reload the mission but is the same.... please I will need some help because otherwise I can't progress in the the game and im not happy to pay 60£ for a game and not be able to play it. Kind Regards, Adrian.

  • fabrefekete
    1 posts

    Mine is stuck, not in the water but in the middle of the shore, I think that's because she picked a fight with herons on the shore and now she won't move, whatever I do. Hope it'll be fixed soon. She is not even attacking the fish, just standing there, roaring from time to time.

  • kizza0721
    63 posts

    Have you unlocked the fishing line yet? I caught the bear some fish with that and then interacted to feed her.

Suggested topics

Community details

20
Online
123.7k
Users
21.3k
Topics
109.6k
Posts