Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • SarahVerona1
    2 posts

    I finished the quest but am unable to recruit Bjorn, or give him the berserker flower ingredients I've found. He is just kneeling next to my long boat in the settlement, and the recruit button is greyed out when I talk to him

  • FearlessFlaw
    7 posts

    @ubi-woofer also the way of the berserker is glitched. The bear is stuck in the water and unable to be fed the fish. I encountered this and it appears it's not just mean. It's probably the bears path finding is glitched unfortunately

  • TangoFoxtrot23
    1 posts

    It's been a few weeks now and I still can not complete recruiting Bjorn and he doesn't stay assigned to the crew. Anyone know when this is going to be fixed?

  • Puck322
    1 posts

    @therealzdealz same. My bear is starring at a tree aboit 12 feet from the water. Won’t move.

  • SarahVerona1
    2 posts

    @tangofoxtrot23 I had same issue, then all of a sudden it just worked, didn't need to even recruit him, he was just in my crew after a reboot of game and system

  • guest-ptAKrxqL
    1 posts

    Hello
    I can’t get past Speak and follow Njal the white bear as the quest icon is hovering over the polar bear but he is having none of it.... doesn’t want to chat and I know he wants a fish. Maybe he’s depressed or not hungry but I can’t progress on this quest.
    please help

  • UltraBlacktiger
    2 posts

    Playing ac valhalla on ps4 since the new fix i still can't access the barracks nor complete ' way of the berserker mission' the bear won't move and is stuck near the lake.
    i still don't have my Way of berserker content as i have limited edition
    I thought it was a known bug and was going to be fixed with the recent patch?

  • nturne1
    3 posts

    @ubi-woofer Does UbiSoft see the problem now for those where the bear is stuck in the lake? Others suggested using the boat to push him back on shore but that is not working for me. I also tried to use the horse to push the bear but no luck. I understand if there is no fix yet but curious if UbiSoft can see the problem now. Previous posts were asking users to submit video clips. Thanks.

  • guest-ITJgGSCP
    1 posts

    I have tried everything to get the Njal back to land. She will not budge. -_-"

  • DrJono
    12 posts

    Can’t even start quest. He doesn’t even appear in the cave. And yes I have put the code in. Im playing on PS5 with a PS4 version as I bought the collector edition. In vectors I don’t seem to have any of the extras that should have come with the codes. 😡

  • TheCrystalHive
    1 posts

    Stuck on "Feed Bullhead to Njal" portion of the quest. Njal swam out to the middle of the lake and won't/can't move. I can't progress any further..

  • guest-c7vX3pyL
    1 posts

    I'm stuck there too I never got past the fish part the bear keeps walking by the river looki g at the river for fish but I cant give it fish and the character never says the dialogue the bear wants fish

  • DeviantChaos
    1 posts

    Stuck on "follow njal the bear" (stadia) he is just stuck in the field and won't budge, this is crazy how it's not fixed yet.

  • suici666
    4 posts

    I play on a ps4, and as same as everyone here, I'm stuck on this mission because Njal got stuck swimming in the water, dumb bear.

  • nturne1
    3 posts

    @thecrystalhive I have the exact same problem of the bear going into the lake and staying there. Has been stuck like this for over a month.

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone,

    Thank you for your continued reports of issues with the "The Mysterious Berserker" section of the "Way of the Berserker" questline. I've passed forward all relevant information posted in this thread since our last reply, however I'd like to ask again that further reports are posted in the following format so that the information is clear and concise:

    • The platform you play on (e.g. PC, PS5, Xbox One)
    • Task that you are struggling with (e.g. "Feed Bullhead to Njal" or "Follow Njal")
    • Link to short video clip demonstrating the issue (on YouTube or a similar site)
    • Confirmation of trying reloading a previous save / desyncing and resuming
    • Confirmation of whether the two workarounds previously posted (to use a boat or mount to lure Njal onward) worked or not


    I would also like to request that any affected players on PC or PS4 submit their save files to us in a support case or via Live Chat, so that the developers can take a closer look at these. Once the save files have been submitted, please reply here with your case reference number so that I can retrieve the files and pass them on.

    Thank you all for your continued patience and understanding while this issue remains under investigation, and I hope to have a more substantial update to share soon. 🙂

    Official Response
  • Agarwaen_42
    9 posts

    Hi, I still can't launch the quest : it disappeared from my log, and now when i come in front of the berserker and his bear, i can't talk to them.

    I'm on PC.

    Thx in advance...

  • crossboy5
    2 posts
    This post is deleted!
  • crossboy5
    2 posts

    Playing on PC.

    I had a similar problem to what some have listed above, and I suspect it could be down to Ubisoft Connect connectivity.

    1. Started the quest one evening with no issues. Saved at a point I needed to follow Bjorn.
    2. Loaded up Ubisoft Connect the following day, but it reported a connectivity issue. I choose to proceed offline.
    3. Loaded my save from the following night, Bjorn and the bear refused to move, were non-interactive and the quest no longer appeared in my quest log.
    4. Loaded previous game saves, including ones before I started the quest arc, and the quest no longer appeared.
    5. I then went into the Connect rewards page in game to verify if it the quest was showing in my account.
    6. It was, put then the rewards program returned an error message and I had to hard crash out of the game and Ubisoft Connect.
    7. Reloaded Connect, this time with full connectivity.
    8. Reloaded my save from the night before, and the game played as expected and I was able to complete the quest.


    Based on my experience, I'd conclude that this is almost a permissions issue. The game and the Connect program stopped talking to each other, which breaks the quest (as the game thinks you haven't got access to the content) and it's only when the connection is restored that normal business is resumed.

  • pistlpacknmama
    3 posts

    Has Ubi made a fix for this problem? This is ridiculous. I am on Xbox One with all add ons installed. The bear was stuck in the water? After trying for several hours, I went on to another quest. When I returned, he was still there. I finally gave up and reloaded an earlier game save (losing over 3 hours of productive play). Even though that quest is no longer active, I am not able to make a new game save. I have checked that I have no other quests open. It will really ruin the game if I am not able to ever make a new save. Please fix and send an update.

Suggested Topics

Community Details

31
Online
130.5k
Users
22.6k
Topics
117.3k
Posts