ubisoft discussions

quick-suggestions

  • locked topic_solved [RESOLVED] Unable to progress with "The Sons of Ragnar" | POST HERE

    86 likes/1311 replies/43816 views
    paddy2k9
    ubisoft:x-posts, 1

    i had this issue, but now it works. basically look to load a save and look for the save thats the start to when you have to go speak to Ubba. i was stuck on this for ages and thought screw it ill go back a bit and see if that works, and it did.

  • DemonMuser1994
    ubisoft:x-posts, 1

    So the quest marker for Travel To Tamworth has disappeared and I can't continue.

    Has anyone else encountered this bug? I REALLY don't want to restart again.

  • DGM1992
    ubisoft:x-posts, 9

    I’ve tried all possible “fixes” for console (playing on Xbox one) ... from what I’ve seen it’s a pretty common bug.... surprising that it’s not been acknowledged yet!

  • Ozzie669920
    ubisoft:x-posts, 4

    Unable to continue with "the sons of ragnar" quest, I'm pledged to Ledecestrescire - the first mission of "The Sons of Ragnar." and the requirement is, I must speak to Ubba. But, there's just the icon above his head and no further progression. I'm unable to press the triangle button above his head. I have also completed the mission with Knud and didn't receive the ability at the end.

  • JKRod89
    ubisoft:x-posts, 1

    It appears I'm not the only one with this issue, but I'm stuck. Near the beginning of the "The Son's of Ragnar" story arc, when needing to "Speak with Ubba" I'm unable to. He just stands there, cannot interact. This is after the brief cut scene in which we learn the soon-to-be planted king's son is coming with us.

    Rather big bug, considering it is stopping me and other players from progressing in the game. Any help is appreciated, thanks.

  • Bellatriix
    ubisoft:x-posts, 1

    When I track the sons of ragnar quest, there is no mark and I can't talk to Ubba where he is. So I can't continue the main story. I have tried to pleged to a different shire, to no avail. Gone to Norway and back. Tried different ways of reloading the game and area.

    I am sure that I'm not the only one with this issue.

  • Apsalara84
    ubisoft:x-posts, 16

    Anyone see the news, ubisoft employees barricaded on the roof in Montreal. All to get away from fixing the game (the last part is my opinion) but the first part is true.

  • UbiExcellent
    ubisoft:x-posts, 756

    Hey everyone! Our teams are aware of this issue and are currently investigating. In the meantime, if you have a secondary save that was made before you encountered this issue, please try loading this save up then accessing the mission. Players have reported that this allows them to speak with Ubba.

  • MrS4b4th
    ubisoft:x-posts, 2

    @ubiexcellent Nice job guys, only problem is that I have 25 hours in game and no save before talking to Ubba..

  • PaulDelestrac
    ubisoft:x-posts, 14

    So the issue as been acknowledged by Ubisoft on another thread so we might see a fix soon!

  • Apsalara84
    ubisoft:x-posts, 16

    What post was this addressed on?

  • Morkelpet37
    ubisoft:x-posts, 3

    @pauldelestrac

    which one, do you have a link?

  • DirtySwaggEr93
    ubisoft:x-posts, 25

    @ubiexcellent please fix this i have a lot of hours into this and no save from before hand either

  • ElderCookie
    ubisoft:x-posts, 1

    @rathma86 same things just happened to me 😞

    I started the Ragnarsons questline and then got distracted, did the whole Seers questline and so much exploration

    Now when I go back to Ubba I can't speak to him anymore??

    No way I'm getting rid of any save data either 😞 gonna hope Ubisoft see this thread asap and get this sorted.

    Am obsessed with this game and was really looking forward to doing this quest after collecting my 120 opals just now!

    There's been a lot of bugs and crashes so far but nothing too problematic honestly, but this bug is REALLY frustrating. Paid £90+ for the collectors edition for this 😞

  • Dark-Coco
    ubisoft:x-posts, 17

    @mickyd1234 I think I tried that and didn't work. I don't know which boat is Hytham's, but I steered into the 2 boats there and nothing. I also can't find Hytham near the area. Did I miss him? Anyway, I also hear from others that doing the other region worked for them, but it hasn't for me. I tried switching the quest and going back again to check first, and then did the actual whole mission, but neither worked. Now I'm even further into the game with no fix. Hope I haven't got to start over...

  • Dark-Coco
    ubisoft:x-posts, 17

    @bellatriix You're definetly not the only one! I, and several others, are also experiencing this bug. Some have found ways to fix it, but they haven't worked for me. Supposidely, you could try bumping into Hytham's boat to get Hytham's animation to work. The other option was doing the other region first, but you've already tried that... I hope Ubisoft fix this soon.

  • Dark-Coco
    ubisoft:x-posts, 17

    @ubiexcellent Glad to hear that Ubisoft are at least aware of the issue, which is reassuring. However, I and several others do not have a save point before talking to Ubba.

  • Dark-Coco
    ubisoft:x-posts, 17

    @paddy2k9 That's great, but some of us don't have a 'load-before-talking-to-Ubba option'. I am happy it fixed for you, I'm just saying that it's not a guarateed fix for everyone. I did have a save before then, quite a few hours back, but a save nontheless.Then I manual saved and it disappeared. RIP

  • SupremeSauce69
    ubisoft:x-posts, 1

    I’be started the quest and now am stuck were I’m supposed to talk to Ubba. I’ve spoken to him and then the whole scene ended and I didn’t have another part to the quest afterwards. I’ve tried to talk to him again and nothing. Now it shows the quest icon above his head and still I cannot talk to him after ending the game and starting back up, I’ve tried quoting the game and starting back up, I’ve tried exiting the animus twice and going back in and nothing. I’ve even completed some of the quest in Asgard and once I come back still the same thing. I have a boat in the middle of the horses in Repton where they are and it wasn’t there before the initial scene glitched and stopped. Any fixes or am I just SOL?

  • Apsalara84
    ubisoft:x-posts, 16

    @supremesauce69 there are now multiple threads for this exact bug

Suggested Topics