Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Awesomefruit6
    4 posts

    @awesomefruit6 need them to fix this asap

  • Ubi-Borealis
    Ubisoft Support Staff 1381 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • ground314
    1 posts

    I have encountered a gamebreaking bug in the Sons of Ragnar quest; I'm being prompted to "talk to Ubba" on the beach however I cannot interact with him once I get there. Oddly enough, the first time I tried I saw the cutscene however all the characters refused to move or progress the story after the cutscene concluded. Subsequent reloads/attempts yielded even less progress with the cutscene refusing to start.

    I see I'm not the only one experiencing this problem, however I figure if everyone reports maybe it will light a fire under Ubisoft. Love the game so far, but I'd like to continue the story; right now it's basically Axe-Hobo Simulator.

  • paddy2k9
    1 posts

    i had this issue, but now it works. basically look to load a save and look for the save thats the start to when you have to go speak to Ubba. i was stuck on this for ages and thought screw it ill go back a bit and see if that works, and it did.

  • DemonMuser1994
    1 posts

    So the quest marker for Travel To Tamworth has disappeared and I can't continue.

    Has anyone else encountered this bug? I REALLY don't want to restart again.

  • DGM1992
    8 posts

    I’ve tried all possible “fixes” for console (playing on Xbox one) ... from what I’ve seen it’s a pretty common bug.... surprising that it’s not been acknowledged yet!

  • Ozzie669920
    4 posts

    Unable to continue with "the sons of ragnar" quest, I'm pledged to Ledecestrescire - the first mission of "The Sons of Ragnar." and the requirement is, I must speak to Ubba. But, there's just the icon above his head and no further progression. I'm unable to press the triangle button above his head. I have also completed the mission with Knud and didn't receive the ability at the end.

  • JKRod89
    1 posts

    It appears I'm not the only one with this issue, but I'm stuck. Near the beginning of the "The Son's of Ragnar" story arc, when needing to "Speak with Ubba" I'm unable to. He just stands there, cannot interact. This is after the brief cut scene in which we learn the soon-to-be planted king's son is coming with us.

    Rather big bug, considering it is stopping me and other players from progressing in the game. Any help is appreciated, thanks.

  • Bellatriix
    1 posts

    When I track the sons of ragnar quest, there is no mark and I can't talk to Ubba where he is. So I can't continue the main story. I have tried to pleged to a different shire, to no avail. Gone to Norway and back. Tried different ways of reloading the game and area.

    I am sure that I'm not the only one with this issue.

  • Apsalara84
    16 posts

    Anyone see the news, ubisoft employees barricaded on the roof in Montreal. All to get away from fixing the game (the last part is my opinion) but the first part is true.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hey everyone! Our teams are aware of this issue and are currently investigating. In the meantime, if you have a secondary save that was made before you encountered this issue, please try loading this save up then accessing the mission. Players have reported that this allows them to speak with Ubba.

    Official Response
  • MrS4b4th
    2 posts

    @ubiexcellent Nice job guys, only problem is that I have 25 hours in game and no save before talking to Ubba..

  • PaulDelestrac
    14 posts

    So the issue as been acknowledged by Ubisoft on another thread so we might see a fix soon!

  • Apsalara84
    16 posts

    What post was this addressed on?

  • Morkelpet37
    3 posts

    @pauldelestrac

    which one, do you have a link?

  • DirtySwaggEr93
    25 posts

    @ubiexcellent please fix this i have a lot of hours into this and no save from before hand either

  • ElderCookie
    1 posts

    @rathma86 same things just happened to me 😞

    I started the Ragnarsons questline and then got distracted, did the whole Seers questline and so much exploration

    Now when I go back to Ubba I can't speak to him anymore??

    No way I'm getting rid of any save data either 😞 gonna hope Ubisoft see this thread asap and get this sorted.

    Am obsessed with this game and was really looking forward to doing this quest after collecting my 120 opals just now!

    There's been a lot of bugs and crashes so far but nothing too problematic honestly, but this bug is REALLY frustrating. Paid £90+ for the collectors edition for this 😞

  • Dark-Coco
    17 posts

    @mickyd1234 I think I tried that and didn't work. I don't know which boat is Hytham's, but I steered into the 2 boats there and nothing. I also can't find Hytham near the area. Did I miss him? Anyway, I also hear from others that doing the other region worked for them, but it hasn't for me. I tried switching the quest and going back again to check first, and then did the actual whole mission, but neither worked. Now I'm even further into the game with no fix. Hope I haven't got to start over...

  • Dark-Coco
    17 posts

    @bellatriix You're definetly not the only one! I, and several others, are also experiencing this bug. Some have found ways to fix it, but they haven't worked for me. Supposidely, you could try bumping into Hytham's boat to get Hytham's animation to work. The other option was doing the other region first, but you've already tried that... I hope Ubisoft fix this soon.

  • Dark-Coco
    17 posts

    @ubiexcellent Glad to hear that Ubisoft are at least aware of the issue, which is reassuring. However, I and several others do not have a save point before talking to Ubba.

  • Dark-Coco
    17 posts

    @paddy2k9 That's great, but some of us don't have a 'load-before-talking-to-Ubba option'. I am happy it fixed for you, I'm just saying that it's not a guarateed fix for everyone. I did have a save before then, quite a few hours back, but a save nontheless.Then I manual saved and it disappeared. RIP

Suggested topics

Community details

8
Online
124.0k
Users
21.3k
Topics
110.0k
Posts