Welcome to discussions

Quick Suggestions

  • ILIKEPANINIS
    94 posts

    It works for me, Ubba was stood in a different position to last time and there was a dead horse near his feet and a boat still in the road but I've progressed, thank you

  • Ubi-Borealis
    Ubisoft Support Staff 3579 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • RiceIsNice710
    19 posts
    This post is deleted!
  • RiceIsNice710
    19 posts
    This post is deleted!
  • mzs627
    1 posts

    I’m now more than 100hrs in. After update still can’t talk to Ubba. What gives? I’ve all suggested “fixes”





















  • Deadmennwalking
    21 posts

    @mzs627 When I first started the game post patch I also couldn't talk to Ubba. I saved the game, logged out to the title screen, closed the application (I am on PS4), started the game again, was able to talk to Ubba and progress in the quest line.
    I am now up to the Heavy is the Head part of the kingmakers saga.
    I hope this helps.
    Have fun and may RNG be forever in your favor.

  • guest-VQnBB6Mo
    3 posts

    @ubi-woofer

    I have the same issue. I could talk to Ubba, but the quest marker over him didn't appeared. I was stuck in the same conversation loop. Then I've created save, traveled to Norway, get out from animus, restarted console.... and now the quest mark appeared. As well as the boat in the middle of the road and... I can't talk to Ubba again. Just like before the update.

    Seriously? After over a month?

  • guest-VQnBB6Mo
    3 posts

    @guest-vqnbb6mo
    Ok, so I've found the reason of my problems.
    DO NOT try to talk with Ubba before making the save and follow the guide provided. It will crash the fix. Do all the things before you ever try to talk with Ubba. Talk with him ONLY if you have the quest mark over his head. The boat still appears in the middle of the road, but the story progress

  • UbiKoreanBBQ
    Ubisoft Support Staff 326 posts

    @guest-vqnbb6mo Thanks for letting us know what was causing the snag for you! I've sent a message over to the team that worked on this issue.

    Official Response
  • longjohn119
    609 posts

    @ubi-woofer
    This basically proves what I've been saying for weeks .... The problem wasn't in the game itself it was with the Connect app breaking the save by not registering a milestone/event had taken place when it made a save to the Cloud ...... Basically what they are doing here is resetting your save, having you quit out so it sticks and then when you go back in the missed event is now registered in the save and you can progress .....

    Not the most elegant fix but likely the only way to get the job done without forcing people to start over from scratch ......

  • Tsarchasm5
    9 posts

    I can’t find where to post this:

    Is there any word on fixing the location of the Eurvicscire hoard treasure? It still doesn’t spawn post latest update. Thank you.

  • MINIM4N22222
    4 posts

    @ubi-woofer YES!!!!! it worked.

    OH WAIT THERES NOW A BOAT BLOCKING THE CHARACTERS FROM MOVING!!!!!!!!!!!!!!!!!!!!!!

    WTAF

  • darkrexje
    1 posts

    Still no fix it seems for players that already talked to him.... Boat still in the middle. Guy still has quest mark on his head but he wont move..

  • nuth1nmuch
    1 posts

    Can you actually fix the sons of Ragnar quest or can you just refund me for selling me trash?

  • DGM1992
    8 posts

    Hot fix my [censored]! It’s still not working! I’m done with this piece of crap game! I won’t even bother putting it back on my Xbox just not worth it!

  • NilsKita
    2 posts

    We demand a refund for this [censored] game! Take CD Projekt Studio as an example.. They have the balls to admit they brought out an unfinished product!

  • williiham
    1 posts

    Still not working for me, even after all the steps provided.

  • longjohn119
    609 posts
    We demand a refund for this [censored] game! Take CD Projekt Studio as an example.. They have the balls to admit they brought out an unfinished product!


    That's [censored] They were dragged kicking and screaming by 3.1 million players that bought the game for consoles and Sony completely took them off their store ...... They won't give me a refund since I bought a digital version for PC, only for PC users that bought the actual DVD disks can get a refund .... maybe

    The [censored] AI in my modded version of Skyrim works better than the AI in Cyberpunk which is ridiculously broken on all versions .... Fire my gun, turn away quick for a fraction of a second and all the civilians NPCs disappear or when you least expect you T=pose through the roof of your car with no pants on ..... Trees constantly melting like wax in the sun ....

    Valhalla is buggy but it sure isn't on the same level as Cyberpunk buggy ...... The Devs are now revolting against management and I don't blame them one bit

    Basically I have 2 games that likely won't be playable for a couple more months ...... So I'm playing a bunch of new quests written by essentially amateurs in Skyrim and came across one bug in 20+ hours and that was likely something I did wrong with my load order or a patch ( My main lighting mode shut down and it was pitch black outside town even with a torch lit I couldn't see more than 5 feet in front of my face but I still managed to complete the mission and save the wench from the evil bandits) .....

  • Dark-Coco
    17 posts

    Is this bug still not fixed? I checked the other day to check and it didn't work. I contacted Sony a while back, since I bought a digital version from the store, it's not through Ubisoft, it's through them. I explained the situation. Do you know what they did? Gave me a list of things to try. "Restart your console", "check you have the updated version of the game". I know they have to say these things, so I can't say "don't you think I've tried that?" (not that I would, in those words), but... I explained that there's literally a thread on the Ubisoft forums about this. It's a game breaking but that can't be fixed by merely restarting the console...

    Even if the bug was fixed, I wasn't interested in having the game for now. Ubisoft, I love the AC franchise, I do, but again, why release a game where a bug like this exists? Surely you must have checked for these things? It's like with Cyberpunk 2077 and how their game runs on PS4, i.e absolutely terrible, like I'm back in 1998, and they said people could get refunds. At least... if you bought physical versions. They even took the game off the shelves, and yet... Sony can't refund me because it's not in their policy? The game doesn't work!

    I hate sounding so complain-like, because I know people worked hard on this, like any game, but it wasn't ready, and I'm still £60 out of pocket for something that doesn't function properly. What am I to do? I replied back to Sony on trying to get my refund, but what if they don't? I've basically been scammed? I go "oh well, that's that"?

  • NilsKita
    2 posts

    Finally, finished this quest after 40 days or so waiting on it to be fixed. The only positive thing is that this game teaches me to be patient, very patient. Now get your act together Ubisoft and fix the other trillion bugs. Ow yeah, parkour in this game is [censored] too, what the hell is going on with these letters you have to chase. Sometimes they outfly you even if you are chasing it at maximum speed, certainly at tamworth fortress

  • longjohn119
    609 posts

    @dark-coco

    The problem isn't the game itself, it's the Connect App breaking the saves when it does an auto save to the Cloud ..... It's not marking an event/milestone as completed in the save file where all that data is stored ..... If the event isn't registered as completed in the Save then the game has no clue that it has been completed ....

Suggested Topics

Community Details

73
Online
191.9k
Users
32.2k
Topics
161.6k
Posts