Welcome to discussions

Quick Suggestions

  • DirtySwaggEr93
    25 posts

    Has anyone uninstalled then re-installed ?

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • imiboz
    2 posts

    Same problem here: Talked to Ragnar's sons in the tend, Ubba left saying to meet up at the pier, initially I had a boat stuck in the middle of the horses and can't talk to Ubba, then I decided to dedicate some time to other things and return later.

    So I did, when I returned the boat wasn't stuck on earth anymore, and a cutscene started with Ivarr and a kid. After the cutscene I still need to speak to Ubba in order to go on with the task but I can't speak with him, so I'm stuck and can't go on.

    I'be tried to change my alliance decision, choosing Lunden instead of Ragnar's sons, and then I immediately choose Ragnar's sons again: it didn't work.

    I guess we have to wait for a fix...

  • ripley1408
    3 posts

    Also tried everything on this thread with the exception of deleting game and then redownloading. I'll guess I'll give an update, but I doubt it. I literally tried everything else, exited animus, repledged TWICE, went to Norway and the other new place. The option to speak to Ubba just isn't there.

  • Jublet_inc
    3 posts

    Quest stuck as can't talk to Ubba, a boat is currently in the middle of the road also. No way to jump restart quest, seems a lot of people have the same issue.

  • tystarkey
    1 posts

    Same issue @jublet_inc

  • Issaph9399
    2 posts

    I cant interact with Ubba in sons of ragnar . He stays on the shore and doesnt get on the horse. I have seen many people with this issue and yet Ubisoft hasnt even aknowledge the bug itself.

  • Talant616
    2 posts

    I'm seeing the same issue as others in this thread. Playing on PS4. I got the cutscene where you meet the heir, but I'm unable to progress further. When I travel back and forth from Norway, the location of the longship changes (sometimes on land sometimes on the water), but otherwise no progress.

  • broyak
    8 posts

    It’s absurd that soo many people are having this problem and still 4 freaking days later nothing from Ubisoft other than “Welp try to load an older save”.

  • Recon4thCav
    31 posts

    Having same issue. Tried everything. Nothing works. 50 hours in. No way I'm restarting. Please fix this soon or you will lose a customer.

  • Crombinator73
    8 posts

    So far I have tried:

    1. Re-pledging alliance - works to resolve Ubba not having a quest symbol, but then there is a boat in the road
    2. When it happened I had just had the bug where a number of old saves were over-written, and so had a choice between the quest and losing 8 more hours of exploring
    3. Exit to Animus and back - again in cases where Ubba does not even have the quest icon this will load it properly, but usually when that happens the boat is not in the road. Doing this only results in the boat in the road, a quest icon, but no option to speak to Ubba
    4. Loading back to Norway, and back. The first time I did this I also took the time to 100% Rygjafylke, and just to be thorough (and to prove the person who posted like 20 times just to load to Norway and back to fix it that this did not work):
      1. Loading back resulted in no change except a boat in the road
      2. Went back to Raventhorpe, loaded to Norway, and immediately went back then:
        1. Fast travelled to Repton, had the quest icon, boat in road
        2. Took the river to Repton, no question icon, no boat in road
    5. Noticed that Ubba was right on the load line between the outside of the city and Repton, proceeded to bounce him out (either by running into him or hitting him with my horse). This resulted in:
      1. A number of groups who were not pathing right began to move beside the boat
      2. A horse got stuck. Killing it allowed more groups to clear past
      3. Ubba kept returning to the same spot faster than any attempts to speak with him
    6. Tried moving all boats in the harbour around to see if I could get the boat in the road to properly load in the river

    None of this made any difference, I think the closest I got was a brief appearance of a 'Y' over Ubba's head when I somehow managed to smack him good with my horse. Since then I have not been able to make him move far enough, and he always goes back to the same spot.

    At this point I have basically stopped progressing the storyline except to upgrade my settlement, and work completing all of the items / side quests that match with my current level. It would be really nice if we could get a timeline on when they might have a patch applied to resolve this issue.

    I skimmed this thread, but did not open all of them to see if anyone had come up with any other possible workarounds. For all of the minor glitches reloading to the Animus and back always fixes it. I think the issue for me is I decided to grind out a few more levels before I came back to finish this fight, but funny thing is I see a number of people mentioning that they had gone to finish the Berserker quest line. That is the same quest I was working on when my game crashed right, and I lost my save data right before these issues started with this quest. They may not be related, but.. maybe?

    Playing on an Xbox One.

  • guest-NLRGkGSG
    1 posts

    I cannot further my progression. I am suppose to speak to Ebba, but the game does not allow me to do so. The objective cursor is above Ebbas head, but I cannot select to talk with him. You're suppose to talk with him on the shoreline; and that
    also has bugs. Sometimes the boats are randomly on the shoreline; they're upside down and filled with people. Something is off. Any help would be appreciated

  • Petteflet88
    346 posts

    @broyak indeed. And they still expect us to be invested. This is absurd...

  • Petteflet88
    346 posts

    @crombinator73 nice... i tried almost all you tried. I also meditated, set him on fire and did not fast travel from settlement but ride to it... nothing worked.

  • guest-9SadcwiF
    3 posts

    Same issue...

  • balthazar0210
    3 posts

    @jublet_inc same issue. Stuck for a day now with over 20 hours in. Tried everything to get it to work apart from reinstall...Ubisoft when is this fixed ?

  • balthazar0210
    3 posts
  • Xl_H3llFlR3_lX
    2 posts

    The sons of Ragnar broken not alot more to say than ffs this happens every single time with assassin creed games for me !!!
    Do you actually get people to test the game anymore !!!!

  • Kartza88
    1 posts

    @jublet_inc same here

  • Crombinator73
    8 posts

    @petteflet88 wait, forgot that I also killed everyone in the fort we would be fighting. At least I think it was everyone. Didn't scan for stragglers!

  • guest-9SadcwiF
    3 posts

    @balthazar0210 I went out of the simulation and got back in and it actually changed... No, no, it doesn't work, but now there's a boat in the middle of the road, that's great 👌

Suggested Topics

Community Details