ubisoft discussions

Quick Suggestions

  • Dark-Coco
    17 posts

    Serious question and suggestion, but where do I go to ask for a refund or discount? Can I do that? If so, I suggest others do the same. I'm often respectful when it comes to mistakes, but people have paid for a product that does not work properly, with no word. This year has been tough, I get that, but why release a product that doesn't function properly?

    I parted with £60 of my money, and I don't have a lot of money, but I was looking forward to a viking setting, have done for some time, but this has really just dampened my experience on it all. I don't understand... why not delay it like Cyberpunk did? People were [censored] that it got delayed, but I didn't mind, partially because so many titles were coming out that I wanted. Like Valhalla. Plus, I'd rather wait for a product with better tweeks than a broken mess.

    I just think right now that Ubisoft need to understand that this is not okay. I'd rather have my money back for a while, or at least part of it. This is like paying for early access but you're not allowed in early.

  • DirtySwaggEr93
    25 posts

    @dark-coco agreed 100%

  • DirtySwaggEr93
    25 posts

    @ubi-woofer update on sons of ragnar quest would be nice. You know... weve only been waiting a week

  • Petteflet88
    348 posts

    @dark-coco 100% agreed

  • crewchief00206
    13 posts

    Did you end up getting past this part? I just got here myself and can't get anyone to open the door for me. I'm [censored]!

  • broyak
    8 posts

    A week in and STILL no fix to this damn bug. Not even an update on maybe an ETA of when this damn issue is gonna be resolved.

  • Ubi-Spud
    Ubisoft Support Staff 703 posts

    Hey there! I'm really sorry that you are unable to progress past this point. Can you confirm that you are on PS5? Does fast travelling elsewhere and coming back help at all? If not, you may need to try reinstalling the game.

    Official Response
  • chfb271990
    7 posts

    They've treated us to the perfect Viking experience. Taken our money and pretty much left us to pick up the pieces.

  • lynx33161
    1 posts

    Same issue. Ubisoft, is there an eta on a fix for this?

  • Jenga187
    1 posts

    Same problem here, can't talk with Ubba to do Son's of Ragnar mission. Been stuck here for almost 3 days now. Have done everything everyone suggested and nothing works. Been traveling around the countryside collecting crap killing time hoping for an update from Ubisoft. Now about 30hrs into and just hate the idea of restarting the game. PLEASE send a patch and fix the game.

  • DarkVeil1
    1 posts

    I was having the same issues. First the marker wouldn't even show for me. When it finally did, the boat was in the road which caused them to get stuck. I loaded the save right before I talked to Ubba and before I talked to him again, I moved the horses to the other side of the boat and headed to the next quest marker. Worked for me.

  • amber2403
    2 posts

    I'm not sure if this has been mentioned yet. But I was seeing a similar bug with this quest, where the quest marker didn't appear on the map even if I had the quest selected. I also couldn't find/see Ubba to even see if I could talk to him. This happened, I think, because I fast traveled back to Ravensthorpe to do some upgrades after talking with Ivaar but before speaking with Ubba.

    I tried a suggested fix to change your pledge to a different region and the re-pledge Ledecestrescire. That didn't work for me. The icon would still not appear on the map. And I could still not find Ubba. So then I tried exiting the animus entirely, then re-entering it. After going back into the animus and loading up Eivor, I saw that the quest icon was showing again. I could then find Ubba, speak to him and then proceed with the quest. Thought I'd post this here in case anyone else wanted to see if this would help them as well.

  • amber2403
    2 posts

    @amber2403 I wanted to add that I didn't personally have any issues with the NPCs mounting their horses and proceeding to the next location of the quest. So not sure this will help those individuals. But it might help those who are not able to speak to Ubba at all? Not sure. But either way, wanted to post a fix that worked for me for others to test as well.

  • Petteflet88
    348 posts

    A week... a week with a gamebreaking bug. This is almost hilarious.

  • CarolTeixeiraL
    3 posts

    After talking to Ubba I chose "Already worried about a sucessor?" After that the quest won't continue.

  • Assassin6912
    1 posts

    The animation to speak to Ubba is not there preventing me from continuing story I fast traveled and came back still nothing ended up finished Grantebridgescire main story first came back and cant still not speak to Ubba this needs to be fixed.

  • imogengracex
    5 posts

    Yep I also have this glitch. Boat in the road and no option to speak to ubba. Not reinstalling the game as I’ve done so much side stuff probably about 30 hours in already.

  • TruncatedGnu29
    2 posts

    Same issue here. I talk to him once then cut scene and now he just stands there.

  • Belfahl
    14 posts

    Really says something about how serious they take their fans. Especially considering the only sort of acknowledgement is including the link to this thread in another post.

    "Later this month" for a fix.. Why release the game if it isn't playable until later in the month.

  • mbrodrick0329
    5 posts

    I've had the same issue since release, now it has gotten worse with the longboat appearing on the path. I have tried restarting the game, restarting my system, still no luck. I don't wanna try deleting my save file and starting over because with a previous glitch that didn't really solve anything.

    Hopefully a patch comes through soon because I've just been sitting and waiting to play the game because I cannot progress

Suggested Topics