Welcome to discussions

Quick Suggestions

  • EmoKid199387
    19 posts

    Still notta after uninstalling and reinstalling. I dont want to start over either I've read in some places that starting over doesn't help either I'm 62 hrs in power 210 and my settlement is at level 5 I just want this fixed but seems ubisoft just doesn't care. On another note has anyone else had problems finding the zealot cola

  • sorsici
    1 posts

    Same 😞 (ps4)

  • Fgjffcg5
    1 posts

    Sort it out! Can't believe you muppets had the gall to release this.


  • SLXW75
    13 posts

    U have to patch this ubisoft... 11 days please...

  • Rinadon93
    14 posts

    @slxw75 ive requested for a refund. Fingers crossed.

  • Petteflet88
    346 posts

    Yeah, I think I am also going for a refund. Also for the season pass. It is 11 days nows and I am done... waited long enough.

  • Jublet_inc
    3 posts

    Now officially done every other allegiance mission, not seen my brother for over 40 hours game time.. Killed most the legendary animals, got Excalibur... This power level 20 mission is going to get DESTROYED (when it's finally fixed)

    It wouldn't be so bad if the reward was like supplies or silver, but it's camp extension....

  • Petteflet88
    346 posts

    @jublet_inc is there a brother? After 50 house of just collecting treasures etc. The story left my memory. Not invested anymore. Great game, last AC i ever play

  • Mcnair17
    2 posts

    i fast travelled to the docks to speak to Ubba to continue the mission. i hear the sound of rain and once i step off the dock the sound is gone, the sun is out and there is a whole ship on land and Ubba doesnt give the option to speak yet has a quest symbol above his head...half the time. i have logged out multiple times yet the bug doesnt seem to fix itself, i have also tried playing online and offline.

  • York_of_Diego
    2 posts

    Dealing with the same issue. I go to talk to Ubba and he doesn't respond. Just stands by his horse as a mute. Please fix this UbiSoft.

  • York_of_Diego
    2 posts
    This post is deleted!
  • Recon4thCav
    31 posts

    Such a waste. Been waiting for over a week. Last Ubisoft game I'll buy. You do not care about your customers, so I won't care if you lose your jobs.

  • EmoKid199387
    19 posts

    Some freaking bs I've done everything needs done from Lunden to jorvik but still cant continue with the freaking mission damnit they need to pull there heads out there butts and start fixing the damn game

  • revforlife
    12 posts

    It would be nice to get a bit of an update on this issue, as well as the many others listed in the known issues section. I have checked the patch notes for updates 1.04 and 1.05 and there does not seem to be any indication that these main quest problems are being addressed. It’s one thing to be a simple glitch that affects a small aspect of gameplay, but to be one that prevents the advancing of the storyline is an incredible disappointment.

  • Heathen45
    3 posts

    Stuck can't talk to ubba they wont mount horses tried everything and cant go back to a previous save before I talked to him

  • unicornbrains08
    2 posts

    During the Sons of Ragnar story quest, there is a bug that presents itself when the objective for this quest tells me to speak with Ubba. No interact prompt shows up when I meet with him in Repton and I have been stuck on this for about a week now and I haven't made any progression in the main story. I have tried everything from restarting the game to reinstalling it multiple times.

  • markourparkour
    3 posts

    @lynx33161 I don’t think Ubisoft is watching their own discussions page

  • Lika_wa
    3 posts

    I have the same problem on my PS4. This is a joke, thought it was important to please your players and have the main quest playable. It's the core of the game, really don't understand how it can take days or weeks to fix?

  • Mikemitch840
    1 posts

    Same issue on xbox one and pc, have even restarted the story, uninstalled and reinstalled, still nothing, please fix this, I've kinda run out of things that I can do according to my power level.

  • ST33L_T4L0N
    1 posts

    This is still an issue for me too. Longship in the road sometimes and sometimes there’s a marker above Ubba’s head and I’m never able to speak to him so main story is broken.

    Tried everything I’ve read on here, still an issue. I will not be restarting, it will either be fixed or I will be returning the game.

    Thoroughly disappointed.

Suggested Topics

Community Details

114
Online
196.9k
Users
33.4k
Topics
167.0k
Posts