ubisoft discussions

Quick Suggestions

  • cptkalifornia
    3 posts

    @janniechka doesnt work here

  • Petteflet88
    346 posts

    It only works in specific orders... but for the most it wont work. Or you can restart and loose all progress made. Which is a big no.

  • deckyramsey
    1 posts

    @janniechka Worked first time, I lost 6 hours of data but nothing too bad. Thanks!

  • janniechka
    2 posts

    @deckyramsey that's great! I lost about 3h but now I do not want to redo them

  • EmoKid199387
    19 posts

    Still no ETA time for when this is gonna be fixed kinda sucky. Oh well just gotta wait I guess.

  • Morkelpet37
    3 posts


    Not even mentioned in their next patch notes, asked for a refund too... Sick of it! 😞

  • DeaconSly29
    1 posts

    Xbox user
    I have the same issue with long boat in the road. I have tried fast traveling and back going to Norway and back, sometimes the long boat is not in the road. I have tried waiting for night nothing for changes cant speak to Ubba. Anyone hear of a patch to rectify this because i am not deleting my 30+ hours of game time just to fix this

  • imiboz
    2 posts

    Guys, try to load the game, go offline and speak to Ubba.. does it work for you? An user from twitter told me it worked for him and I have just deleted my 80+ hours gameplay to restart from the beginning.. if this works, I'm gonna kill somebody (jj)

  • Awesomefruit6
    4 posts

    The quest "sons of ragnar" has been glitched ever since I got the game whenever it says "talk to ubba" it will not allow me and sometimes won't even show up on the map. The boat that's also supposed to be in the water glitches on to land. Please fix this problem it has been here for a while and is getting frustrating.

  • SteampunkZapper
    12 posts

    SAME. Got to where the young man walk away, boat in the road, reload and boat is gone but Ubba just stands there like an idiot. Also - ALL my saves rewrite with whatever my current save is. I've even deleted the game, reinstalled an downloaded just my profile and most recent save but it always populates all the saves.

  • Habs-30
    1 posts

    Originalement l’icône indiquant le lieu de la rencontre n’était pas là. En lisant sur ce but, certaines personnes mentionnaient que le fait de sortir de l’animiste et de retourner dans le jeu pouvait régler le but.

    Lors de mon retour l’icône s’y trouvait, mais rien ne se passe. Comment régler ce bug?


  • benleatherman
    2 posts
    This post is deleted!
  • benleatherman
    2 posts

    Ubba seems to be glitching when you explore Tamworth Fortress in the middle of his quest line. All of the NPCs spawned around the battlefield between TW Fortress and the war camp think that there's been a victory (cheering and standing around doing nothing).

    The NPCs in Repton including Ubba and Sigurd are probably stuck in that loop as well. Both are on the map in between the cutscenes with Ceowolf's son and the horses/longboats. Ubba's map marker has disappeared, and even when you have the quest selected in the menu the HUD in-game prompts you to select another quest.

    I did get stuck with the longboat on land. Travelling to Norway reset those spawn locations, but the quest was still broken. Pledging another territory (and completing it) and coming back does not reset the Ubba error.

    (Download Version on Xbox 1)

  • revforlife
    12 posts

    Looking at the mega thread of quest issues that involve an inability to proceed, how in the world did this game go “gold”? This particular issue was first posted on Nov. 11. It is now Nov. 25, and there is no answer in sight that I can see. You have indicated that our patience is appreciated, Ubi, but a bit of an explanation and update would go a long way toward reducing, perhaps, the number of refund requests you are sure to receive at this stage of the mess.

  • RTA3000
    1 posts

    @benleatherman this sounds like a great explanation. I just wish Ubisoft would pay attention to posts like these and actually fix it!

  • guest-7OXsteWH
    17 posts

    This is rediculous. I have collected everything there is to collect. Reached powerlevel 360 and all I can now do is wait until I can complete a powerlevel 20 quest and finally continue the game...
    This is such an amateur move on your part, Ubisoft. Your staff probably won't even read this but in case that they do, atleast give us an update instead of turning on the game everyday and seeing if a patch was brought out...

  • Tjaco
    2 posts

    Same here

  • Tjaco
    2 posts

    same problem here

  • connorcovbadboy
    2 posts

    @guest-7oxstewh It's honestly a joke I've done everything in leicstershite and grantebridgeshire now gone back to Norway to finish everything there hopefully this all gets fixed £92 for an incomplete game

  • MolodoyRoze
    2 posts

    The game was made by the delitants. I have the same problem. Get your money back for this fake. Give low marks to a game that has the same gaps, otherwise it will drag on forever.

Suggested Topics