Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Morkelpet37
    3 posts

    @progamerzlolz

    Not even mentioned in their next patch notes, asked for a refund too... Sick of it! 😞

  • Ubi-Borealis
    Ubisoft Support Staff 2029 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • DeaconSly29
    1 posts

    Xbox user
    I have the same issue with long boat in the road. I have tried fast traveling and back going to Norway and back, sometimes the long boat is not in the road. I have tried waiting for night nothing for changes cant speak to Ubba. Anyone hear of a patch to rectify this because i am not deleting my 30+ hours of game time just to fix this

  • imiboz
    2 posts

    Guys, try to load the game, go offline and speak to Ubba.. does it work for you? An user from twitter told me it worked for him and I have just deleted my 80+ hours gameplay to restart from the beginning.. if this works, I'm gonna kill somebody (jj)

  • Awesomefruit6
    4 posts

    The quest "sons of ragnar" has been glitched ever since I got the game whenever it says "talk to ubba" it will not allow me and sometimes won't even show up on the map. The boat that's also supposed to be in the water glitches on to land. Please fix this problem it has been here for a while and is getting frustrating.

  • SteampunkZapper
    12 posts

    SAME. Got to where the young man walk away, boat in the road, reload and boat is gone but Ubba just stands there like an idiot. Also - ALL my saves rewrite with whatever my current save is. I've even deleted the game, reinstalled an downloaded just my profile and most recent save but it always populates all the saves.

  • benleatherman
    2 posts
    This post is deleted!
  • benleatherman
    2 posts

    @UbiExcellent
    Ubba seems to be glitching when you explore Tamworth Fortress in the middle of his quest line. All of the NPCs spawned around the battlefield between TW Fortress and the war camp think that there's been a victory (cheering and standing around doing nothing).

    The NPCs in Repton including Ubba and Sigurd are probably stuck in that loop as well. Both are on the map in between the cutscenes with Ceowolf's son and the horses/longboats. Ubba's map marker has disappeared, and even when you have the quest selected in the menu the HUD in-game prompts you to select another quest.

    I did get stuck with the longboat on land. Travelling to Norway reset those spawn locations, but the quest was still broken. Pledging another territory (and completing it) and coming back does not reset the Ubba error.

    (Download Version on Xbox 1)

  • revforlife
    12 posts

    Looking at the mega thread of quest issues that involve an inability to proceed, how in the world did this game go “gold”? This particular issue was first posted on Nov. 11. It is now Nov. 25, and there is no answer in sight that I can see. You have indicated that our patience is appreciated, Ubi, but a bit of an explanation and update would go a long way toward reducing, perhaps, the number of refund requests you are sure to receive at this stage of the mess.

  • RTA3000
    1 posts

    @benleatherman this sounds like a great explanation. I just wish Ubisoft would pay attention to posts like these and actually fix it!

  • guest-7OXsteWH
    17 posts

    This is rediculous. I have collected everything there is to collect. Reached powerlevel 360 and all I can now do is wait until I can complete a powerlevel 20 quest and finally continue the game...
    This is such an amateur move on your part, Ubisoft. Your staff probably won't even read this but in case that they do, atleast give us an update instead of turning on the game everyday and seeing if a patch was brought out...

  • Tjaco
    2 posts

    Same here

  • Tjaco
    2 posts

    same problem here

  • connorcovbadboy
    2 posts

    @guest-7oxstewh It's honestly a joke I've done everything in leicster[censored] and grantebridgeshire now gone back to Norway to finish everything there hopefully this all gets fixed £92 for an incomplete game

  • MolodoyRoze
    2 posts

    The game was made by the delitants. I have the same problem. Get your money back for this fake. Give low marks to a game that has the same gaps, otherwise it will drag on forever.

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone, please accept my apologies for the delayed update to this thread. Thank you for your continued reports of issues with "The Sons of Ragnar", and for sharing your insight and workarounds with each other. I am sorry to hear that for many of you, it is still not possible to speak to Ubba, or else that after doing so you're unable to proceed to the Tamworth raid due to an obstruction in the road or the water.

    The development team continue to investigate these issues and have asked that we collect further save files from affected players for them to analyse. PC and PS4 players are able to submit their save files to us by opening a support case or starting a Live Chat, and then following these instructions. Players on Xbox One or Xbox Series X|S, unfortunately it isn't possible for you to submit your save files, however you can still help us by providing any videos of the issue(s) that you can, including any helpful details that could be relevant, including which quests you completed prior, or if anything unusual happened that may be linked to the issue.

    A few workarounds that players have reported to us / mentioned in the thread so far are below - please let me know if any of these help you to continue in the meantime while the investigation continues:

    • Reload a previous save game prior to the start of the questline, and play through it again
    • Create a save in a secondary/other save slot, and reload this save
    • Open the game while offline and try to continue in the quest
    • Fast travel to Norway, then return to England, and try again to speak to Ubba / follow him to Tamworth


    Thank you all for your patience and understanding while we continue to look into this. I fully appreciate that this bug is preventing progress, and I'd like to reassure you all that the developers are working hard to reproduce the issue and find a fix as soon as they can.

    Official Response
  • EmoKid199387
    19 posts

    @ubi-woofer I've done all you've said but do you got a ETA time of when it will be fixed or is that still up in the air

  • Petteflet88
    346 posts

    @ubi-woofer really sorry man but this answer has been given 8 days ago. The issue is now 2 weeks open (issued on nov. 11). This is just too long... i stopped playing and asked for refund. For an AAA title with such a big team behind it, you are asking for way too much patience without communication.

    Reproducing is not hard. If you read, the People who have this issue started the quest and went treasure hunting. The people who do not have the issue immediately go forward with the mission. Thats it... so the dev team can start the mission, go treasure hunting, come back and have the bug.

    Anyway. It will be silent now for another 10 days so I am out of here! Thank you.

  • Fernatius
    32 posts

    @ubi-woofer non of these work for some people and doin other stuff has made some unable to get to the point before this. If the marker doesn't show on the map the boat is also not on the road and if the marker shows the boat is on the road or at least that on my case, it even came as far as that the horses are now squashed and death 😕

  • DHangelfan16
    24 posts

    @ubi-woofer I made a ticket!

    Do you wanna know what they told me?!

    That I might have a defective PS4 or product! And go try another disk!

    You people literally tried to tell me to buy another broken copy of your game!

    That's what your support said! What a joke! What an absolute insult!

    I'm actually offended, and quite frankly, angry that you guys don't just acknowledge it's a bug.

    Buy another copy of the game? It'll be a cold day in hell before I buy another AC game ever!

    How do you guys sleep at night? I'm curious.

  • jadelson
    2 posts

    @ubiexcellent So ten days after your post, no mention of when this is likely to be fixed? Can it really be THAT hard to get a patch out for a specific story-killing bug like this? Maybe next time don't release the game until after Christmas.

Suggested Topics

Community Details

41
Online
129.3k
Users
22.3k
Topics
115.6k
Posts