ubisoft discussions

Quick Suggestions

  • anxietycrossing
    1334 posts

    Hello everyone, please accept my apologies for the delayed update to this thread. Thank you for your continued reports of issues with "The Sons of Ragnar", and for sharing your insight and workarounds with each other. I am sorry to hear that for many of you, it is still not possible to speak to Ubba, or else that after doing so you're unable to proceed to the Tamworth raid due to an obstruction in the road or the water.

    The development team continue to investigate these issues and have asked that we collect further save files from affected players for them to analyse. PC and PS4 players are able to submit their save files to us by opening a support case or starting a Live Chat, and then following these instructions. Players on Xbox One or Xbox Series X|S, unfortunately it isn't possible for you to submit your save files, however you can still help us by providing any videos of the issue(s) that you can, including any helpful details that could be relevant, including which quests you completed prior, or if anything unusual happened that may be linked to the issue.

    A few workarounds that players have reported to us / mentioned in the thread so far are below - please let me know if any of these help you to continue in the meantime while the investigation continues:

    • Reload a previous save game prior to the start of the questline, and play through it again
    • Create a save in a secondary/other save slot, and reload this save
    • Open the game while offline and try to continue in the quest
    • Fast travel to Norway, then return to England, and try again to speak to Ubba / follow him to Tamworth

    Thank you all for your patience and understanding while we continue to look into this. I fully appreciate that this bug is preventing progress, and I'd like to reassure you all that the developers are working hard to reproduce the issue and find a fix as soon as they can.

  • EmoKid199387
    19 posts

    @ubi-woofer I've done all you've said but do you got a ETA time of when it will be fixed or is that still up in the air

  • Petteflet88
    346 posts

    @ubi-woofer really sorry man but this answer has been given 8 days ago. The issue is now 2 weeks open (issued on nov. 11). This is just too long... i stopped playing and asked for refund. For an AAA title with such a big team behind it, you are asking for way too much patience without communication.

    Reproducing is not hard. If you read, the People who have this issue started the quest and went treasure hunting. The people who do not have the issue immediately go forward with the mission. Thats it... so the dev team can start the mission, go treasure hunting, come back and have the bug.

    Anyway. It will be silent now for another 10 days so I am out of here! Thank you.

  • Fernatius
    32 posts

    @ubi-woofer non of these work for some people and doin other stuff has made some unable to get to the point before this. If the marker doesn't show on the map the boat is also not on the road and if the marker shows the boat is on the road or at least that on my case, it even came as far as that the horses are now squashed and death 😕

  • DHangelfan16
    24 posts

    @ubi-woofer I made a ticket!

    Do you wanna know what they told me?!

    That I might have a defective PS4 or product! And go try another disk!

    You people literally tried to tell me to buy another broken copy of your game!

    That's what your support said! What a joke! What an absolute insult!

    I'm actually offended, and quite frankly, angry that you guys don't just acknowledge it's a bug.

    Buy another copy of the game? It'll be a cold day in hell before I buy another AC game ever!

    How do you guys sleep at night? I'm curious.

  • jadelson
    2 posts

    @ubiexcellent So ten days after your post, no mention of when this is likely to be fixed? Can it really be THAT hard to get a patch out for a specific story-killing bug like this? Maybe next time don't release the game until after Christmas.

  • jadelson
    2 posts

    @dhangelfan16 I'm glad they never responded to my ticket. In fairness, I was immensely sarcastic and unpleasant when I filed it, which is exactly what these imbeciles deserve.

  • Agony567
    16 posts

    @ubi-woofer I speak with Ubba but on the fort my game crashes after cinematic,freeze and crash.

    For how long they are investigating come on 20 days,you are big company to allow this to happen is disgrace

  • Recon4thCav
    31 posts

    @ubi-woofer go F yourself. 20+ days and this is still Ubisoft's response? I'll never buy another Ubisoft game again. I hope you all get fired.

  • CashlessCobra28
    3 posts

    I got tired of waiting for support. Their long list of things to try (change resolution, reinstall, clear cache, different disc, different console) were either not helpful or not possible. I started over and was able to complete the Sons of Ragnar quest without any issues. But I had over 60 hours in my original game so I’m hoping that the patch coming tomorrow will fix it and I can continue without having to replay 40-50 hours to catch up to where I was

  • Petteflet88
    346 posts

    Forget it, will be another 10 days. Just see those 50 hours as lost.

  • Curunir07
    1 posts

    My "Speak to Ubba" marker does not appear on the map; after I talk to him, they just stand there and nothing happens.

  • revforlife
    12 posts

    Unfortunately, this response does little to help, and the recommendations listed have already been tried....for days. The idea of loading a saved game prior to the issue means, for some us, losing too much progress to make it worth the effort. With as many people on this thread, it would seem your Game team could just play a retail copy of the game on any platform and the chances are exceptionally good that one of them will reproduce the issue for you. As I said in a previous post, it’s hard for me to see how a gold-master game contains so many main-quest-breaking bugs. I know your team is working on it, but it’s frustrating to be stuck so early into the game with little to do but treasure hunt and hope, beyond hope, for a patch that doesn’t seem to be any closer to release. I enjoy this series too much to ask for a refund....just needed to rant.

  • EmoKid199387
    19 posts

    Just saw that the update 1.04 comes out tomorrow idk if true

  • MooseNuugle
    22 posts

    So since I have Xbox one and bought their trash game on (Sorry, rephrase I didn’t buy it my girlfriend who is on unemployment because of COVID bought it for my birthday with what little she has. Knowing I’ve been so excited and waiting for it.) digital copy then that fault is on Xbox too?! This is ridiculous I have never played a game with as many bugs as this and the patches they have put out only fix dumb [censored] like sound effects and graying out the sell all trinket button once all trinkets are sold....ya know because those are priorities over story breaking bugs. At least cyberpunk is making sure they put out a good product and not just pumping out garbage to release on the same day as new consoles. Scam artist and I loved every thing Ubisoft did up until this.

  • guest-EGoq4TWH
    2 posts

    Same type of bug is happening with me on the quest Sons of Ragnar Chapter 1. It wont track on the map and wont let me interact with any of the characters.

  • guest-EGoq4TWH
    2 posts

    Im experiencing this type of bug with the quest Sons of Ragnar Chapter 1. Quest will not track on the map and wont let me interact with the characters in said quest. Weird thing is I had this quest tracked yesterday and started it. Now today it is gone but the characters are there like they are waiting for me to interact with them but I am unable to. System is Xbox One.

  • Rinadon93
    14 posts

    @ubi-woofer so over 2 weeks later theres nothing you have done about it. Wanting us to send you evidence basically? Do ubisoft not use twitter? Or do they just ignore people for fun because the amount of people send you videos of this is ridiculous. And now exspect us to go to another save? Might aswell of told us to [censored] off and laugh in our faces. Last ubisoft piece of broken crap im ever paying for again. Roll on cyber punk and cd projekt.

  • Petteflet88
    346 posts

    Hahahaha, guess what. 1.04 installed, did not fix the bug. F YOU Ubisoft. Worst release ever, 2 weeks later and still stuck. I dont understand this how you screw your fans.

  • Ner0Infern0
    14 posts


    Are you [censored] kidding me Ubisoft isnt it? I won’t start a new game, i have over 65hrs accumulated in this save.

    On top of that the legendary trophies are still broken and won’t display in the longhouse, and the [censored] petra’s father keep telling me the same things over and over about how i went and killed the [censored] white deer with his bitchass daughter.


Suggested Topics