Welcome to discussions

Quick Suggestions

  • SLXW75
    13 posts

    @nightiie Tout dépend de l’édition que t’a pris mais là c’est révoltant

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • Chriswvu99
    2 posts

    This infuriates me so much that I created an account just to [censored] at Ubisoft. I can’t believe as many people have complained about this bug, not being able to speak to Ubba in the Sons of Ragnar mission, that you haven’t done anything to address it. I woke up this morning hoping 1.04 would fix it......but you failed miserably

  • PhaeoGy
    1 posts

    @chriswvu99 Me too.
    Even I finished next other quest then take it again ,still can't talk with Ubba.

  • Petteflet88
    346 posts

    @chriswvu99 same here... 15 days now.

  • Petteflet88
    346 posts
    This post is deleted!
  • Kratos3989
    4 posts

    The sons of ragnar quest isstill not working, even after this new update.

  • Nicotaco87
    24 posts

    I've heared there is a new update...any one got it already. And did it fixed thé quest?

  • Fernatius
    32 posts

    @nicotaco87 nope they have not done much about the big game breaking bugs it seems

  • Petteflet88
    346 posts

    @nicotaco87 you mean 1.04? Did not fix anything.

  • BlitzBStone
    7 posts

    So I downloaded the patch, I’ve cleared my cache on my console, I’ve closed and reloaded the game and yet Ubba does not progress the quest. My objective still says to talk to him. I did that. I watched the cutscene with the kings dumb kid. I’ve still got a longboat parked on the road and a NECESSARY QUEST that can’t be completed. I do not have a previous save file that I can go back to because like many others I worked other quests and collected wealth and artifacts to pass the time until a patch was released. Now I’m outside of the realm of a refund, I’ve got just under 90 hours into a play through, and the only potentially viable solution is to start over and hope it doesn’t glitch out again. What did you actually fix? I want to see legit patch notes to see what missions were given higher priority than the main missions.

  • Fernatius
    32 posts

    @petteflet88 this is why people who want the game asap should not be allowed to play any games and just let the devs have their extra time to work on the game and delay the release date 😉

  • Petteflet88
    346 posts

    @fernatius agree. I rather have waited for 2 more weeks then this garbage

  • Chriswvu99
    2 posts

    @ubi-woofer let me echo another's thougths.....GO [censored] YOURSELF

  • Petteflet88
    346 posts

    @chriswvu99 yes. Exactly.

  • DanteKingM.O.W
    4 posts

    So last night i decided to restart the game. I flew through to get to the Sons of Ragnar mission and was able to complete it. After raiding with ivar before completing the quest, i tried to load my first manual save which i was level 138 and had about 60 hours of game play. Well needless to say i didnt exit ths animus fully and when i loaded my first manual save, it copied the game i was currently on and now i lost my first save. I was able to complete sons of ragnar but now i have to basically start from scratch!!!! One mad dude right now!

  • Ner0Infern0
    14 posts

    Just release an hotfix that will reset the mission for everybody and then work for a proper fix! We don’t want to wait anymore.

  • BlitzBStone
    7 posts


    this is a way better solution than they could come up with on their own

  • Petteflet88
    346 posts

    @blitzbstone best solution ever

  • guest-VQnBB6Mo
    3 posts

    I must say it's astonishing how unprofessional Ubisoft is. Next to none communication with the community. Updates that fix nothing. And we even can't contact support?! Yesterday it was suggesting contact via chat that that didn't work and now the site is crashed.

    So maybe you should create a thread about getting our money back? We've paid for full game, not some short demo.

    This is the last Ubisoft game I've ever purchased. It's not because of the failing game, [censored] happens, bugs can occur in best games (but you should definitely fire all testing team). It's because how you're treating people, that paid for the game.

  • Agony567
    16 posts

    Okay i make it Work this worked for me a Solution and i finish the quest,i use PC.

    Uninstall the game and delete everything from folder,and i download all 51 GB again,all my save's was there cuz they are on Cloud.
    I just continue infront of the Tamensworth fort,watched cinematic and no freeze and no crash,i Finished thank to God.

    I hope this will help to others same as me,becouse this Ubisoft will do nothing

Suggested Topics

Community Details